2 Replies Latest reply on Mar 21, 2020 5:39 AM by Avi Miller-Oracle

    yum upgrade as of 2020-03-20

    Beremour

      today's  yum upgrade gives:

       

      --> Finished Dependency Resolution

      Error: Package: boost-regex-1.53.0-27.el7.x86_64 (@ol7_latest)

                 Requires: libicui18n.so.50()(64bit)

                 Removing: libicu-50.2-3.el7.x86_64 (@ol7_latest)

                     libicui18n.so.50()(64bit)

                 Updated By: libicu-50.2-4.el7_7.i686 (ol7_latest)

                     Not found

                 Available: libicu-50.1.2-15.el7.x86_64 (ol7_latest)

                     libicui18n.so.50()(64bit)

                 Available: libicu-50.1.2-17.el7.x86_64 (ol7_latest)

                     libicui18n.so.50()(64bit)

      Error: Package: boost-regex-1.53.0-27.el7.x86_64 (@ol7_latest)

                 Requires: libicudata.so.50()(64bit)

                 Removing: libicu-50.2-3.el7.x86_64 (@ol7_latest)

                     libicudata.so.50()(64bit)

                 Updated By: libicu-50.2-4.el7_7.i686 (ol7_latest)

                     Not found

                 Available: libicu-50.1.2-15.el7.x86_64 (ol7_latest)

                     libicudata.so.50()(64bit)

                 Available: libicu-50.1.2-17.el7.x86_64 (ol7_latest)

                     libicudata.so.50()(64bit)

      Error: Package: boost-regex-1.53.0-27.el7.x86_64 (@ol7_latest)

                 Requires: libicuuc.so.50()(64bit)

                 Removing: libicu-50.2-3.el7.x86_64 (@ol7_latest)

                     libicuuc.so.50()(64bit)

                 Updated By: libicu-50.2-4.el7_7.i686 (ol7_latest)

                     Not found

                 Available: libicu-50.1.2-15.el7.x86_64 (ol7_latest)

                     libicuuc.so.50()(64bit)

                 Available: libicu-50.1.2-17.el7.x86_64 (ol7_latest)

                     libicuuc.so.50()(64bit)

      You could try using --skip-broken to work around the problem

       

      But I can't install this .i686 lib

       

      yum install libicu.i686

      gives

      Error:  Multilib version problems found

       

      Corresponding x86_64 library seems to be exists:

       

      curl -I "https://yum.oracle.com/repo/OracleLinux/OL7/latest/x86_64/getPackage/libicu-50.2-4.el7_7.x86_64.rpm"

      HTTP/1.1 200 OK

      Accept-Ranges: bytes

      ETag: "c649555d1dda1cbb9fa0434cea7adeda:1584662213.31106"

      Last-Modified: Wed, 18 Mar 2020 16:34:59 GMT

      Server: AkamaiNetStorage

      Content-Length: 7202240

      Date: Fri, 20 Mar 2020 18:07:22 GMT

      Connection: keep-alive

      X-Frame-Options: SAMEORIGIN

      Content-Type: application/x-rpm