0 Replies Latest reply on Apr 23, 2020 11:51 AM by Franco Soldera

    apex_export.get_application - truncated output using SQLcl v. 19.4

    Franco Soldera

      I am experiencing a truncation of the latest few line of the export of APEX applications APEX_EXPORT package in SQLcl. It is an intermittent problem that happens when thefile size is around 5-6MB.

      Here is the script that shows the issue in our environment:

       

      DEFINE input_app_id = &1

      set feedback off

      set heading off

      set echo off

      set flush off

      set termout off

      set pagesize 0

      set long 2000000000

      set longchunksize 2000000000

      column output format a4000

      set linesize 4000

      set trimspool on

       

       

      variable contents clob

      variable name varchar2(255)

       

       

      declare

          l_files apex_t_export_files;

      begin

          l_files := apex_export.get_application(p_application_id          => &input_app_id.,

                                                 p_with_date               => true,

         p_with_ir_public_reports  => true,                                         

         p_with_translations       => true,

         p_with_comments           => true,

         p_with_supporting_objects => 'Y');

          :name     := l_files(1).name;

      :contents := l_files(1).contents;

       

      end;

      /

       

       

      col name new_val name

      select :name name from dual;

      spool &name.

      --select :contents contents from dual;

      print :contents

      spool off

       

      When using "print :contents" the output is truncated. If I comment the "print" command out and use "select :contents content from dual;" then I get the full (unbroken) export of the application, but it is slower. I have tried the same script in SQL Developer (also v. 19.4) and it gives the same result.

       

      Meddelelse blev redigeret af: Franco Soldera.