0 Replies Latest reply on May 2, 2020 9:33 PM by berkaysit

    Git or Bitbucket Remote Repository Access Issue: "authentication not supported"

    berkaysit

      Hi everyone,

       

      I'm having trouble connecting to any Git repository from SQL Developer.

       

      I tried for 2 different Git system; a repo in company's Bitbucket and my private Github.com repo.

       

      Step-1: In SQL Developer, I open Team > Git > Clone: Remote Repository window

      Step-2: The text boxes are filled as below:

      Remote: origin

      Repository URL: https://github.com/reponame/MyAppTest.git

      User: username

      Password: ***************

      Step-3: I click NEXT and get the error below:

      Validation Failed: https://username@github.com/reponame/MyAppTest.git : authentication not supported

       

      I search for the error, and found that the term "authentication not supported" is really about the auth method used. (The error message when incorrect User/pass entered is different.)

      I thing SQL Developer uses JGit and doesn't fully support NTLM as auth method. (I saw people faced the same problem in Eclipse).

      I tried to connect using SSH Key, but same error occurred.

       

      SQL Developer Version: 19.4.0.354

      Local JDK In SQL Dev folder:  java version "1.8.0_251" | Java(TM) SE Runtime Environment (build 1.8.0_251-b08) | Java HotSpot(TM) 64-Bit Server VM (build 25.251-b08, mixed mode)

       

      Windows 10 [Version 10.0.18363.778]