1 Reply Latest reply on May 14, 2020 12:01 PM by thatJeffSmith-Oracle

    ORDS upgrade to 19.4 / APEX to 20.1 - Static images no longer showing due to duplication in URI

    TuningGuy

      Database 12.2 in Oracle Cloud

      ORDS installed in CBS (was upgraded from 19.1). Running standalone.

      APEX in PDB (was upgraded from 18.2)

       

      APEX upgrade went fine. No apparent errors.

      ORDS upgrade went fine. No apparent errors. Using identical config as before upgrade. All config verified to remain as was, including standalone, uri mapping, db connection.

       

      After upgrades APP works fine, but all static files are not showing as URI has changed for these files (duplication one one part of URI

       

      "GET /ords/vicasol/vicasol/r/126/files/static/v13/app-icon.css?version=Versi%C3%B3n%201.0 HTTP/1.1" 404

      "GET /ords/vicasol/vicasol/r/126/files/static/v13/logo_vicasol.png HTTP/1.1" 404 16127

      "GET /ords/vicasol/vicasol/r/126/files/static/v13/app-icon.css?version=Versi%C3%B3n%201.0 HTTP/1.1" 404 16127

       

      One thing discovered during troubleshooting:

       

      - when I try to run the reset_image_prefix_con.sql against the CDB - it fails in the called script: reset_image_prefix_core.sql here:

       

      declare

          c_schema constant sys.dba_registry.schema%type := sys.dbms_registry.schema('APEX');

      begin

          execute immediate 'alter session set current_schema='||sys.dbms_assert.enquote_name(c_schema);

      end;

      /

       

      I then ran instead directly against PDB the script: reset_image_prefix.sql and it succeeded, but it did not resolve the issue.

       

      Any help in where to troubleshoot next?

       

      PS! This is a prod environment (and is becoming slightly urgent)

       

      Thanks for any help/support.

       

      Kind regards

      Trond