5 Replies Latest reply on Jun 3, 2020 5:41 PM by Olafur T

    Strange validation bug when upgrading to 19.4.6

    Olafur T

      Hi thatJeffSmith-Oracle

       

      Ran into this strange problem while upgrading. 3 out of 4 instances where upgraded without problem. One simply stopped working, all ORDS services responding with 404.

       

      We ran multiple "java -jar ords.war validate" and they came out with no errors.

      Tried resetting the passwords, checking if password was expired etc.. None of that did anything.

       

      So I moved the ords directory and went through the "java -jar ords.war setup" again, just to start again from scratch.

       

      Ran into this error:

       

      Enter 1 if you want to verify/install Oracle REST Data Services schema or 2 to skip this step [1]:
      Enter the database password for ORDS_PUBLIC_USER:
      Confirm password:
      Retrieving information.
      Error the ORDS_VERSION does not exist.
      

       

      So we started to note down any differences between ORDS_PUBLIC_USER in this database vs the others. Found out that the schema was missing a role that the others had.

       

      So the DBA ran:

      ALTER USER ORDS_PUBLIC_USER DEFAULT ROLE ORDS_RUNTIME_ROLE
      

       

      I ran the ords setup process again without a problem and the services started working again.

       

      Shouldn't the "java -jar ords.war validate" process have picked up that the user was missing a vital role?

       

      Regards

      Olafur