12 Replies Latest reply on Jul 21, 2020 2:33 AM by Madhusudhan. M

    Hyperion Foundation->Deploy to application server failing

    3175164
      • I am trying to configure EPM 11.2 , Configuration of database and common settings was completed.
      • Deploy to application server was failing, that is when i realized I should create infra schemas using RCU (Doc ID 2623890.1) . Updated RCUschema.properties file accordingly
      • Now tried to re-run Deploy to application server. It is failing. Below are some of the errors I see in log file.

       

      wlst_debug.log

      64267: Error creating JarHelper

      64267: Encountered error: D:\Oracle\Middleware\oracle_common\common\templates\wls\epm_blank_11.1.2.2.jar

      64267: Check log for more detail.

      Caused by: com.oracle.cie.domain.script.jython.WLSTException: Error updating domain:

      64267: Error creating JarHelper

       

      configtool.log

      [2020-06-15T14:15:50.242-05:00] [EPMCFG] [WARNING] [EPMCFG-01013] [oracle.EPMCFG] [tid: 37] [ecid: 6786ff4f-ef20-45a8-bb68-7faaddea05be-00000006,0] [SRC_CLASS: com.hyperion.cis.ConfigToolDocument] Failed to parse Relation Storage Configuration task priority: priority = null

       

      Also

      Caused by: java.lang.IllegalStateException: Deployment failed for D:\Oracle\Middleware\EPMSystem11R1\products\Foundation\AppServer\InstallableApps\common\interop.ear

      at com.hyperion.hit.tool.deploy.ant.wrappers.TemplateWrapper.processStatus(TemplateWrapper.java:82)

      ... 36 more

       

      Also

      [2020-06-15T14:15:50.039-05:00] [EPMCFG] [TRACE] [EPMCFG-01001] [oracle.EPMCFG] [tid: 61] [ecid: 6786ff4f-ef20-45a8-bb68-7faaddea05be-00000006,0:23] [SRC_CLASS: com.hyperion.hit.tool.deploy.wlst.ScriptWlstConsole] trace: 2:Error: runCmd() failed. Do dumpStack() to see details.

       

      Also

      ERROR: Jars manifest  check failed with message "Some referenced jars do not exist.

       

      registry.log

      com.hyperion.hit.registry.ComponentImpl] [SRC_METHOD: setProperties] WRITE - SETPROPERTY: Component- Instance Tasks Configuration, Property Name- applicationServerDeployment, Property Value- Configuration Failed

        • 1. Re: Hyperion Foundation->Deploy to application server failing
          Madhusudhan. M

          Did you check that missing files in the system?

           

          Thanks,

          Mady

          • 2. Re: Hyperion Foundation->Deploy to application server failing
            Srini+K

            1. Run as administrator..(messages indicate security issue)

            2. check operating system compatibility (compatibility matrix). 

            • 3. Re: Hyperion Foundation->Deploy to application server failing
              3175164

              Madhusudhan. M Srini+K Thanks for your time and suggestion. I am using Windows Server 2019 and SQL 2016 R2.I am running the config tool as an administrator.

              I had an SR with Oracle for this and they suggested me below action item

               

              1. Cancel and exit the EPM Configuration tool

              2. Correct the entries in RCUSchema.properties ( make sure that all values are correct )

              3. Drop all db users – ones created using RCU ( use RCU drop schema option ) as well as the db user that you used for EPM Configuration

              4. Create new db users – with RCU as well as the db user for EPM Configuration

              5. Rename the user_projects folder C:\Oracle\Middleware\user_projects ( to something like user_projects_old )

              6. Re-run the EPM Configuration tool ( which will be from scratch since we renamed user_projects folder ) and complete required tasks

              7. Delete the user_projects_old folder ( renamed folder in step 5 )

               

              Still Deploy to application server task failed. But now I do not see wlst_debug.log in the new user_projects folder. Below are the errors I am seeing now

               

              Configtool.log

              [2020-06-16T15:58:54.450-05:00] [EPMCFG] [TRACE] [EPMCFG-01001] [oracle.EPMCFG] [tid: 92] [ecid: c262f3bb-05fc-4e20-8be1-ff313d6f9675-00000006,0] [SRC_CLASS: com.hyperion.cis.config.AntDeploymentApiAdapter] trace: Local deployment failed, removing APP_SERVER(f1c439b60fd364d747a8fda172beeb07f6S7f00) component for domain which was not really created

               

              registry.log

              [2020-06-16T15:58:54.419-05:00] [EPMREG] [WARNING] [EPMREG-11019] [oracle.EPMREG.REG] [tid: 92] [ecid: c262f3bb-05fc-4e20-8be1-ff313d6f9675-00000006,0] [SRC_CLASS: com.hyperion.hit.registry.Encrypter] [SRC_METHOD: decrypt] An exception of type javax.crypto.BadPaddingException occurred when decrypting the password.RootCause:Given final block not properly padded. Such issues can arise if a bad key is used during decryption..

              [2020-06-16T15:58:54.450-05:00] [EPMREG] [WARNING] [EPMREG-11019] [oracle.EPMREG.REG] [tid: 92] [ecid: c262f3bb-05fc-4e20-8be1-ff313d6f9675-00000006,0] [SRC_CLASS: com.hyperion.hit.registry.Encrypter] [SRC_METHOD: decryptUsingBlowfish] An exception of type javax.crypto.BadPaddingException occurred when decrypting the password.RootCause:Given final block not properly padded. Such issues can arise if a bad key is used during decryption..

              • 4. Re: Hyperion Foundation->Deploy to application server failing
                Madhusudhan. M

                It is better to remove the domain and deploy it to a fresh one, in my opinion.

                 

                If you are doing it for the client, I have one point here. If you rename user_projects to user_projects_old, it will be there still in registry and deployment report right? Instead of that remove an instance and deploy to the new one.

                 

                It's just a suggestion, the final call is yours only.

                 

                Thanks,

                Mady

                1 person found this helpful
                • 5. Re: Hyperion Foundation->Deploy to application server failing
                  3175164

                  This is resolved. Below are the steps I had to perform

                  • Uninstall EPM products
                  • Drop all the tables from my foundation database (Because configure Db and configure common tasks were successful )
                  • Run RCU to drop the schemas
                  • Delete and recreate new database for RCU. Before I did this creating schemas via RCU was failing with error Invalid Object Name 'dbo.schema_version_registry$ . Quick fix for me was to delete and create new DB for RCU since i had admin access to db server
                  • Clear registry entries for EPM
                  • Restart server, re-install EPM products
                  • Creating schemas using RCU (new DB)
                  • Update RCUSchema.properties file
                  • Re-run configurator tool
                  • 6. Re: Hyperion Foundation->Deploy to application server failing
                    Vasantha Kumar

                    Thanks for updating with the resolution steps.

                    • 7. Re: Hyperion Foundation->Deploy to application server failing
                      4279921

                      Hi Guys

                       

                      I did the above and my deploy still fails.

                      I've logged ticket with oracle support, but they are yet to respond with something of value.

                      My deploy to application keeps failing...Anyone have anything else I can try?

                       

                      Regards

                      John

                      • 8. Re: Hyperion Foundation->Deploy to application server failing
                        Krishna Chukkaluru

                        If you deploy the web applications to application server in EPM system configurator without updating the RCUschema.properties file the deployment will fail. This is the new pre-requisite in EPM 11.2 because of FMW 12c architecture, and we tend to miss this step if we don't follow the installation guide.

                         

                        Now, after updating the RCUschema.properties file, remove the domains folder before running the step Deploy to application server again for successful deployment. I have seen the same issue as I updated incorrect details in the file during my first deployment. And my deployment kept on failing in further attempts even after updating the file with correct details. I came to know later from one of the documents that unless you remove the domains folder and deploy again, it can't read the RCUschema.properties file.

                         

                        Regards,

                        Krishna C

                        • 9. Re: Hyperion Foundation->Deploy to application server failing
                          4279921

                          Hi Krisha

                           

                          Thank you for the reply. I did as you suggested and still my deploy fails. I can't make head or tails of the log file.

                           

                          I cannot seem to get past this point.

                          Will send attach log file on my ticket, perhaps oracle support can assist.

                           

                          Kind regards

                          John

                          • 10. Re: Hyperion Foundation->Deploy to application server failing
                            4279921

                            I've been ignoring this pop up when running rcu....Could this be the reason it's failing?

                             

                            • 11. Re: Hyperion Foundation->Deploy to application server failing
                              Krishna Chukkaluru

                              Hi John,

                               

                              Cannot comment if that is the reason for failure without checking logs.

                               

                              But, I will surely recommend to go with the supported database version for RCU because these databases/schemas are required to support the Java web applications.

                               

                              Regards,

                              Krishna C

                              • 12. Re: Hyperion Foundation->Deploy to application server failing
                                Madhusudhan. M

                                Even with complete clean up and doing fresh installation also, you're facing issue?

                                 

                                Open thread from answered and update config logs, will check the issue.

                                 

                                Thanks,

                                Mady