1 Reply Latest reply on Jun 25, 2020 10:24 AM by thatJeffSmith-Oracle

    SQL developer 19.4 problems with multitasking

    PaulStuart

      Hi everyone,

      I've just downloaded the new 19.4.  I'm on Windows 10, and i'm using the latest instant client, which it seems to need (ie it needs ocijdbc19, ocijdbc18 won't do).

       

      Here is my problem.  Multitasking doesn't work with this version :

       

      I run a long running query in a particular session.

      Then I attempt to open a new session or a worksheet on an existing session.

      Nothing happens, SQL developer basically hangs.

       

      When the original query completes, then all the actions you've just requested happen (connection to database happens, worksheets fly open).

       

      This absolutely worked in 19.1.  I've been using SQL developer for years.  I like to think of myself as a power user, and I'm promoting it at the company where i work.

       

      My issue is this :  Why do these problems with multi-tasking/threading keep happening?  I've pointed these kinds of things out in the past, and when I raise an SR, they get fixed.

      It just surprises me that basic things like this slip through testing.

       

      Am I the only one who logs into more than one database, and runs many things simultaneously?

       

      regards

       

      Paul Stuart