0 Replies Latest reply on Jul 3, 2020 2:10 PM by user9244153

    Integrated SOA Gateway after database upgrade to 19c ....

    user9244153

      Hi,

       

      After upgrade to 19c the generation of a service gives the following errors:

       

      irepName is  : XXANW_WEBSERVICE_DEBITEUR

      ClassId = 4438

      Class Type  = PLSQL

      Generating service with classId = 4438

      Error in Service Generation.

      ServiceGenerationError: ServiceGenerationError: Error in Service GenerationJ2T-130, ERROR: Array element type <unsupported type>(typecode 0) is not supported

      oracle.apps.fnd.soa.util.SOAException: ServiceGenerationError: ServiceGenerationError: Error in Service GenerationJ2T-130, ERROR: Array element type <unsupported type>(typecode 0) is not supported

              at oracle.apps.fnd.soa.provider.util.ServerAccess.analyzeServerResponse(ServerAccess.java:160)

              at oracle.apps.fnd.soa.ui.ProviderAccess.generateWSDL(ProviderAccess.java:44)

              at oracle.apps.fnd.soa.provider.wsdl.ServiceGenerator.generateSingleServiceSOAP(ServiceGenerator.java:102)

              at oracle.apps.fnd.soa.provider.wsdl.ServiceGenerator.main(ServiceGenerator.java:423)

       

       

      EBS: 12.1.3

      DB: 19.7.0.0.0

       

      Any idea what causes this?

       

      Thanks in advance