2 Replies Latest reply on Jul 20, 2020 8:39 PM by Dude!

    how to check numa in OL8

    3760159

      Hi everybody,

       

      It is very confusing to check numa disable and I got different results.

       

      [root@localhost ~]# dmesg | grep -i  numa

      [    0.120889] No NUMA configuration found   <<--- shows NUMA config disabled

       

      [root@localhost ~]# find /proc -name numa_maps   

      /proc/1/task/1/numa_maps                             <<----- seems like NUMA is enabled, so many tasks

      /proc/1/numa_maps

      /proc/2/task/2/numa_maps

      /proc/2/numa_maps

      /proc/3/task/3/numa_maps

      /proc/3/numa_maps

      …...

       

      [root@localhost ~]# grep NUMA=y /boot/config-`uname -r`

      CONFIG_NUMA=y                    <<---  confusing, NUMA enabled ?

      CONFIG_AMD_NUMA=y

      CONFIG_X86_64_ACPI_NUMA=y

      CONFIG_ACPI_NUMA=y

       

      I already explicity set numa to disabled and grub again, reboot twice after that

      in /etc/default/grub

            GRUB_CMDLINE_LINUX="crashkernel=auto resume=/dev/mapper/ol-swap rd.lvm.lv=ol/root rd.lvm.lv=ol/swap  rhgb quiet numa=off"  <<--- set NUMA OFF

       

      grub2-mkconfig -o /boot/grub2/grub.cfg

       

      Please advise how to check if numa is disabled.

       

      Thanks

        • 1. Re: how to check numa in OL8
          Avi Miller-Oracle

          The /boot/config-* files show how the kernel is compiled not what is active. The numa=off on your kernel command line and in dmesg should that NUMA has been disabled. However, with NUMA disabled, it still creates a single NUMA zone which is why you have entries in /proc.

          • 2. Re: how to check numa in OL8
            Dude!

            Perhaps you find the following useful:

             

            [root@localhost ~]# yum install -y numactl

            [root@localhost ~]# numactl --hardware

            available: 1 nodes (0)

            node 0 cpus: 0

            node 0 size: 1978 MB

            node 0 free: 1374 MB

            node distances:

            node   0

              0:  10

             

            [root@localhost ~]# dmesg | grep NUMA

            [    0.087433] No NUMA configuration found

             

            The above shows there's no NUMA support.

             

            I already explicity set numa to disabled and grub again, reboot twice after that

             

            Are you using PC BIOS or UEFI. In case of the later, try:

            grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg

            1 person found this helpful