5 Replies Latest reply on Aug 11, 2020 1:41 PM by Mohammed Ali A. Syed

    High load averages in Oracle Linux 7 with EBS 12.2 installed

    Alexander Pavlik

      Hello

       

      I recently installed EBS 12.2 with Oracle Database 19c on top of OEL 7, kernel version: 4.1.12-124.40.6.el7uek.x86_64

      The OS is installed in the a Xen Hypervisor version 8 virtual machine.

      Number of CPU: 4. Number of RAM: 14 GB.

      I observe the following behavior:

       

      When I start EBS apps load averages increase to quite high values.

      A lot of CPU is taken by weblogic managed servers during the startup

       

      top - 16:10:23 up 23 min,  2 users,  load average: 88.03, 32.71, 13.51
      Tasks: 330 total,   2 running, 328 sleeping,   0 stopped,   0 zombie
      %Cpu(s): 77.4 us, 19.4 sy,  0.0 ni,  2.6 id,  0.4 wa,  0.0 hi,  0.1 si,  0.1 st
      KiB Mem : 14341116 total,  2095368 free,  7023184 used,  5222564 buff/cache
      KiB Swap:        0 total,        0 free,        0 used.  3003756 avail Mem
      
      
         PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
        9452 oracle    20   0 1164748   8336      0 S 221.9  0.1   0:30.02 opmn
       12321 oracle    20   0 3872660   1.2g  15052 S 131.2  9.1   0:49.89 java
       12289 oracle    20   0 1696784 584692   4580 S  13.3  4.1   0:42.14 java
       10658 oracle    20   0 3891044 888464      0 S   5.0  6.2   1:16.54 java
       10187 oracle    20   0 5442484 105792   5608 S   0.3  0.7   0:11.63 java
      

       

      And usually some of the managed servers fail randomly, sometimes it's oafm, sometimes - oacore or forms

       

      Executing service control script:
      /u01/install/APPS/fs2/inst/apps/EBSDB_demo/admin/scripts/admanagedsrvctl.sh start oafm_server1 -nopromptmsg
      Timeout specified in context file: -1 second(s)
      
      script returned:
      ****************************************************
      
      You are running admanagedsrvctl.sh version 120.14.12020000.12
      
      Starting oafm_server1...
      
      Server specific logs are located at /u01/install/APPS/fs2/FMW_Home/user_projects/domains/EBS_domain/servers/oafm_server1/logs
      
      admanagedsrvctl.sh: exiting with status 1
      
      admanagedsrvctl.sh: check the logfile /u01/install/APPS/fs2/inst/apps/EBSDB_demo/logs/appl/admin/log/adoafmctl.txt for more information ...
      

       

      After a managed server fails during the startup, load average returns back to normal.

       

      So the issue is: Managed servers taking much CPU during startup and eventually failing randomly.

       

      Please tell:

       

      1) If anyone faced and fixed the same issue?

      2) Can you please advise on the investigation?

       

      Regards,

      Alex