0 Replies Latest reply on Oct 23, 2006 6:01 AM by 539701

    CRS could not start after reboot

    539701
      I installed oracle 10g R2 RAC on RHEL4 U4 with 2 nodes. It runs fine on 2 nodes (without reboot after installation). But when I rebooted one node, I found that the CRS daemon could not start automatically. The boot menu show "Starting CRS" [OK]. The "init.crs start" command won't init the CRS daemon.

      $ ./crs_stat
      CRS-0184: Cannot communicate with the CRS daemon.

      SQL> conn / as sysdba
      Connected to an idle instance.
      SQL> startup
      ORA-01078: failure in processing system parameters
      ORA-01565: error in identifying file '+DATA1/RAC/spfileRAC.ora'
      ORA-17503: ksfdopn:2 Failed to open file +DATA1/RAC/spfileRAC.ora
      ORA-15077: could not locate ASM instance serving a required diskgroup
      ORA-29701: unable to connect to Cluster Manager

      $ /etc/init.d/init.crs start
      Startup will be queued to init within 90 seconds.

      $ cat /etc/inittab
      ......
      id:5:initdefault:
      # Run xdm in runlevel 5
      x:5:respawn:/etc/X11/prefdm -nodaemon
      h1:35:respawn:/etc/init.d/init.evmd run >/dev/null 2>&1 </dev/null
      h2:35:respawn:/etc/init.d/init.cssd fatal >/dev/null 2>&1 </dev/null
      h3:35:respawn:/etc/init.d/init.crsd run >/dev/null 2>&1 </dev/null

      $ ls /etc/rc5.d
      K01tog-pegasus K35smb K85mdmpd S05openibd S18rpcidmapd S55sshd S96readahead
      K02NetworkManager K35vncserver K87auditd S06cpuspeed S19rpcgssd S56rawdevices S97messagebus
      K05saslauthd K35winbind K87ipmi S08arptables_jf S19vmware-tools S56xinetd S97rhnsd
      K10dc_server K40smartd K89netplugd S08iptables S25netfs S58ntpd S98cups-config-daemon
      K10psacct K50ibmasm K90bluetooth S09isdn S26apmd S80sendmail S98haldaemon
      K12dc_client K50netdump K94diskdump S10network S26lm_sensors S85gpm S99local
      K15httpd K50snmpd K96pcmcia S12syslog S27vasd S90crond
      K20nfs K50snmptrapd S00microcode_ctl S13irqbalance S28autofs S90xfs
      K24irda K50tux S01sysstat S13portmap S29oracleasm S95anacron
      K25squid K73ypbind S04readahead_early S14nfslock S44acpid S95atd
      K30spamassassin K74nscd S05kudzu S15mdmonitor S55cups S96init.crs

      Do I miss any configuration to initialize the CRSD at boot?

      thanks, ezlee