1 2 Previous Next 15 Replies Latest reply: May 9, 2007 4:11 AM by 325351 RSS

    problems installing ilm assitant

    Lmarques-Oracle
      Hi,
      when I run ilma_install I get (after some lines):

      *
      ERRO na linha 1
      ORA-06502: PL/SQL: erro numÚrico ou de valor : erro de conversÒo de n·mero em
      carßcter
      ORA-06512: na linha 16

      and it gets disconnected.

      If I go to apex and log in with admin user there is no ilm workspace created...

      any help?

      thanks
        • 1. Re: problems installing ilm assitant
          543302
          Hi,

          I'm wondering if it is an NLS problem with our installation procedure. You clearly have a language setting other than en-us, which is our default environment here.

          For test purposes, can you set your language environment to en-us and try the installation again? If this works, we need to determine what non-English settings do to our installation procedure.

          Thanks,

          Greg
          • 2. Re: problems installing ilm assitant
            Lmarques-Oracle
            thanks greg.

            that's it.

            lm
            • 3. Re: problems installing ilm assitant
              573582
              Hi Greg.

              I have exactly the same problem but i didn´t undertand your soluction. I have the "Regional and Language Options" set to portuguese. Is it that i have to change to english? Or when you refer "language environment" you mean the language of my oracle database?

              I also ask Oracle for help by metalink but they respond that they didn´t suport ILM by metalink!!

              Best Regards.

              Óscar.
              • 4. Re: problems installing ilm assitant
                459761
                The ILM Assistant is a free download and is not supported through the normal channels used for revenue products. Instead, the ILM Assistant is community supported via this forum. In effect, you have a direct link to the developers, as well as potential support from other users.

                I'll leave it to Greg to reply to the language setting issue.

                Thanks, Jack
                • 5. Re: problems installing ilm assitant
                  543302
                  Hi Óscar,

                  You need set your database language environment to English. I believe this can be done just for your session within SQL*Plus. Once the installation completes, you can set it back to your preferred locale; however, the ILM Assistant will still present everything in English.

                  Now, once ILMA is installed, you may wish to go to our ILMA preferences and set the language locale there in order to display the correct number and currency formats.

                  Let me know if you still have problems with the installation.

                  Thanks!

                  Greg
                  • 6. Re: problems installing ilm assitant
                    573582
                    Hi Greg!

                    I use the GUI of my database and change, in the SPFile, the:
                    - variable "nls_language" to "AMERICAN"
                    - the variable "nls_territory" to "AMERICA".

                    Then i restart the database, i verified that the variables heve been changed and i try to install the ILM again. I've got the same error message!! Did i do everything right? I would be thankful if you give me more tips.

                    Best Regards.
                    Óscar.
                    • 7. Re: problems installing ilm assitant
                      543302
                      Hi Óscar,

                      I don't have another suggestion at this point. I will do some investigation and get back to you as soon as possible.

                      Regards,

                      Greg
                      • 8. Re: problems installing ilm assitant
                        573582
                        Hi Greg!

                        I try a diferent way (there are things that i realy don't understand!!!):

                        I change my language environment by using the follow command in the MS-DOS command prompt:

                        C:\> set NLS_LANG=AMERICAN_AMERICA.WE8MSWIN1252

                        I think i resolve the problem. But now i have another. At the end of installation i've got the follow error message:

                        *************************************************************************************
                        Commit complete.

                        begin
                        *
                        ERROR at line 1:
                        ORA-04063: package body "ILM_TOOLKIT.ILM_TOOLKIT" has errors
                        ORA-06508: PL/SQL: could not find program unit being called:
                        "ILM_TOOLKIT.ILM_TOOLKIT"
                        ORA-06512: at line 2


                        Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.2.0 - Production
                        With the Partitioning, OLAP and Data Mining options

                        C:\Oracle\ILM>
                        ************************************************************************************

                        Once more i would be thankfull if you help me.

                        Regards.
                        Óscar.
                        • 9. Re: problems installing ilm assitant
                          543302
                          Hi,

                          Check this APEX link out for the NLS stuff. It may help.

                          Re: Version 2.2 installation fails

                          For the other package errors, execute the following from within SQL*Plus:

                          1. connect to sys as sysdba

                          2. @prvtilmh.sql

                          3. @prvtilms.plb

                          4. @prvtilmh.plb

                          This should reload all of our ILM Assistant packages.

                          Thanks,

                          Greg
                          • 10. Re: problems installing ilm assitant
                            573582
                            Hi!

                            I try to follow your instructions. In the step 4, i don't find the file that you specify. Do you mean the file "prvtilmb.plb"? I try to execute this file and i got the follow errors:

                            *********************************************************************************************
                            SQL> @prvtilmb.plb

                            Warning: Package Body created with compilation errors.

                            Errors for PACKAGE BODY ILM_TOOLKIT.ILM_TOOLKIT:

                            LINE/COL ERROR
                            -------- -----------------------------------------------------------------
                            4540/3 PL/SQL: Statement ignored
                            4540/30 PLS-00201: identifier 'V' must be declared
                            5892/3 PL/SQL: Statement ignored
                            5892/44 PLS-00201: identifier 'V' must be declared
                            6201/4 PL/SQL: Statement ignored
                            6201/45 PLS-00201: identifier 'V' must be declared
                            6226/7 PL/SQL: Statement ignored
                            6226/19 PLS-00201: identifier 'HTMLDB_APPLICATION.G_F01' must be declared
                            6244/10 PL/SQL: Statement ignored
                            6244/22 PLS-00201: identifier 'HTMLDB_APPLICATION.G_F01' must be declared
                            7157/3 PL/SQL: Statement ignored

                            LINE/COL ERROR
                            -------- -----------------------------------------------------------------
                            7162/34 PLS-00201: identifier 'V' must be declared
                            SQL>

                            ***********************************************************************************************

                            I'm sorry to borrow you again but i don´t find usefull information about ILM.

                            Regards.

                            Óscar.
                            • 11. Re: problems installing ilm assitant
                              543302
                              Hi Óscar,

                              You have the correct package file. The errors indicate that APEX is not found by our ILM toolkit routines. This could mean that your Application Express installation may have not installed correctly. Have you been able to get to the APEX development page from your browser? The link would be something like this:

                              http://your-system.your-domain.com:7777/pls/apex

                              If you can't get to the Apex main page, then you might try installing Apex again.

                              Thanks,

                              Greg
                              • 12. Re: problems installing ilm assitant
                                573582
                                Hi Greg.

                                It's correct! I can't acess the Apex. I have one doubt! I'm using Oracle Database 10.2.0.2 and i think i read somewhere that this version was "ready to ILM"! I check the "Installed Products" and there is no Application Express! I already try to install Apex 3.0 and then, when i try to install ILM, i got the error message: "incorrect version of Application Express found". Its possible that i made a mistake somewhere (I´m a traine with litlle experience in Oracle!!!). After so mutch talk..... what you recomend that i do? Try to install Apex again?

                                Best Regards.

                                Óscar.
                                • 13. Re: problems installing ilm assitant
                                  543302
                                  Hi Óscar,

                                  There should be no problems running either APEX or ILMA on Oracle 10.2. Given that, I suggest starting over with the installations.

                                  1. APEX

                                  2. ILM Assistant

                                  Regarding the Assistant, we are just about ready to post V1.1 on OTM, so you should watch for that release shortly.

                                  Regards,

                                  Greg
                                  • 14. Re: problems installing ilm assitant
                                    573582
                                    Hi Greg!

                                    After some problems i have installed APEX. But once again, i'm with problems installing ILM. when i execute the command "SQL> @ilma_install pass ILM NONE" i get the follow error:

                                    ******************************************************************************************
                                    Checking the versions of Oracle and Oracle Application Express ...

                                    DECLARE
                                    *
                                    ERROR at line 1:
                                    ORA-20000: The version of Oracle Application Express must be 2.2 or later.
                                    ORA-06512: at line 19

                                    Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.2.0 - Production
                                    With the Partitioning, OLAP and Data Mining options

                                    C:\Oracle\ILM>

                                    *********************************************************************************************

                                    The problem is that i install APEX 3.0 and it´s working. I acess the administrative services and i create a workspace. I don't do anything else bacause explore APEX isn't my primary objective. ILM is my objective.

                                    If you could help me again i would be very thankfull.

                                    Best regards.

                                    Óscar.
                                    1 2 Previous Next