1 2 Previous Next 27 Replies Latest reply on Dec 18, 2006 10:20 AM by 548059 Go to original post
      • 15. Re: Em is working; iSQL*Plus is not
        548059
        Hi,

        My Oracle installation is on Win XP.

        So I tried http://abc.xyz.com/:5561/isqlplus/dba/dynamic, but failed.

        FYI...Just after I completed installation of Oracle 10gR2, I was able to connect using below

        http://abc.xyz.com:5561/isqlplus/

        http://abc.xyz.com:5561/isqlplus/dba.uix

        Then I shutdown the machine and the next day when I restarted the machine,
        the problem started from then onwards.

        I was not even able to connect using EM DB Console.

        Later noticed the OS service for EM DB Console was not started.
        Then I started the service using "emctl start dbconsole" command and now its working OK.

        But iSQL*Plus is not working since then.

        I even tried to login to iSQL*Plus from the EM's iSQL*Plus link. Still the same issue exists.

        Thanks.
        • 16. Re: Em is working; iSQL*Plus is not
          mnazim-Oracle
          You also need to start isqlplus service .
          dbhome\bin\isqlplusctl start
          • 17. Re: Em is working; iSQL*Plus is not
            277993
            I still think there are 3 things that could be causing the problem. A) the service not started or not starting correctly. B) The wrong port number. C) IP/DHCP issues.

            If your Oracle<oracle_home>iSQL*Plus service is not started, then you must start it . I fit is set to start manually, you must start it each time you restart your machine. If you want it to start all the time, the change Strtup Type in Services in Windows to Automatic.
            • 18. Re: Em is working; iSQL*Plus is not
              mnazim-Oracle
              any update ..
              • 19. Re: Em is working; iSQL*Plus is not
                548059
                I'm referring to "OracleOraDb10g_home1iSQL*Plus" service out of the services running.
                Isn't it the same service for iSQL*PLus?

                Yes, it's already running. And "Startup type" is "Automatic".

                Still I ran the command, "isqlplusctl start" with the following output

                iSQL*Plus 10.2.0.1.0
                Copyright (c) 2003, 2005, Oracle. All rights reserved.
                Starting iSQL*Plus ...
                iSQL*Plus started.

                There's no effect.

                Do I need to review anything else that I might have skipped that's worth mentioning?
                • 20. Re: Em is working; iSQL*Plus is not
                  548059
                  To narrow down the issue

                  A) the service not started or not starting correctly

                  - I believe you're referring to "OracleOraDb10g_home1iSQL*Plus" (in this case)
                  it's already running. And "Startup type" is "Automatic".


                  B) The wrong port number

                  - can't suspect this. Because I was able to login using iSQL*Plus immediately after the installation was complete (with the specifications that the "end of installation" screen showed in the end)

                  C) IP/DHCP issues

                  The workflow went like this...

                  - After installation, I was able to login using iSQL*Plus
                  - shutdown the system
                  - next day restarted the system
                  - observed EM DBConsole & iSQL*Plus not working
                  - started the EM related service from the service control
                  - then iSQL*Plus service was already running
                  - still was not able to login using iSQL*Plus
                  - consulted the sysadmin (he perhaps made some changes, assigned another IP & tried to get it to work)
                  - was unsuccessful, restored the earlier IP
                  - In between, checked the System event log & found the following

                  source: dhcp
                  computer: abc
                  Description: your computer was not able to renew its address from the network (from the DHCP server) for the network card with network address 1234E56789. The following error occured:

                  The semaphore timeout period has expired. Your computer will continue to try and obtain an address on its own from the network address(DHCP) server.
                  • 21. Re: Em is working; iSQL*Plus is not
                    548059
                    To narrow down the issue

                    A) the service not started or not starting correctly

                    - I believe you're referring to "OracleOraDb10g_home1iSQL*Plus" (in this case)
                    it's already running. And "Startup type" is "Automatic".


                    B) The wrong port number

                    - can't suspect this. Because I was able to login using iSQL*Plus immediately after the installation was complete (with the specifications that the "end of installation" screen showed in the end)

                    C) IP/DHCP issues

                    The workflow went like this...

                    - After installation, I was able to login using iSQL*Plus
                    - shutdown the system
                    - next day restarted the system
                    - observed EM DBConsole & iSQL*Plus not working
                    - started the EM related service from the service control
                    - then iSQL*Plus service was already running
                    - still was not able to login using iSQL*Plus
                    - consulted the sysadmin (he perhaps made some changes, assigned another IP & tried to get it to work)
                    - was unsuccessful, restored the earlier IP
                    - In between, checked the System event log & found the following

                    source: dhcp
                    EventID: 1003
                    computer: abc

                    Description: your computer was not able to renew its address from the network (from the DHCP server) for the network card with network address 1234E56789. The following error occured:

                    The semaphore timeout period has expired. Your computer will continue to try and obtain an address on its own from the network address(DHCP) server.
                    • 22. Re: Em is working; iSQL*Plus is not
                      mnazim-Oracle
                      Behaviour is expected to resolve ip address you need to cofigure loopback adpater
                      http://download-west.oracle.com/docs/cd/B19306_01/install.102/b14317/reqs.htm
                      • 23. Re: Em is working; iSQL*Plus is not
                        548059
                        Hi,

                        I removed the loopback adapter and reconfigured it as per the documentation.
                        However that did not solve the problem.

                        Is there any way I can reconfigure iSQL*Plus to get it work?
                        As this is a test system, I don't have any issues in doing it from scratch.

                        Thanks.
                        • 24. Re: Em is working; iSQL*Plus is not
                          mnazim-Oracle
                          just reboot the box again to make changes effective
                          • 25. Re: Em is working; iSQL*Plus is not
                            548059
                            Still that doesn't work!!
                            • 26. Re: Em is working; iSQL*Plus is not
                              mnazim-Oracle
                              Paste the emoms.trc file and eventlog
                              • 27. Re: Em is working; iSQL*Plus is not
                                548059
                                Hi,

                                I reinstalled everything and all is well now.

                                Thank you everybody for all the help!!
                                1 2 Previous Next