This discussion is archived
2 Replies Latest reply: Dec 15, 2006 12:37 PM by 551646 RSS

Insufficient privileges error when deploying a connector to a flat file

551646 Newbie
Currently Being Moderated
I cannot deploy OWB script due to insufficient privileges, the error message is:

ORA-01031: insufficient privileges

While trying to deploy a connector to a flat file I have created as an external table to be loaded into an Oracle database. It accepts the runtime user account to access deployment manager for the runtime repository so may be it's missing some privileges on that account (e.g. object creation rights). If so what privileges should I add to the account?

The target database and the flat file directory both register fine and when I try to create/deploy the external table (of the flat file) it displays the following error message:

ORA-06564: object {connector name} does not exist

Is this a privileges problem or am I missing a step in the deployment?

Thanks,

John
  • 1. Re: Insufficient privileges error when deploying a connector to a flat file
    468749 Newbie
    Currently Being Moderated
    Hi John,

    are you using OWB10gR2?
    Is your target-user correctly created as a target-user inside OWB (=>Security-window =>User) and registered?

    Normaly you don´t have to deploy the connector seperatly, it´ll be done automatically if you deploy your ext tab.

    Otherwise it may be a problem, if you created your File-location from your client (f.e. windows c:/... ) and on your serverside where you deploy that location you need f.e. /u02/...

    Check
    Re: Error Querying Contents of External Table

    Regards
    jwehner
  • 2. Re: Insufficient privileges error when deploying a connector to a flat file
    551646 Newbie
    Currently Being Moderated
    Hi,

    Thanks for the response!

    I am using OWB10gR1 and I will check with the network administrator if the target-user is actually a target-user and registered.

    I tried deploying the external table first initially but received the following error:

    ORA-06564: object LEADS_CONNECTOR does not exist

    So I assumed I needed to deploy the connector before the external table which was when I recieved the error:

    ORA-01031: insufficient privileges

    I did create the file location from the design client (on the "client" machine, i.e. not the server hosting the repository and OWB) but I used a network location that should be accessible from both my machine and the server. I will check this is true with the network administrator.

    I also get the following error when trying to deploy everything:

    RPE-01012: Cannot deploy to the target location because it is owned by a different runtime platform.

    I have found one other post on this but inly one repository was created so I don't think that's the problem:

    RPE-01012: Cannot deploy to the target location because it is owned by a di

    And this error for all the tables and sequences:

    ORA-00955: name is already used by an existing object

    The "insufficient privileges" error does not appear when I try to deploy everything though.

    Thanks you for your help so far!

    Regards,

    John