2 Replies Latest reply on Jan 15, 2007 8:27 AM by 553151

    Why am I getting JBO-25002: Definition  of type Attribute not found?

    553151
      I have created a advancedTable named GoodsOuterTableRN and its perfectly working fine. Even when I created a "detail" to it and placed a messageStyledText item (here I have given outertable as View instance and one of the attribute of outer table as view attribute to it) in that, its working fine.

      But when I use inner table in "detail" instead of simple item with below mentioned code, its giving exception -
      "oracle.apps.fnd.framework.OAException: java.lang.NullPointerException
           at oracle.apps.fnd.framework.OAException.wrapperException(OAException.java:888)"

      The code that I have written in CO is as below as mentioned in Developers guide customised to my program variables.
      =====================================================
      OAWebBean outerTable = (OAWebBean)webBean.findChildRecursive("GoodsOuterTableRN");
      OAWebBean innerTable = (OAWebBean)webBean.findChildRecursive("GoodsInnerTableRN");

      if (outerTable != null)

      outerTable.setAttributeValue(CHILD_VIEW_ATTRIBUTE_NAME,"FLEX_VALUE");
      outerTable.setAttributeValue(VIEW_LINK_NAME,"XXCC_VL");
      }

      if (innerTable != null)
      {
      innerTable.setAttributeValue(CHILD_VIEW_ATTRIBUTE_NAME,"FLEX_VALUE");
      innerTable.setAttributeValue(VIEW_LINK_NAME,"XXCC_VL");
      }

      OAApplicationModule am = pageContext.getApplicationModule(webBean);
      am.invokeMethod("initGoodsQuery");
      ==============================================

      If I comment the line "innerTable.setAttributeValue(VIEW_LINK_NAME,"XXCC_VL"); " then its rendering the Outer table details but when I expanded any row for inner table, its throwing exception --> "oracle.apps.fnd.framework.OAException: oracle.jbo.NoDefException: JBO-25002: Definition of type Attribute not found"

      I am struggling with this issue from last one and half day. Any suggetion that would solve my problem would be highly appreciated.
      Thanks in advance.
        • 1. Re: Why am I getting JBO-25002: Definition  of type Attribute not found?
          442947
          You need to set the child view attribute and view link name for both inner and outer table for the Table in Table to work. Can you paste first 4 lines from the detail#0 part of the NPE, you had already made null checks so I am wondering where the exception is coming from. Indicate the line which throws the NPE from your code.
          • 2. Re: Why am I getting JBO-25002: Definition  of type Attribute not found?
            553151
            Thanks for taking time. I was getting NPE at "innerTable.setAttributeValue(VIEW_LINK_NAME,"XXCC_VL"); ". After so many trial and error work finally I could get thru with the problem and now its working fine.
            My observations are below.
            (1) some how (how i really dont know, i would appreciate if you can add useful information to it), even though i created AM after View Link being created my view link was not appearing for both of the Views displayed in AM. (Please note that I have two VOs and one one VL). Thus I could select VL for only one VO instead of two in the first trial.
            (2) the problem was solved after i reated VL and AM and when I selected VL for both VOs, then my problem was solved half way. The remaining solution includes I have changed view link name that I have used in "innerTable.setAttributeValue(VIEW_LINK_NAME,"XXCC_VL"); " to "XXCC_VL1" instead of "XXCC_VL".
            Thanks indeed Ramkumar.