6 Replies Latest reply: Sep 13, 2011 8:48 AM by 842201 RSS

    JDev10132: Problem with slow IDE and text editor

    25112
      Hi,

      I have installed JDev 10132 and JDev 10131 on my new WinXP Notebook. While the performance of the JDev 10131 is fine, the performance of JDev 10132 is far slower. Typing or Copy/Paste Java source code is a pain. Resizing of the IDE is OK with both versions, but restoring the main window of the JDev 10132 IDE shows a grey rectangle for about 1-2 secs.
      The GUI performance of ADF Swing Applications build with JDev 10132 is fine.

      I have read Shays blog entry 'http://blogs.oracle.com/shay/2006/03/29' about slow JDev installations.

      Any hints to solve my problem are welcome!

      cheers, Markus
        • 1. Re: JDev10132: Problem with slow IDE and text editor
          3020
          Hi Markus,

          Not much (if anything) has changed in the core code editing functionality of the IDE between 10.1.3.1 and 10.1.3.2 that would account for the performance difference you're seeing. Are you seeing sluggish code editing performance with java code, or with xml or some other document type? Does switching off or fiddling with the code assist delay options for Audit (see Tools->Preferences->Audit) make much of a difference to performance?

          Long pauses on re-activation usually occur when you have a large number of documents open in the IDE. Note that some documents can be opened in the background, so they needn't necessarily be visible as actual editors. You can see a count of the number of open documents by invoking save all (check the status bar - it will tell you the number of open "nodes"). You can disable the automatic reloading of externally modified files that happens on application switch on the Environment page in Preferences.

          Whenever you see performance problems like this, it's helpful for us to see a stack dump of the ide. You can obtain a stack dump by making sure you start the product using jdev.exe and pressing Ctrl+Break in the resulting command prompt window while the product is hung.

          Thanks,
          Brian
          • 2. Re: JDev10132: Problem with slow IDE and text editor
            451653
            It seems like JDeveloper 10.1.3.2 is sensitive to screen resolution. We tried a new laptop with high spec (2 gig memory) on a 1900 x 1200 resolution (default) and JDev was a nightmare. The editor was very slow. Pressing delete-button trigged a response after 2-3 sec. The response times is barely acceptable just after JDev starts, but gets progressively slower.
            With all the other (lower) screen resolutions everyting works fine.

            Per Sverre.
            • 3. Re: JDev10132: Problem with slow IDE and text editor
              3020
              Hi,

              I routinely run JDev on a dual 1920x1200 display and don't have any problems.

              It's probably an issue with Java and your laptop video driver. Try running with -J-Djava2d.noddraw=true passed in on the command line. Java is known to have performance issues with certain laptop graphics hardware.

              Thanks,
              Brian
              • 4. Re: JDev10132: Problem with slow IDE and text editor
                451653
                AddVMOption -Dsun.java2d.noddraw=true solved the problem.

                Thanks !

                Per Sverre
                • 5. Re: JDev10132: Problem with slow IDE and text editor
                  602580
                  Thank you so much for this solution!
                  I have had a problem for a while now with the JDeveloper IDE (10.1.3.2.0) being really slow on my machine ( I mean, really slow) and I've just lived with it after having tried all other suggestions.
                  This fix sorted out the problem and now its twice, no three, no five times quicker!
                  Thanks a lot!
                  Andy
                  • 6. Re: JDev10132: Problem with slow IDE and text editor
                    842201
                    Thanks Much for the solution. It works

                    -Guna.