This discussion is archived
0 Replies Latest reply: Feb 17, 2007 3:49 PM by 10864 RSS

OBE: Portal 10.1.2 Building Portlets Declaratively - web service errors

10864 Newbie
Currently Being Moderated
Note: I found a similiar post from mid-2006 which had no solution reported. I hope my question gets a response more quickly.
.
.
"Creating a Portlet Using a Web Service as a Data Source"
Step 9: WSDL URL: http://webservices.oracle.com/ws/emp/oracle.ws.scott.OTNDeptEmp?WSDL
Step 10: displayed a list of service methods
Step 13 did not display any table columns.
Clicking the <TEST> from the Source definition page only produced the following errors.
.
Q1) What are the needed changes to get the tutorial to work?
.
.
XML Data:
<ns1:getEmpXMLResponse xmlns:ns1="oracle.ws.scott.OTNDeptEmp" SOAP-ENV:encodingStyle="http://xml.apache.org/xml-soap/literalxml" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<return>
<ERROR>
oracle.xml.sql.OracleXMLSQLException: Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=168821760)(ERR=12505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))
</ERROR>
</return>
</ns1:getEmpXMLResponse>
.
SOAP Response Body:
<SOAP-ENV:Body xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<ns1:getEmpXMLResponse xmlns:ns1="oracle.ws.scott.OTNDeptEmp" SOAP-ENV:encodingStyle="http://xml.apache.org/xml-soap/literalxml">
<return>
<ERROR>
oracle.xml.sql.OracleXMLSQLException: Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=168821760)(ERR=12505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))
</ERROR>
</return>
</ns1:getEmpXMLResponse>
</SOAP-ENV:Body>
.
SOAP Request:
<?xml version='1.0' encoding='UTF-8'?>

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<SOAP-ENV:Body>

<ns1:getEmpXML xmlns:ns1="oracle.ws.scott.OTNDeptEmp" SOAP-ENV:encodingStyle="http://xml.apache.org/xml-soap/literalxml">
</ns1:getEmpXML>


</SOAP-ENV:Body>


</SOAP-ENV:Envelope>