5 Replies Latest reply: Mar 14, 2007 3:27 AM by Jes RSS

    Blank page after cloning apex 2.2.1

      Hi to all,

      I have lately cloned a production database with apex 2.2.1 to a development box on Linux. The Oracle 10g database opens up fine. The Apex 2.2.1 supported by Oracle 10g Companion CD seems to be right in place. I can restart my HTTP server by commands 'opmnctl stopall' and 'opmnctl startall'. The only problem is the apex login page on my development box ends up in a blank page.

      redirect automatically to http://chooyu.shm.com:7777/pls/apex/apex (a blank page with ‘done’ at bottom)
      Both Apache access logs and error logs look like this:

      [oracle@shm logs]$ more access_log.1173355200
      x.y.13.97 - - [08/Mar/2007:15:53:34 -0500] "GET / HTTP/1.1" 200 19596
      x.y.13.97 - - [08/Mar/2007:15:53:34 -0500] "GET /ohs_images/portals.css HTTP/1.1" 200 14795
      x.y.13.97 - - [08/Mar/2007:15:53:34 -0500] "GET /ohs_images/space.gif HTTP/1.1" 200 43
      x.y.13.97 - - [08/Mar/2007:15:53:34 -0500] "GET /Tab_files/asytlse.gif HTTP/1.1" 200 830
      x.y.13.97 - - [08/Mar/2007:15:53:34 -0500] "GET /Tab_files/asytrsm.gif HTTP/1.1" 200 924
      x.y.13.97 - - [08/Mar/2007:15:53:34 -0500] "GET /favicon.ico HTTP/1.1" 404 308
      x.y.13.97 - - [08/Mar/2007:15:53:42 -0500] "GET /pls/apex HTTP/1.1" 302 5
      x.y.13.97 - APEX_PUBLIC_USER [08/Mar/2007:15:53:42 -0500]
      "GET /pls/apex/apex HTTP/1.1" 200 5
      x.y.13.97 - - [08/Mar/2007:15:53:42 -0500] "GET /favicon.ico HTTP/1.1" 404 308
      x.y.13.97 - - [08/Mar/2007:16:00:50 -0500] "GET /pls/apex HTTP/1.1" 302 5
      x.y.13.97 - APEX_PUBLIC_USER [08/Mar/2007:16:00:50 -0500]
      "GET /pls/apex/apex HTTP/1.1" 200 5
      x.y.13.97 - - [08/Mar/2007:16:00:50 -0500] "GET /favicon.ico HTTP/1.1" 404 308

      [oracle@shm logs]$ more error_log.1173355200
      [Thu Mar  8 15:52:58 2007] [notice] FastCGI: process manager initialized (pid 6391)
      [Thu Mar  8 15:52:59 2007] [notice] Oracle-Application-Server-10g/ Oracle-HTTP-Server configured -- resuming normal operations
      [Thu Mar  8 15:52:59 2007] [notice] Accept mutex: fcntl (Default: fcntl)
      [Thu Mar  8 15:53:34 2007] [error] [client x.y.13.97] [ecid: 1173387214:,0] File does not exist: /u01/app/oracle/product/10.1.0/Db_2/Apache/Apache/htdocs/favicon.ico

      I have checked all files: marvel.conf, httpd.conf, images etc.
      I have also verified that apex_public_user can connect to the database via SQL*PLUS

      SQL>connect apex_public_user/<pwd>@<net_service_name>

      As I’ve been pulling my hair to fix this blank page problem for a while, I’d really appreciate anyone’s input or suggestion.

        • 1. Re: Blank page after cloning apex 2.2.1
          Hi Deborah,

          I'm curious - do you encounter the same results when you go to:

          1) Are there any errors in the database alert log?
          2) Can you briefly describe the process you followed to clone your database?

          • 2. Re: Blank page after cloning apex 2.2.1
            Hi Joel,

            Thanks for your quick response.

            1. I have the 'Gateway Timeout' error when going to http://chooyu.shm.com:7777/pls/apex/f?p=4550:1

            504 Gateway Timeout
            The following error occurred: [code=GATEWAY_TIMEOUT] A gateway timeout occurred. The server is unreachable. Retry the request.
            Could not open error file

            2. The only errors in my database alert log is complaining about my tempfiles.
            WARNING: The following temporary tablespaces contain no files.
            This condition can occur when a backup controlfile has
            been restored. It may be necessary to add files to these
            tablespaces. That can be done using the SQL statement:

            ALTER TABLESPACE <tablespace_name> ADD TEMPFILE

            Alternatively, if these temporary tablespaces are no longer
            needed, then they can be dropped.
            Empty temporary tablespace: GROUP2

            It's very strange. I can connect the database and successfully query my temporary tablespace via database_properties, dba_users, v$tempfile, dba_tablespace_groups but when I shut down and re-start my database the same warning message come up. I have also re-create my control files on the development box but still the database fails to recognize the tempfile !

            3. The following are my cloning steps:
            a. configure my development box exactly like my production box (same server, same OS - RHEL 4.0, same kernel parameters, same oracle user and oinstall group).
            b. backup and shut down production box
            c. copy whole mount point /u01 for oracle directory, oracle user profile, environment parameters from production box to development box.
            d. change hostname from the files below:

            *init.ora and spfile

            e. clean up filename corruption @ ~/db_2/Apache/Apache/htdocs
            [oracle@chooyu htdocs]$ mv BIF.htm.htm BIF.htm
            [oracle@chooyu htdocs]$ mv BI.htm.htm BI.htm
            [oracle@chooyu htdocs]$ mv Caching.htm.htm Caching.htm
            [oracle@chooyu htdocs]$ mv EBI.htm.htm EBI.htm
            [oracle@chooyu htdocs]$ mv HA.htm.htm HA.htm
            [oracle@chooyu htdocs]$ mv iASDemos.htm.htm iASDemos.htm
            [oracle@chooyu htdocs]$ mv IM.htm.htm IM.htm
            [oracle@chooyu htdocs]$ mv index.html.html index.html
            [oracle@chooyu htdocs]$ mv J2EEandIA.htm.htm J2EEandIA.htm
            [oracle@chooyu htdocs]$ mv J2EE.htm.htm J2EE.htm
            [oracle@chooyu htdocs]$ mv MS.htm.htm MS.htm
            [oracle@chooyu htdocs]$ mv NFIntro.htm.htm NFIntro.htm
            [oracle@chooyu htdocs]$ mv Portals.htm.htm Portals.htm
            [oracle@chooyu htdocs]$ mv PW.htm.htm PW.htm
            [oracle@chooyu htdocs]$ mv SM.htm.htm SM.htm
            [oracle@chooyu htdocs]$ mv UM.htm.htm UM.htm
            [oracle@chooyu htdocs]$ mv Wireless.htm.htm Wireless.htm

            f. connect and find the blank page on apex login page.

            Thanks for your help.

            • 3. Re: Blank page after cloning apex 2.2.1
              Hi Deborah,

              I don't know if you've solved this already, but I'll ask a silly question anyway ;)

              Have you changed the entry in your DAD to point to the new cloned database? It's kind of suggesting to me (particularly with the gateway timeout) that it's perhaps trying to contact the old instance via the DAD rather than your new one.
              • 4. Re: Blank page after cloning apex 2.2.1
                Thanks to Jes and Joel for your input. I have finally made it work.

                After cloning, connection to the database is good but my APEX application is hard to bring up on the web. This tells me that maybe there are the metadata, privileges and lots of other stuff in the 'black box' that I did not cycle through correctly. I have been very desperate and decided to take the last resort to drop the user and recreate the user on my development box. The apexins scripts fix all the data integrity issues for me.

                SQL> alter user flows_010500 account unlock;


                SQL> EXEC FLOWS_010500.WWV_FLOW_UPGRADE.SWITCH_SCHEMAS('FLOWS_020200','FLOWS_010500');

                SQL> drop user flows_020200 cascade;

                SQL> @apexins <pwd> SYSAUX SYSAUX TEMP /i/ none

                SQL> @utlrp.sql

                verify image file
                verify marvel.conf
                verify httpd.conf

                opmnctl startall >>> to bring up the HTTP Server

                connect: http://chooyu.shm.com:7777/pls/apex >>> opens up fine with apex 2.2.1 and all previous HTMLDB applications and workspaces are there.

                This really makes my day!

                • 5. Re: Blank page after cloning apex 2.2.1
                  Hi Deborah,

                  Glad you got it to work, I'm still a bit confused since if it's a clone then it is a clone, in fact I did something similar only a few days ago and it worked fine.

                  If you ever find out what the core problem was, please do post back because I'd be interested to know what it was.