1 2 3 4 Previous Next 48 Replies Latest reply on Apr 3, 2008 2:14 PM by Turloch O'Tierney-Oracle Go to original post
      • 15. Re: SQL Server connection options
        583670
        I have the some problem but when a add entry not apper to be saved, because next time i go there, i cant see
        • 16. Re: SQL Server connection options
          585055
          I didnt see a resolution to this...I am getting the same error
          Network error IOException: Connection Refused: connect.

          I have enabled the tcpip at the sqlserver and also disabled the firewall.

          Still cant connect to the sqlserver database.

          Can anyone help
          • 17. Re: SQL Server connection options
            SueHarper
            When you add the driver in the preferences, be sure to click away from the field, as this is sometimes not saved as you have experienced.

            Regards
            Sue
            • 18. Re: SQL Server connection options
              585055
              Sue,
              I am getting the following error
              Network error IOException: Connection Refused: connect.

              I have enabled the tcpip at the sqlserver and also disabled the firewall.

              Still cant connect to the sqlserver database.

              Can yo help?

              Thanks,

              Rahul
              • 19. Re: SQL Server connection options
                SueHarper
                The networkio error sounds like either you do not have the driver installed, with the SQL Developer preference set or the SQL Server database is not up and running. Can you verify both?

                Sue
                • 20. Re: SQL Server connection options
                  585055
                  Sue,

                  Thanks, I am able to login now and connect to the sqlserver database.
                  But i am running into another problem.

                  When I try and click on tables , it gives me the following error.

                  Invalid Column Name 'NAME'
                  Vendor Code 207

                  Any suggestions?
                  • 21. Re: SQL Server connection options
                    579942
                    Hey...

                    Even after adding the jar in third party servers.... its giving the same connection failure problem.

                    As someone was telling... Enabled TCP/IP protocol for MS SQL SERVER and restarted the SQL SERVER, Then also the same connection failure problem is coming.

                    Am I missing anything? Help me out???

                    Regards,
                    Naveen
                    • 22. Re: SQL Server connection options
                      585296
                      It sounds like you were having the same problems connecting that I was (and it appears I had done the same things as you - enable TCP, disable firewall, etc) but I am still having problems. Can you please share what you did to make it connect?

                      By the way, I have tried the windows authentication option on a local database (SQL Server 2005) on my machine, using "localhost" and [machine name] as the host name (no quotes or brackets) and also manually entering the sa ID and password. I have verified the port number too.

                      Please share what I might have missed. THANKS!
                      -Wayne

                      Message was edited by:
                      wayneds
                      • 23. Re: SQL Server connection options
                        141565
                        Hi Naveen,

                        I had same problem as you and user579801. I managed to resolve it by doing the following.

                        1. Locate the file called IDEConnections.xml in the folder where you have installed SQL Developer (eg. c:\sql developer\sqldeveloper\system\oracle.jdeveloper.db.connection.11.1.1.0.11.42.62).
                        2. Create the following entries under <connections> tag.
                        <connection>
                        <URL>jdbc:jtds:sqlserver://\\.\;namedPipe=true;instance=SQLDBNam;</URL>
                        <ConnectionName>SQLServer</ConnectionName>
                        <user>SQLUser</user>
                        <ConnectionType>JDBC</ConnectionType>
                        <DeployPassword>false</DeployPassword>
                        <JdbcDriver>net.sourceforge.jtds.jdbc.Driver</JdbcDriver>
                        <RaptorConnectionType>Microsoft SQL Server</RaptorConnectionType>
                        </connection>
                        3. Save the file; Close and re-open the SQL Developer and try connecting.

                        Hope this will solve your problem. Good luck.

                        Regards
                        Raja
                        • 24. Re: SQL Server connection options
                          579942
                          Hey Guys... I'm sorry...

                          I was trying with a default port number 1433, but my server is running at 1778, which I could able to figure it out once ran through REGEDIT.

                          Hey Wayne, Whatever you've told were absolutely Right.

                          Thx, Naveen
                          • 25. Re: SQL Server connection options
                            579942
                            Thanks Rajaram..
                            • 26. Re: SQL Server connection options - named instance
                              601389
                              This took some figuring out but I cracked it in the end....

                              SQLServer tab:

                              Hostname: <servername>
                              Port: <portnumber>/<databasename>;instance=<instancename>

                              so for me the Port field looks like this: 1433/Gaffa;instance=SQL01

                              That should now connect to a named instance SQL Server.

                              Paul Fairhurst
                              • 27. Re: SQL Server connection options - named instance
                                618338
                                Hi,
                                This worked perfectly. I'm connecting to a local install of sql server.
                                Thanks

                                SQLServer tab:
                                Hostname: <servername>
                                Port: <portnumber>/<databasename>;instance=<instancename
                                • 28. Re: SQL Server connection options
                                  627047
                                  Andy,

                                  Put the jar anywhere.....

                                  Run SQL Developer. Click on Tools menu, select
                                  preferences. Select database node, and expand it.
                                  click on third party drivers node. A panel will
                                  appear where you can select the jar file.

                                  This preference loads the jar dynamically. We do not
                                  have a specific dir for third party jars.

                                  Barry
                                  Barry,
                                  I have tried that, I d/l both sets of drivers from MS to connect to MS SQL from ORacle. Referenced the drivers jar files in the appropriate place.
                                  I still get the same error message the other fellow spoke about.
                                  Please help.
                                  • 29. Re: SQL Server connection options
                                    627047
                                    Okay, I got the right jar file.

                                    Now I get the exception error connection refused.

                                    I am using a named instance of SQL2005 on the same machine as oracle is installed.
                                    Firewall is turned off.
                                    And sql server is setup to receive remote connections, both by tcpip and named pipes.

                                    Any other ideas?