1 Reply Latest reply on Apr 2, 2007 4:49 PM by 569639

    Enterprise Manager can't connect to database.

    569639
      All,

      I am new to Oracle and I need to investigate the spatial features for a project I am working on. I had Oracle 10g developer installed but it lacked the spatial features, so I uninstalled it and installed Enterprise (twice). Then I tried to install the Personal edition (twice). Each time, all features (database, SQL*Plus, etc.) work properly except for the Enterprise Manager which can't connect to the agent. After investigation, it appears the EM agent can not start.

      Environment:
      Windows XP SP2 laptop with DHCP.

      I followed instructions for the Microsoft Loopback Adaptor which appears to be configured correctly as the primary network connection and updated the hosts file with the loopback IP and host-machinename:

      Ethernet adapter Local Area Connection 2:

      Connection-specific DNS Suffix . :
      Description . . . . . . . . . . . : Microsoft Loopback Adapter
      Physical Address. . . . . . . . . : 02-00-4C-4F-4F-50
      Dhcp Enabled. . . . . . . . . . . : No
      IP Address. . . . . . . . . . . . : 192.168.10.10
      Subnet Mask . . . . . . . . . . . : 255.255.255.0
      Default Gateway . . . . . . . . . :

      After each install, I notice the following output at C:\oracle\product\10.2.0\db_1\log\d36r14b1\client\css.log:

      2007-03-30 09:28:04.078: [  OCROSD][168]utgdv:1:could not open registry key SOFTWARE\Oracle\ocr os error The system could not find the environment option that was entered.

      2007-03-30 09:28:04.078: [  OCRRAW][168]proprinit: Could not open raw device
      2007-03-30 09:28:04.078: [ default][168]a_init:7!: Backend init unsuccessful : [33]
      2007-03-30 09:28:04.078: [ CSSCLNT][168]clsssinit: error(33 ) in OCR initialization


      It appears OCR is not created during install. Could that be the problem? Install never complained or presented any errors.

      Also,
      C:\oracle\product\10.2.0\db_1\D36R14B1.sybase.com_orcl\sysman\log\emons reports:
      2007-03-29 22:01:57,218 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.ias.ias.IASIntegration
      2007-03-29 22:01:57,515 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.eml.target.slb.common.SLBIntegration
      2007-03-29 22:01:57,578 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.eml.ssl.intg.SSLIntegration
      2007-03-29 22:01:57,671 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.tip.oem.central.domain.ProcessConnectDomainIntg
      2007-03-29 22:01:57,671 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.tip.oem.central.instance.ProcessConnectInstanceIntg
      2007-03-29 22:01:57,671 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.webdb.admin.em.PortalIntegration
      2007-03-29 22:01:57,671 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.webdb.admin.em.SSOIntegration
      2007-03-29 22:01:57,671 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.reports.em.RepIntg
      2007-03-29 22:01:57,671 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.ocs.mntr.target.OcsEmailIntegration
      2007-03-29 22:01:57,687 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.ocs.mntr.target.OcsOidIntegration
      2007-03-29 22:01:57,687 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.ocs.mntr.target.OcsOvfIntegration
      2007-03-29 22:01:57,687 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.ocs.mntr.target.OcsWebconfIntegration
      2007-03-29 22:01:57,687 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.ocs.mntr.target.OcsWirelessIntg
      2007-03-29 22:01:57,703 [Orion Launcher] ERROR app.ContextInitializer contextInitialized.271 - Integration Class not found: oracle.sysman.ocs.mntr.target.OcsCalGrpIntegration
      2007-03-29 22:05:58,187 [EMUI_22_05_57_/console/database/instance/sitemap] ERROR perf.sitemap initializeGeneral.398 - Failed to initialize object: ORA-20206:
      ORA-06512: at "SYSMAN.EMD_DATABASE", line 1165
      ORA-01403: no data found
      ORA-06512: at line 1

      2007-03-29 22:05:58,937 [MetricCollector:HOMETAB_THREAD600:60] ERROR rt.DbMetricCollectorTarget _getAllData.328 - oracle.sysman.emSDK.emd.comm.CommException: Exception in sending Request :: null
      oracle.sysman.emSDK.emd.comm.CommException: Exception in sending Request :: null
           at oracle.sysman.emSDK.emd.comm.EMDClient.getResponseForRequest_(EMDClient.java:1319)
           at oracle.sysman.emSDK.emd.comm.EMDClient.getResponseForRequest(EMDClient.java:1212)
           at oracle.sysman.emSDK.emd.comm.EMDClient.getMetrics(EMDClient.java:637)
           at oracle.sysman.emo.perf.metric.rt.DbHomeTab._getAllData(DbHomeTab.java:324)
           at oracle.sysman.emo.perf.metric.rt.DbHomeTab.getData(DbHomeTab.java:139)
           at oracle.sysman.emo.perf.metric.eng.MetricCached.collectCachedData(MetricCached.java:402)
           at oracle.sysman.emo.perf.metric.eng.MetricCollectorThread._collectCachedData(MetricCollectorThread.java:596)
           at oracle.sysman.emo.perf.metric.eng.MetricCollectorThread.run(MetricCollectorThread.java:320)
           at java.lang.Thread.run(Thread.java:534)



      This is only the beginning of the log. It goes on with repeated connection failures. The beginning looks like a classpath issue.

      Any help please?

      Thanks