1 Reply Latest reply on Apr 6, 2007 5:52 AM by 472559

    Anyone encountered a problem with acts_as_authenticated plugin?

      Config :
      Ruby 1.8.5, Rails 1.2.3
      Developement Server : WebRICK, Lighttpd, Mongrel

      I currently develop a little app, and i installed the
      acts_as_authenticated plugin
      Everything worked fine til yesterday evening. While working on CSS
      sheet, then testing iteratively : nothing worked.
      Checking the development.log file in my Rails app , it shows:

      NameError (uninitialized constant
      dependencies.rb:477:in `const_missing'

      It comes from the :
      include AuthenticatedSystem
      declared in my application.rb file (inside the class)

      When commenting it, no more problems.

      It seems the plugin's libraries are not loaded.
      Wht i do not understand, is i have another plugin installed :
      acts_as_taggable, which works perfectly.

      After searching with Google, i had some configurations tricks in
      environment.rb >
      Dependencies.log_activity = true

      But nothing changes

      Any help is welcome

        • 1. Re: Anyone encountered a problem with acts_as_authenticated plugin?
          I resolved the problem with the help of some folks on irc.
          In fact, after several reinstallation of the plugin, i should run the script :
          ./script/generate authenticated user account

          It should create a folder /lib into : /vendor/plugins/acts_as_authenticated, including the authenticated_system.rb file

          But, this folder has been created in the /log folder.
          Moving the lib folder to the plugin root folder did the trick.