11 Replies Latest reply on Aug 19, 2010 10:08 PM by 432061

    OC4J Configuration issue.


      I installed Oracle 10g Database & AS without a starter database.

      We have custom scripts that will create the database. Right now I have no database.

      When I try to start/stop/status EM, I get the following error:

      i,e ( Any of these 3 )
      /opt/oracle/oracle/product/10.2.0/DB/bin/emctl status dbconsole
      /opt/oracle/oracle/product/10.2.0/DB/bin/emctl start dbconsole
      /opt/oracle/oracle/product/10.2.0/DB/bin/emctl stop dbconsole
      OC4J Configuration issue. /opt/oracle/oracle/product/10.2.0/DB/oc4j/j2ee/OC4J_DBConsole_dev3.symm.com_MV10 not
      Any idea where to look?
        • 1. Re: OC4J Configuration issue.

          I have the following directories under oc4j/j2ee/
          # ls
          OC4J_DBConsole     deploy_db.ini      home               isqlplus           oc4j_applications
          Should I rename OC4J_DBConsole to OC4J_DBConsole_dev3.symm.com_MV10 ?

          • 2. Re: OC4J Configuration issue.
            Did you ever get this resolved? I'm having a similar issue.
            • 3. Re: OC4J Configuration issue.
              I got this issue.
              OC4J Configuration issue. d:\oracle\product\10.2.0\db_1/oc4j/j2ee/OC4J_DBConsole_zhangdekai_ryan not found

              I checked "d:\oracle\product\10.2.0\db_1/oc4j/j2ee/",

              I found I got "OC4J_DBConsole_localhost_ryan" in this directory.

              And then I disconnected my wireless internet,I restart the dbconsole,

              It's ok. I think it used localhost instead. I connected the internet again. The issue came out again.
              So make a copy of OC4J_DBConsole_localhost_ryan , change this copy name to


              And then you start it , you will got another problem,just like above. So slove it as the same.
              start it. it will be ok.
              I know this is not a good way.
              • 4. Re: OC4J Configuration issue.
                i tried this solution and its works,
                first go to run and type CMD (to enter command dos window)
                c:\oracle\yourdatabaselocation\db\bin\emctl status dbconsole
                EM Configuation issue . c:\oracle\yourdatabaselocation\db/yourcomputername.mshome.net_sidname not found

                solution :
                rename c:\oracle\yourdatabaselocation\db\oc4j\j2ee\oc4j_DBConsole_localhost_sidname

                then go to your services from control panel and RESTART your service dbconsole again.
                • 5. Re: OC4J Configuration issue.
                  E:\>set oracle_sid=db01

                  E:\>emctl getemhome
                  Oracle Enterprise Manager 10g Database Control Release
                  Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.

                  If you get above output mean DATABASE configure FOR DB CONTROL otherwise DATABASE is not configure for DB CONTROL and you will see message like "EM Configuration issue".

                  We can configure DATABASE/INSTANCE for DB CONTROL through TWO WAY

                  E:\>set oracle_sid=sh

                  E:\>emctl status dbconsole
                  OC4J Configuration issue. C:\oracle\product\10.1.0\Db_1/oc4j/j2ee/OC4J_DBConsole
                  taj.domainname.localsh not found.

                  Note : dbca ---> Configure Database option ---> Select DB and give PWD ---> Check Mark on Configure database with enterprise manager. ---> Finish
                  E:\>set oracle_sid=sh

                  E:\>emctl status dbconsole
                  Oracle Enterprise Manager 10g Database Control Release
                  Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
                  Oracle Enterprise Manager 10g is running.
                  Logs are generated in directory C:\oracle\product\10.1.0\Db_1/taj.domainname.local_sh/sysman/log

                  You can also Configure Database Control through EMCA command line utility.
                  E:\>set oracle_sid=db01
                  • 6. Re: OC4J Configuration issue.
                    you can solve the problem without renaming the directorys...

                    They really create a directory whose name is composed of hostname (or IP) and the SID!
                    So it breaks whenever you change the hostname. Furthermore this strongly depends on the entries in /etc/hosts which typicall look like so: strongbow.odi.ch strongbow.
                    Oracle will use the first entry after the IP address (of probably the first ethernet device) as the name.
                    So whenever IP or hostname changes you need to alter this line.

                    If you have the FQDN / Hostname problem change the order in your /etc/hosts file

                    If oracle use the Hostname change from FQDN to Hostname after the IP address
           strongbow.odi.ch strongbow => strongbow strongbow.odi.ch strongbow

                    If oracle use the FQDN change from Hostname to FQDN after the IP address
           strongbow strongbow.odi.ch => strongbow.odi.ch strongbow
                    • 7. Re: OC4J Configuration issue.
                      emctl getemhome
                      EM Configuration issue. /aix05oracle/10.2/mcraix05.na.ad.corp_PACKOUTP not found.

                      so it means that database is not configured fo DB control.

                      I got the above messgae when i tried to start DB console.

                      can i use DBCA to configure the DB console for a databse created manually..?

                      kindly help me on this issue..?

                      Edited by: soundar on Feb 24, 2010 10:38 PM
                      • 8. Re: OC4J Configuration issue.
                        Kevin Honde
                        I was getting the following error when I try to run emctl:

                        oracle@myhost:~> emctl status dbconsole
                        OC4J Configuration issue. /opt/oracle/product/11gR2/db/oc4j/j2ee/OC4J_DBConsole_myhost.domain.local_myhost not found.

                        I discovered that some how the /etc/hosts file had enabled entry.

                        Commented out the entry
                        # myhost.domain.local myhost
                        • 9. Re: OC4J Configuration issue.
                          when i isuue the command

                          E:\app\Asanka\product\11.1.0\db_1\oc4j>set ORACLE_HOSTNAME=localhost
                          E:\app\Asanka\product\11.1.0\db_1\oc4j>emctl status dbconsole;
                          EM Configuration issue. E:\app\Asanka\product\11.1.0\db_1/localhost_orcl; not found

                          error gives then

                          i set the
                          E:\app\Asanka\product\11.1.0\db_1\oc4j>set ORACLE_HOSTNAME=asanka
                          emctl status dbconsole;
                          E:\app\Asanka\product\11.1.0\db_1\oc4j>EM Configuration issue. E:\app\Asanka\product\11.1.0\db_1/asanka_orcl; not found
                          error gives

                          E:\app\Asanka\product\11.1.0\db_1\oc4j\j2ee with in this folder
                          OC4J_DBConsole_asanka_orcl folder exists

                          I am working on a standalone machine which is not connected to an any network and i connected to internet with mobile broadband

                          can anybody give me a help to solve this problem
                          • 10. Re: OC4J Configuration issue.
                            I had this issue today. I have just installed my 11G on a RHEL which already has a 10G home. I logged into the 11G Oracle home and when tried to get status of emctl, I got this issue.

                            I think what happens when you give emctl is , it tries to start your other ORACLE_HOME dbconsole, in my case 10G emctl, which showed me this error. Now what I did was , I logged into my 11G oracle_home and , ran ./bin/emctl so that my 11G console gets invoked, it was fine.
                            My EM was up sucessfully,

                            • 11. Re: OC4J Configuration issue.
                              Thank you I configured database options and it's done...