7 Replies Latest reply on Jul 8, 2007 10:28 AM by 15816

    Internal Server Error (NullPointerException) when invoking a Web Service

    583509
      I'm using SOA suite 10.1.3.3 (incl the latest patch set) on Windows XP.

      I've created 3 web services using the wizard interface out of 3 existing WSDL files. The Java code inside the web services is just dummy code.

      I'm testing the web services using the Test Web Service functionality in Oracle Enterprise Manager's Application Server Control.

      The moment I fill in the data and press invoke, I get back the following fault:
      <env:Body>
      <env:Fault>
      <faultcode>env:Server</faultcode>
      <faultstring>Internal Server Error (Caught exception while handling request: java.lang.NullPointerException)</faultstring>
      </env:Fault>
      </env:Body>

      I know that control never reaches inside the services themselves.

      I've even followed the online demo that shows users how to create, deploy and test a Web Service in JDeveloper to make sure that I wasn't doing anything silly.

      What could be wrong? Please help.
      Thanks in advance.
        • 1. Re: Internal Server Error (NullPointerException) when invoking a Web Servic
          583509
          Seems to be a problem in serialization??? What do I do?

          When I invoke the web service from a web proxy client, this is the stack trace:

          QueryGDSAsiaPackage.SearchAirline_fault: java.lang.NullPointerException
               at QueryGDSAsiaPackage.runtime.SearchAirline_fault__LiteralSerializer.doDeserialize(SearchAirline_fault__LiteralSerializer.java:71)
               at oracle.j2ee.ws.common.encoding.literal.LiteralObjectSerializerBase.internalDeserialize(LiteralObjectSerializerBase.java:250)
               at oracle.j2ee.ws.common.encoding.literal.LiteralObjectSerializerBase.deserialize(LiteralObjectSerializerBase.java:159)
               at QueryGDSAsiaPackage.runtime.QueryGDS_Asia_PortType_searchAirline_Fault_SOAPSerializer.deserializeDetail(QueryGDS_Asia_PortType_searchAirline_Fault_SOAPSerializer.java:56)
               at oracle.j2ee.ws.common.encoding.SOAPFaultInfoSerializer.doDeserializeSOAP11(SOAPFaultInfoSerializer.java:132)
               at oracle.j2ee.ws.common.encoding.SOAPFaultInfoSerializer.doDeserialize(SOAPFaultInfoSerializer.java:94)
               at oracle.j2ee.ws.common.encoding.ObjectSerializerBase.deserialize(ObjectSerializerBase.java:180)
               at oracle.j2ee.ws.common.encoding.ReferenceableSerializerImpl.deserialize(ReferenceableSerializerImpl.java:147)
               at oracleesb.QueryGDA_Asia_proxy.runtime.QueryGDS_AsiaSOAP_Stub._readBodyFaultElement(QueryGDS_AsiaSOAP_Stub.java:346)
               at oracle.j2ee.ws.client.StreamingSender._sendImpl(StreamingSender.java:321)
               at oracle.j2ee.ws.client.StreamingSender._send(StreamingSender.java:112)
               at oracleesb.QueryGDA_Asia_proxy.runtime.QueryGDS_AsiaSOAP_Stub.searchAirline(QueryGDS_AsiaSOAP_Stub.java:155)
               at QueryGDSAsiaPackage.QueryGDS_AsiaSOAPClient.searchAirline(QueryGDS_AsiaSOAPClient.java:43)
               at QueryGDSAsiaPackage.QueryGDS_AsiaSOAPClient.main(QueryGDS_AsiaSOAPClient.java:30)
          Process exited with exit code 0.
          • 2. Re: Internal Server Error (NullPointerException) when invoking a Web Servic
            Eric Elzinga
            Does it give good output/return valid when you run the java...instead of the service.
            • 3. Re: Internal Server Error (NullPointerException) when invoking a Web Servic
              583509
              I wouldn't know. Control never reaches my implementation code.

              I'm trying to invoke searchAirline.

              From the stack trace:

              Control enters the main function of the web proxy
              Then to the web proxy client's searchAirline method
              Then goes to the stub code and calls a send
              The stub reads the fault element to try to deserialize it
              After going through a bunch of method calls in the deserialization stack, it fails while calling SearchAirline_fault_LiteralSerializer.doDeserialize

              Everything that's executed in the stack trace is generated by the wizard.

              It doesn't even reach my implementation code.
              • 4. Re: Internal Server Error (NullPointerException) when invoking a Web Servic
                Eric Elzinga
                hmm and searchAirline is some public service...or a local service which you developed too.
                • 5. Re: Internal Server Error (NullPointerException) when invoking a Web Servic
                  583509
                  It's a local service I developed.

                  Starting from a valid WSDL, I used the "Java Web Service from WSDL" project wizard to generate a web service with all the default options. I put in simple, dummy implementation code to return dummy values - no processing, no fancy stuff. Everything seemed to go fine - no errors, no warnings. Just messages saying "Successful".

                  I deployed the service onto my local server. Again, everything went fine.

                  The service showed up as deployed on my server.
                  I then tried to invoke the service through the application server control and hit the nullpointerexception with no stack trace.

                  I then created a web proxy client, again using the wizard. using all default options.
                  When I ran the web proxy client from within JDeveloper, I got a (the same?) nullpointerexception, but this time with a stack trace that seemed to lead to generated code that was supposed to do deserialization.
                  • 6. Re: Internal Server Error (NullPointerException) when invoking a Web Servic
                    583509
                    I've tried everything I possible can including reinstalling the SOA suite and JDeveloper. All I'm trying to do is prove to my customer that Oracle actually works.

                    Oracle fails at even something as simple as creating, deploying and running a Java web service out of an existing/legacy WSDL.

                    Has anyone ever created a Java web service from an existing/legacy WSDL using Oracle ESB/JDeveloper?

                    Does Oracle itself even acknowledge that it works?
                    • 7. Re: Internal Server Error (NullPointerException) when invoking a Web Service
                      15816
                      John,

                      I get something similar that I was just about to ask the forum about.

                      I'm running SOA Suite 10.1.3.1.0. on w

                      I've been given wsdls by a standards body and implementing the services as routing services in ESB (with some BPEL behind doing some stuff).

                      Won't go into the long version, but what I've found is that my request response routing service turns into a one way message if I do an "Apply" in any of the console tabs (e.g. Definition or Properties).

                      Then my interface goes cactus. I have to redeploy from JDev and I'm back in business again. And then I stay away from "Apply" in the console.

                      Seems to happen to SOAP invocation services too. This is a bit awkward as you may want to change or specify the end point location property.

                      Hope this helps you and would appreciate comments from anyone else as I've only just identified this as my issue.

                      Regards

                      Zeljko.