4 Replies Latest reply on Jul 25, 2007 3:20 PM by -K-

    SQL Developer dbms_output buffer

    580450
      I have just downloaded sql developer and evaluating and using the product. One thing that seems to be a real problem is setting the dbms_output buffer. When I try to run a packaged procedure from the gui, the buffer size defaults to 20000. I tried setting the dbms_output buffer from the sql editor but it too, doesn't seem to work in that when I exit sql developer, it reverts back to the 20000 byte default. The help docs - aren't. Any ideas on how to change this other than having to set it each time in the run script? In Navigator, its straight forward, for some reason sql developer isn't, direction please.
        • 1. Re: SQL Developer dbms_output buffer
          Jim Smith
          Not sure I understand. Are you talking about the text field in the dbms_output tab?

          There isn't a preference to change the default permanently. You could request it in the sqldeveloper exchange.

          You could try setting it in a login.sql
          • 2. Re: SQL Developer dbms_output buffer
            -K-
            The feature is still very buggy. For scripts inside a worksheet, I often just lose the output (see the DBMS Output tab, next to the Results tab). Other times I change the size to 500000, but the script overflows at 20000 again. I end up changing the value and pushing the enable output button several times to let sqldev know I'm serious about it.
            Changing the value or enabling the output through the worksheet never worked for me. You say you can change it in your scripts... how do you do that?

            Regards,
            K.
            • 3. Re: SQL Developer dbms_output buffer
              580450
              What I do is put the following in the begin block that is generated from the 'RUN' button.
              exec dbms_output.disable; -- this turns serveroutput off

              exec dbms_output.enable(1000000); -- this sets the buffer size then turns serveroutput on.

              But I have to do it each time I run a package from sql developer.
              • 4. Re: SQL Developer dbms_output buffer
                -K-
                Ah, right, but that only works for sessions started through running stored procedures.
                As Jim said, you can try adding that to login.sql (which sqldev runs automatically on opening whichever session, like sqlplus), but I'm afraid sqldev will overwrite it's own values afterwards...

                Thanks,
                K.