1 2 Previous Next 15 Replies Latest reply: Sep 6, 2007 9:02 AM by 414854 RSS

    esb deployment with ant problem

    414854
      I'm having some trouble deploying an esb process to another server then it was developed on, using ant.
      Using Sjoerd's excellent article (http://www.oracle.com/technology/tech/soa/soa-suite-best-practices/auto-deploy.html) we created ant tasks that deploy our esb process to the server.
      After extracting the deployment plan, deploying to the same server as we're developing on works fine.
      However, if I change the url's in my deployment plan, and deploy to another server, the deployment fails. The exceptions I keep getting are due to the fact that ESB can't find files in a temp location:
      [esb:deployESBProjects] Deployment Attempt Response :
      [esb:deployESBProjects] <deploymentSummary>
      [esb:deployESBProjects]    <message>Entity Deployment Failed</message>
      [esb:deployESBProjects]    <errors>
      [esb:deployESBProjects]       <error code="1049" severity="5">
      [esb:deployESBProjects]          <description>WSDL "esb:///ESB_Projects/temp_ESB_FundeonAsyncEventRouter_srvhw21.kao.sbwinfra.nl/Fundit_wijzigingErkenningRS.wsdl" of service "Fundit.wijzigingErkenning
      RS" is invalid or unaccessible. Following error is thrown by WSDL Parser : WSDL Parsing Failed: org.apache.slide.structure.ObjectNotFoundException: No object found at /files/ESB_Projects/temp_ESB_Fund
      eonAsyncEventRouter_srvhw21.kao.sbwinfra.nl</description>
      [esb:deployESBProjects]          <fix>Ensure that the WSDL is accessible and valid. If the problem persists, Contact Oracle Support.</fix>
      [esb:deployESBProjects]       </error>
      [esb:deployESBProjects]    </errors>
      [esb:deployESBProjects] </deploymentSummary>
      [esb:deployESBProjects]
      Somehow, ESB thinks it's a smart decision to concatenate the servername to this temporary directory called temp_ESB_FundeonAsyncEventRouter_srvhw21.kao.sbwinfra.nl.
      The problem of course is, that this is different for development and test (and acceptance and production and... and...).
      So now in the .esbsvc files there's a hardcoded location pointing to a directory with srvhw21 in it, while we're deploying on another server which has srvhw23.

      Did anyone have this problem? Can I parametrize this setting by e.g. adding something to the deployment plan? Or maybe use variables in the .esbsvc files??

      I tried a 'hack' by creating a symbolic on our (linux) server using ln -s, but that doesn't work (nor is it desirable).

      Any help is much appreciated!
      Cheers,
      Bas
        • 1. Re: esb deployment with ant problem
          206307
          Are you able to use the import/export tool supplied by the ESB? $ORACLE_HOME/integrtation/esb/bin
          • 2. Re: esb deployment with ant problem
            414854
            Hoi Marc,

            That's an good idea. I didn't try this, I'll check and update asap.

            Cheers,
            Bas
            • 3. Re: esb deployment with ant problem
              414854
              Hi Marc,

              Tried export.sh, but it doesn't work. I've had serious issues with the reset.sh script before, and I think I'm running into the same problems again. I'll probably end up setting a lot of environment variables and using ant export or something...

              But why do you suggest using the export/import scripts? Is it necessary to export/import the systems first, before I can deploy using Ant? Why don't all artifacts get deployed? I can see the file in the generated ZIP-file, but it doesn't get copied to the server....

              (rant on..) Sorry for all my questions, but I'm getting pretty annoyed by the very very poor deployment functionality of ESB. As long as you work single developer, single machine it's reasonably okay, but as soon as you want to use ESB seriously (seperated development, test and production environments, automated build scripts, etc.), it really sucks... The poor documentation by Oracle doesn't help. Luckily there are people like Sjoerd, Dave and yourself on here to get things working. (rant off)

              Cheers,
              Bas
              • 4. Re: esb deployment with ant problem
                306887
                Hi Bas,

                we are using ant deployment for ESB services, too. We solved the problem with different environments by using differrent property files for each destination environment.
                In the ESB build file we are using the corresponding ANT variables set in the property file. The bold variables in the following example are taken from that property file:

                <deployESBProjects esbMetadataServerHostname="${esb.hostname}" esbMetadataServerPort="${esb.port}" userName="${admin.user}" password="${admin.password}">
                <esbProject directory="../myNiceEsbProject" />
                </deployESBProjects>

                hope this helps,

                Stefan
                • 5. Re: esb deployment with ant problem
                  512413
                  Hi Bas,

                  I don't know if this is the case in your environment so it might be a long shot from my behalf.

                  Did you use $varName variables ( e.g. your endpoint properties ) while creating / editing your Adapters in ESB? I found out that this was one of the main causes I had serious troubles using ANT and deployment for more then 1 server.
                  • 6. Re: esb deployment with ant problem
                    414854
                    No we're not using variables. As I said we're using deployment plans.
                    The problem was due to the fact that somehow JDeveloper decided to put in a concrete WSDL url pointing to ESB's WebDAV (Jakarta slide). These look something like:
                    esb:///ESB_Projects/temp_ESB_FundeonAsyncEventRouter_srvhw21.kao.sbwinfra.nl/Fundit_wijzigingErkenningRS.wsdl

                    I manually edited all .esbsvc files to only have the wsdl filenames as concrete WSDL url (Fundit_wijzigingErkenningRS.wsdl in case of the previously mentioned url), which solved my problem.

                    I have two TAR's running at the moment to figure out why/how these slide url's are used.

                    Cheers,
                    Bas
                    • 7. Re: esb deployment with ant problem
                      561667
                      Did you find a solution for this? I am running into the same issue and would like to hear about how you solved this issue very much.

                      Thanks.
                      • 8. Re: esb deployment with ant problem
                        561667
                        Thank you for sharing your work around.
                        • 9. Re: esb deployment with ant problem
                          414854
                          As I mentioned, my work-around is to manually change all .esbsvc files from the /esb/slide/tmp_..... path to the filename of the local wsdl.

                          I've spoken with Clemens Utschig, and this is probably a bug. We're currently trying to switch ESB's WebDAV from file-based to database based. You can do this by renaming the Domain_DB.xml file in $ORACLE_HOME/integration/esb/config to Domain.xml, and restarting your instance.

                          Not sure if this will fix the issue, as we're still testing this.

                          HTH,
                          Bas
                          • 10. Re: esb deployment with ant problem
                            571736
                            Hi Bastiaan,

                            What method do you use to create the SOAP Services (presumably) in your ESB System?
                            - Using the concrete WSDL Url; preferred method I believe
                            - Or using the Browse 'Target Service Operation' dialog from the ESB Designer in JDev?

                            As outlined in this blog post (http://technology.amis.nl/blog/?p=2371) the latter method makes us run into problems.

                            Hth,
                            Sjoerd
                            • 11. Re: esb deployment with ant problem
                              414854
                              Hoi Sjoerd,

                              We're using the concrete WSDL url from a SOAP adapter. We've experienced the problems with the browse option as well, that's why we used the concrete wsdl. This worked perfectly, until at a certain point we experienced the problems described in this post.

                              Thanks!
                              Bas
                              • 12. Re: esb deployment with ant problem
                                571736
                                Hoi Bastiaan,

                                Could it be JDev version-specific: which version of JDev are you using?

                                We are not having these problems and use ESB quit a lot. I just want to understand better hoping to prevent this from happening ;-)

                                Cheers, Sjoerd
                                • 13. Re: esb deployment with ant problem
                                  414854
                                  Hi Sjoerd,

                                  We're on 10.1.3.3 all the way... Actually, the problem seems to have been introduced when we migrated to 10.1.3.3 from 10.1.3.2. We double checked and verified our upgrades, they're fine.. If you're interested, here's the TAR#s we've opened on this issue:

                                  - 6429987.993 ERRORS WHEN DEPLOYING THROUGH DEPLOYMENT PLAN USING ANT
                                  - 6464735.992 ESB IS INCORRECTLY CACHING ARTIFACTS

                                  The first one is about the deployment issues, the second a related problem with the deployed ESB projects running against old XSD versions..

                                  The caching issue seems to be solved by switching to database persistence for slide, but we'll do some more testing on that to be sure.

                                  HTH,
                                  Bas
                                  • 14. Re: esb deployment with ant problem
                                    571736
                                    Hi Bastiaan,

                                    Thanks for sharing these. Although I cannot access the TARs (once used to this as an Oracle employee, take it from me that this is a serious drawback of leaving Oracle Corporation ;-)) from the descriptions I get an idea of what you are facing.

                                    Thanks again,
                                    Sjoerd
                                    1 2 Previous Next