0 Replies Latest reply on Aug 24, 2007 5:48 AM by 474459

    oo4o in a COM+ server: client app fails when connecting from other machine


      I'm building an COM+ server application that queries an Oracle 8.1.6 database using oo4o and returns the result to clients calling the COM+ methods. This application was firstly designed using ADO and MS OLEdb but I ran in a few deadlock problems that couldn't be fixed. So it's now implemented using Oracle Inprocess Server: The COM+ Server application calls CreateOleObject('OracleInProcServer.XOraSession') to access oo4o.

      The problem I have is that when I run the server and the client application in the same machine everything works fine. But when I try to use the client in any other machine I get errors: "RPC Server is not available". If I run the old version based on ADO everything works fine (except for the occasional deadlock ;) )

      Any comments/ideas will be very much appreciated.

      If anyone is interested in the Delphi implementation for oo4o I'm more than happy to post it here.