2 Replies Latest reply on Sep 6, 2007 2:53 AM by 590519

    rsh is not working

    178210
      Logged on as root
      OS:RedHat AS 4

      $rpm -qa|grep rsh
      $rsh-0.17-25.3

      $chkconfig rsh on
      error reading information on service rsh; No such file or directory


      What is the problem, How I can enable rsh and rlogon?
        • 1. Re: rsh is not working
          Ivan Kartik
          You need to install "rsh-server" package.
          • 2. Re: rsh is not working
            590519
            1)install packages
            #up2date -i rsh-server
            # rpm -qa|grep rsh
            rsh-0.17-25.4
            rsh-server-0.17-25.4 <------------------rsh server package.

            2) setting disable from "yes" to "no" in the /etc/xinetd.d/rsh
            # cat /etc/xinetd.d/rsh
            # default: on
            # description: The rshd server is the server for the rcmd(3) routine and, \
            # consequently, for the rsh(1) program. The server provides \
            # remote execution facilities with authentication based on \
            # privileged port numbers from trusted hosts.
            service shell
            {
            disable = no <----------------disable from "yes" to "no"
            socket_type = stream
            wait = no
            user = root
            log_on_success += USERID
            log_on_failure += USERID
            server = /usr/sbin/in.rshd

            3)append "rsh" to /etc/securetty
            # echo "rsh" >> /etc/securetty
            4)append rsh client ip/hostname to /root/.rhosts
            echo "rsh_client_ip root" >> /root/.rhosts

            5)restart xinted.
            # /etc/init.d/xinetd restart

            6)rsh from rsh client host, setting in step 4.

            Message was edited by:
            Changhai