9 Replies Latest reply on Aug 24, 2009 5:45 AM by 716329

    Internal Server Error

    abidalim
      how to resolve following error in application express ??
      The server encountered an internal error or misconfiguration and was unable to complete your request.
      Please contact the server administrator, you@your.address and inform them of the time the error occurred, and anything you might have done that may have caused the error.

      More information about this error may be available in the server error log.

      this is log files error.
      mod_plsql: DAD '/pls/apex' is disabled because of misconfiguration. Please refer to the log entries during server startup for more information.

      this mis my DAD file configuration
      Alias /i/ "d:\oracle\product\10.2.0\db_11\Apache\Apache\images\"
      AddType text/xml xbl
      AddType text/x-component htc

      <Location /pls/apex>
      Order deny,allow
      PlsqlDocumentPath docs
      AllowOverride None
      PlsqlDocumentProcedure wwv_flow_file_mgr.process_download
      PlsqlDatabaseConnectString aa-notebook:1522:ora10g ServiceNameFormat
      PlsqlNLSLanguage AMERICAN_AMERICA.AR8MSWIN1256
      PlsqlAuthenticationMode Basic
      SetHandler pls_handler
      PlsqlDocumentTablename wwv_flow_file_objects$
      PlsqlDatabaseUsername APEX_PUBLIC_USER
      PlsqlDefaultPage apex
      PlsqlDatabasePassword password
      Allow from all
      </Location>
        • 1. Re: Internal Server Error
          135285
          Hi Abidalim,

          after taking a quick look at your DAD configuration...
          PlsqlNLSLanguage AMERICAN_AMERICA.AR8MSWIN1256
          According to http://download-west.oracle.com/docs/cd/B32472_01/doc/install.300/b32468/post_inst.htm#CHDHCBGI

          The PlsqlNLSLanguage setting determines the language setting of the DAD. The character set portion of the PlsqlNLSLanguage value must be set to AL32UTF8, regardless of whether or not the database character set is AL32UTF8. For example:
          ...
          PlsqlNLSLanguage AMERICAN_AMERICA.AL32UTF8
          ...

          That's something you should fix, but I don't think that's your real problem.

          According to the error message you should also check

          mod_plsql: DAD '/pls/apex' is disabled because of misconfiguration. Please refer to the log entries during server startup for more information.

          Have you done that? There you maybe get more meaningful error information.

          Patrick
          ----------------------------------------------------------------------------------------------------
          My APEX Blog: http://inside-apex.blogspot.com
          The ApexLib Framework: http://apexlib.sourceforge.net
          The APEX Builder Plugin: http://sourceforge.net/projects/apexplugin/
          • 2. Re: Internal Server Error
            didub2
            Did you finally succeed? I got strictly the same strange behaviour. According to the time I spent to take care of my installation process, it's really disappointing.

            Any idea, should be greatly appreciate before Christmas Day.
            • 3. Re: Internal Server Error
              438381
              Take a look at the Apache log/error file for any errors .

              Also, if you could post your DAD file here somebody may be able to help you.

              Varad
              • 4. Re: Internal Server Error
                472952
                Hi,
                I have the same problem...

                My dads.conf:
                Alias /i/ "C:\oracle\product\10.2.0\http_1\Apache\Apache\images\"
                AddType text/xml xbl
                AddType text/x-component htc

                <Location /pls/htmldb>
                Order deny,allow
                PlsqlDocumentPath docs
                AllowOverride None
                PlsqlDocumentProcedure wwv_flow_file_mgr.process_download
                PlsqlDatabaseConnectString angelswar:1521
                PlsqlNLSLanguage AMERICAN_AMERICA.AL32UTF8
                PlsqlAuthenticationMode Basic
                SetHandler pls_handler
                PlsqlDocumentTablename wwv_flow_file_objects$
                PlsqlDatabaseUsername APEX_PUBLIC_USER
                PlsqlDefaultPage apex
                PlsqlDatabasePassword      mypw
                Allow from all
                </Location>
                --
                Error page:
                http://angelswar:7777/pls/htmldb/ shows the following error:

                500 Internal Server Error
                The server encountered an internal error or misconfiguration and was unable to complete your request.

                Please contact the server administrator, you@your.address and inform them of the time the error occurred, and anything you might have done that may have caused the error.

                More information about this error may be available in the server error log.
                --
                My error_log:
                mod_plsql: DAD '/pls/htmldb' is disabled because of misconfiguration. Please refer to the log entries during server startup for more information.
                --
                access_log:
                192.168.0.10 - - [24/Feb/2008:22:54:59 +0100] "GET /pls/htmldb/ HTTP/1.1" 500 650


                Is there any other error logfile i can check ?
                And where can i check the numbers 500 and 650 are these error numbers ?
                But wher can i look them up.

                angelswar is my pc and my db name and my tnsname entry and my service name
                tnsping can be done
                http server is on (http://angelswar:7777/ is working)

                I alread tried for PlsqlDatabaseConnectString
                PlsqlDatabaseConnectString angelswar:1521:angelswar ServiceNameFormat
                But that brings the same error.

                I also tried to connect to APEX_PUBLIC_USER with "mypw" and it works.

                I had this problems several times but can't remember how to solve it.

                Thanks for any help.
                • 5. Re: Internal Server Error
                  369783
                  Just for the heck of it, how about changing
                  PlsqlDatabaseConnectString angelswar:1521
                  to this:
                  PlsqlDatabaseConnectString angelswar TNSFormat

                  Remember to stop and start the web server after making changes.

                  Bill Ferguson
                  • 6. Re: Internal Server Error
                    472952
                    Hi,

                    I changed the ConnectString in dads.conf and it works, so this is one part of my solutions.
                    PlsqlDatabaseConnectString angelswar TNSFormat

                    I found a different solution and my mistake.

                    First solution:
                    I didnt mention that error log file from opmn ("http_home"/opmn/logs/HTTP_Server~1)
                    said:
                    mod_plsql: DAD /pls/htmldb disabled => Duplicate DAD
                    that was my mistake:
                    i made a include into httpd.conf file for my dads.conf
                    thats wrong, cause the dads.conf will be automaticly included somehow.
                    so i change connectstring as mentioned above
                    and it worked.
                    (Note: If you do the include correct you get a readable error log in opmn log file and then i mentioned my tried connectString was incorrect)

                    Second solution:
                    I made a year ago another installation from an older apex version, and it said you should
                    make a marvel.conf in <http_home>/apache/modplsql/conf/marvel.conf and insert all entries just like in dads.conf.
                    One different is that you have to make an include in httpd.conf

                    Note:
                    I can remember that the older installation guide said that the end sign "/" of this line:
                    Alias /i/ "C:\oracle\product\10.2.0\http_1\Apache\Apache\images/"
                    shoudl be a /
                    but in i tested it and this line works, too
                    Alias /i/ "C:\oracle\product\10.2.0\http_1\Apache\Apache\images\"
                    Just if you have some prblems, so try to replace \ with /

                    Hope i could help some other peoples having same problems.

                    Thanks to wbfergus.

                    Sebastian

                    PS my working dads.conf:

                    Alias /i/ "C:\oracle\product\10.2.0\http_1\Apache\Apache\images/"
                    AddType text/xml xbl
                    AddType text/x-component htc
                    <Location /pls/htmldb>
                         SetHandler pls_handler
                         Order deny,allow
                         Allow from all
                         AllowOverride None
                         PlsqlDatabaseUsername APEX_PUBLIC_USER
                         PlsqlDatabasePassword yourpw
                         PlsqlDatabaseConnectString angelswar TNSFormat
                         PlsqlDefaultPage htmldb
                         PlsqlDocumentTablename wwv_flow_file_objects$
                         PlsqlDocumentPath docs
                         PlsqlDocumentProcedure wwv_flow_file_manager.process_download
                         PlsqlAuthenticationMode Basic
                         PlsqlNLSLanguage AMERICAN_AMERICA.AL32UTF8
                    </Location>
                    • 7. Re: Internal Server Error
                      369783
                      Glad you got it working again.

                      Bill Ferguson
                      • 8. Re: Internal Server Error
                        490074
                        Thanks for the solution... I was also stuck on this in the exact same place!
                        • 9. Re: Internal Server Error
                          716329
                          I have this problem too.
                          I followed your solutions but there is error again.
                          Notice that I use port 1522 for listener
                          -----
                          My dads.conf file is :
                          Alias /i/ "/u01/app/oracle/product/10.2.0/ohs/Apache/Apache/images/"
                          AddType text/xml xbl
                          AddType text/x-component htc

                          <Location /pls/apex>
                          Order deny,allow
                          PlsqlDocumentPath docs
                          AllowOverride None
                          PlsqlDocumentProcedure wwv_flow_file_mgr.process_downloadd
                          PlsqlDatabaseConnectString s2.rs.tce.ir:1522:APC ServiceNameFormat
                          PlsqlNLSLanguage AMERICAN_AMERICA.AL32UTF8
                          PlsqlAuthenticationMode Basic
                          SetHandler pls_handler
                          PlsqlDocumentTablename wwv_flow_file_objects$
                          PlsqlDatabaseUsername APEX_PUBLIC_USER
                          PlsqlDefaultPage apex
                          PlsqlDatabasePassword 6731558
                          PlsqlRequestValidationFunction wwv_flow_epg_include_modules.authorize
                          Allow from all
                          </Location>
                          -----