2 Replies Latest reply: Jul 25, 2012 7:39 AM by 800528 RSS

    Need Help on Date Format in Apps

    546613
      Hi,

      I am getting error message ORA-01861:literal does not match format string.

      My concurrent program has 5 parameters. one of this is Date datatype. I have attached FND_STANDARD_DATE value set for that parameter.

      when i submit the concurrent program, i am getting the above error.

      I wrote like this query in cursor declaration
      SELECT * FROM <TABLE>
      WHERE <COLUMN.DATE datatype,'DD/MM/YYYY'>(Retieving Database) = <PARAMETER.DATE.datatype,'RRRR/MM/DD'>(this is fnd_standard_date)

      Please any one guide me to solve above qurery.

      Thanks in advance
        • 1. Re: Need Help on Date Format in Apps
          13808
          Try using this :
          WHERE <your date column> =
          trunc(to_date(<date parameter>,'YYYY/MM/DD HH24:MI:SS'))

          FND_STANDARD_DATE format is character with format 'YYYY/MM/DD HH24:MI:SS'
          • 2. Re: Need Help on Date Format in Apps
            800528
            hi

            i have similar to above thing


            i solved when i have to pass date value to pl/sql procedure that is in fnd_standard_date (yyyy/mm/dd hh24mi ss) format vice versa now i want to pass value from

            program paramter form value type as sql statment and default value as select func(sysdate) from dual

            i want to know that sysdate is what format is it same fnd_standard_date (but i tried it is showning APP-FND-01564: ORACLE error 904 in FDFGDF)

            i tried lot of thing no solution



            please help me
            in this regard
            thankd in advance ....