This discussion is archived
2 Replies Latest reply: Aug 20, 2007 6:02 PM by 3004 RSS

Data Load Rules - Header

3004 Newbie
Currently Being Moderated
How can I configure a Data Load Rule File to utilize column headers in the load file? The load file is created from a Report Script and looks like the following:<BR><BR>tab tab tab tab tab tab <BR>tab tab tab tab Jan'07 Feb'07<BR>Actual Dollars No_Department Cust_1234 4567.23 5678.45<BR>Actual Dollars No_Department Cust_5678 8767.23 7878.45<BR><BR><BR>The first row of the load file is always blank. (Not sure how to eliminate this. SUPMISSINGROWS in report script doesn't help.)<BR><BR>The second row contains the proper column headings for fields 5 & 6. However, I can't seem to configure the Rule File to properly use these headings (Jan'07 and Feb'07) as the header names.<BR><BR>DBAG refers to the 'Data Source Properties' box and the 'Data source header records' options but I'm not having any luck.<BR><BR>Any suggestions?<BR>
  • 1. Data Load Rules - Header
    3004 Newbie
    Currently Being Moderated
    <p>If I understand correctly, what I would do is ignore the firstrow completely (not even use it as a header). You can do this usingthe "number of lines to skip" parameter.</p><p> </p><p>Then on your dataload, the column holding "Jan" data Iwould have the load rule point to your January Time Member, and forthe column named "Feb" point to your February timemember.</p><p> </p><p>You may notice that if you choose to "Skip first row"or "ignore row" etc, that essbase doesn't grey out thatrow or hide it in any fashion in the load rule editor. Never fear,it should handle it properly when actually running the rule.</p>
  • 2. Data Load Rules - Header
    3004 Newbie
    Currently Being Moderated
    Another option is to use the QUOTEMBRNAMES command in your report script and skip the load rule altogether. Of course that requires that all your member names line up in the target database, or that you can use the RENAME command in your report script to make them line up - RENAME will ignore the QUOTEMBRNAMES command, unfortunately and there appears to be no way to make the renamed version of the name quote-enclosed. If your target DB member names don't require quotes, then RENAME also works just fine.<BR><BR>You can possibly get rid of the first row in the results file with the SUPPAGEHEADING command in the report script.