6 Replies Latest reply: Nov 18, 2007 7:32 PM by Karl Weller RSS

    10g R2 dbca fails in Solaris 10

    600602
      Hi,

      I am facing the following problem in Solaris 10 SPARC 64 bit machine.

      1.     Downloaded Oracle 10g R2 installable from oracle
      2.     Created user oracle and group dba and modified project settings and permissions as per quick installation guide
      3.     Installation of software is successful. But dbca fails with following error message.
      ORA-19624: operation failed, retry possible
      ORA-19870: error reading backup piece /vol1/ora10gr2/product/10.2.0/Db_1/assistants/dbca/templates/Seed_Database.dfb
      ORA-19587: error occurred at reading 0 bytes at block number 1
      ORA-27091: unable to queue I/O
      ORA-27067: size of I/O buffer is invalid

      4.     I also tried creating scripts using dbca and running it manually. It fails with following error message in trace file

      Corrupt block 1 found during reading backup piece, file=/ora10gr2/ora10gr2/product/10.2.0/Db_1/assistants/dbca/templates/Seed_
      Database.dfb, corr_type=3
      5.     Creation of custom database also fails with similar error message

      It is Solaris 10 (Solaris 10 11/06 s10s_u3wos_10 SPARC) machine with patch level 125100-05 . Please help.

      Regards
      Vijoy
        • 1. Re: 10g R2 dbca fails in Solaris 10
          Madrid
          In both cases, there it is shown a block corrupt for database file 1, that means the install media was originally corrupt and the corruption was at the seed database files.

          Check the media consistency to discover if corruption was originally there. In case it was redownload the zip file for solaris and unzip it somewhere else. Look for the seed database files at the ORACLE_HOME/assistants/dbca/templates and replace them.

          When you created by scripts, ensure the option where the scripts only is selected, do not try to create the database by means of the dbca, run scripts from the OS.


          ~ Madrid
          • 2. Re: 10g R2 dbca fails in Solaris 10
            600602
            Thanks Madrid,

            I also tried re-downloading and extracting files in a different system and installing from the NFS mounted path. Before extracting, I checked the checksum value of cpio.gz file and it is matching with the value given in Oracle site. But still I am facing the same issues. Is this something related to OS block size in Solaris 10?

            Regards
            Vijoy
            • 3. Re: 10g R2 dbca fails in Solaris 10
              Madrid
              It looks like it is a bug, however this was related to a 10gR1 database, please verify.

              Error Ora-19624 On Create Database with DBCA When Installing Oracle10g
                   Doc ID:      Note:305411.1

              There it states privilege problems.


              ~ Madrid
              • 4. Re: 10g R2 dbca fails in Solaris 10
                600602
                Hi,

                Even I reformatted the system with latest Solaris 10 release and tried. Still I am facing the same Control file corruption..

                Error in in trace file says about control file corruption

                Detected a media corrupt controlfile block (block# 9) in '/u01/ora10gr2/c3.ctl'

                Can anybody suggest some other troubleshooting steps.

                Regards
                Vijoy
                • 5. Re: 10g R2 dbca fails in Solaris 10
                  Madrid
                  dbca shouldn't lead to corrupted blocks at the controlfile, unless there are some other issues with the IO system. DBCA doesn't have a stored controlfile, so it could not be diagnosed as a media origin failure.

                  It points to physical damage, and no more corrupted blocks can be found, probably because database cannot be started. Check if you can redirect database creation to another partition.

                  I suggest you to generate creation scripts from dbca, so you can cotnrol creation procedure, and retry.


                  ~ Madrid
                  • 6. Re: 10g R2 dbca fails in Solaris 10
                    Karl Weller
                    My user was in the oinstall group, I changed the primary group to dba and made sure my raw devices were owned by oracle:dba and dbca got passed the error described here.

                    Karl