6 Replies Latest reply: Oct 28, 2007 5:03 PM by 604983 RSS

    Installation of more than one ILM Assistant on the same machine

    604983
      Hi,
      I have two Oracle 10g test databases and Application Express for each database installed on the same machine (Windows). These are working fine.
      I have also installed ILM Assistant for one of the databases without any problems and it is also working fine.
      Now, I'm trying to install ILM Assistant for the second database, but I get the following errors:

      DECLARE
      *
      ERROR in line 1:
      .ORA-01119: Error in creating database file 'ILM_TOOLKIT_ILM_ASSISTANT.f'.
      ORA-27086: unable to lock file - already in use
      OSD-00002: additional error information
      O/S-Error: (OS 32) The process cannot access the file because it is being used
      by another process.
      ORA-06512: in line 19

      Is it not possible to have 2 ILM Assistants on the same machine or is this error about something else?
      Thanks.
        • 1. Re: Installation of more than one ILM Assistant on the same machine
          543302
          Hi,

          Are you using the same location for your tablespace datafiles for both databases? If so, the second installation may be trying to reuse the datafile from the 1st installation.

          For the second install, try using a different tablespace name for the ILM Assistant. This should create a new datafile that will be different from the 1st install.

          Thanks,

          Greg
          • 2. Re: Installation of more than one ILM Assistant on the same machine
            604983
            Hi,
            My datafiles are in the following locations:
            D:\oracle\product\10.2.0\oradata\prod1 - for the 1st database
            D:\oracle\product\10.2.0\oradata\prod2 - for the 2nd database

            I tried what you suggested. Everything seemed to be going fine at first - the ILM_TOOLKIT user and the tablespace were created - but somewhere along the way, I get an ORA-12541: TNS: No listener error.
            I then tried to uninstall everything, but I get the same No listener error. (The ILM_TOOLKIT user was deleted but not the tablespace.)
            I'm not sure why I am getting this error - Database Control shows that my listener is up, and I even restarted my listener a few times.
            Thanks.
            • 3. Re: Installation of more than one ILM Assistant on the same machine
              604983
              Hi,
              I have managed to solve this problem. When I use none for the connect string, for example,

              @ilma_install password tablespace none

              both, install and uninstall are successful!
              But when i use the connect string, example...

              @ilma_install password tablespace PROD1

              I get the No listener error. I know this is a local install/uninstall, but the connect string is in the listener.ora & tnsnames.ora, so why would i get this error?
              Thanks.
              • 4. Re: Installation of more than one ILM Assistant on the same machine
                604983
                Hi,
                I have another question....
                In the ILM Assistant installation guide, it states that...

                " .... You need to specify the tablespace to use as the default tablespace for the ILM_TOOLKIT user. If you specify a tablespace that exists, the ILM Assistant installation uses it. If you specify a tablespace that doesn’t exist, the ILM Assistant installation creates it and uses it."

                If this is the case, why would I get the 'error in creating database file/already in use' error when I use the same tablespace name as the 1st installation? Shouldn't the installation then use the tablespace from the 1st installation?
                Thanks.
                • 5. Re: Installation of more than one ILM Assistant on the same machine
                  543302
                  Hi,

                  We indeed reuse the tablespace if it already exists; however, in your case, I believe the error occurs because we are trying to reuse the underlying data file while creating a new tablespace. For the next release, I'll remove this feature of the tablespace create operation so that we don't generate this kind of confusion.

                  Hope this helps!

                  Greg