1 2 3 Previous Next 40 Replies Latest reply: Jan 29, 2009 5:20 PM by jpiwowar RSS

    Oracle 10.1 + Leopard

    491831
      Just upgraded from 10.4 (Tiger) to 10.5 (Leopard) today on a G5 iMac (powerPC chip). I had Oracle 10.1 for PPC installed and working fine with 10.4, but when I try to start it under leopard it crashes the machine. Guess I was a bit optimistic in hoping it would "just work".

      Anyone had any success (yet) in getting Oracle 10.1 working under Leopard? Will have a go at re-installing using the Leopard version of the developer toolkit.
        • 1. Re: Oracle 10.1 + Leopard
          491831
          No luck - tried relinking (using gcc 3.3, which was necessary before) and also tried the trick of renaming libnnz10.dylib beforehand and then renaming it back afterwards (as described in other posts about 10.1 on OSX) since the symptoms and error messages I got initially were identical to those where this solved the problem on earlier releases of OSX. That still causes Leopard to crash, though. So Oracle 10.1 + OSX 10.5 looks like a non-runner (at least on PPC).
          • 2. Re: Oracle 10.1 + Leopard
            Ronald Rood
            Did you try installing gcc 3.2 ?
            With a little luck this helps ...
            (forget about this I mixed up versions of gcc :-()

            regards,
            Ronald
            http://ronr.nl/unix-dba
            • 3. Re: Oracle 10.1 + Leopard
              491831
              No - didn't try gcc 3.2 : that doesn't come in the Leopard Xcode toolkit. And 3.3 is only installed if you specifically request it.
              Not sure why 3.2 would help get it working under Leopard when 3.3 was fine for Tiger.
              • 4. Re: Oracle 10.1 + Leopard
                Ronald Rood
                $>uname -a
                Darwin ronald-roods-power-mac-g4.local 9.0.0 Darwin Kernel Version 9.0.0: Tue Oct 9 21:37:58 PDT 2007; root:xnu-1228~1/RELEASE_PPC Power Macintosh
                test10 ronr@ronald-roods-power-mac-g4:/Users/oracle/oradata
                $>sqlplus "/ as sysdba"

                SQL*Plus: Release 10.1.0.5.0 - Production on Mon Oct 29 20:52:17 2007

                Copyright (c) 1982, 2005, Oracle. All rights reserved.

                Connected to an idle instance.

                SQL> startup
                ORACLE instance started.

                Total System Global Area 612368384 bytes
                Fixed Size 780656 bytes
                Variable Size 300684944 bytes
                Database Buffers 310378496 bytes
                Redo Buffers 524288 bytes
                Database mounted.
                Database opened.
                SQL> select * from v$instance;

                INSTANCE_NUMBER INSTANCE_NAME
                --------------- ----------------
                HOST_NAME
                ----------------------------------------------------------------
                VERSION STARTUP_T STATUS PAR THREAD# ARCHIVE LOG_SWITCH_
                ----------------- --------- ------------ --- ---------- ------- -----------
                LOGINS SHU DATABASE_STATUS INSTANCE_ROLE ACTIVE_ST
                ---------- --- ----------------- ------------------ ---------
                1 test10
                ronald-roods-power-mac-g4.local
                10.1.0.5.0 29-OCT-07 OPEN NO 1 STOPPED
                ALLOWED NO ACTIVE PRIMARY_INSTANCE NORMAL


                SQL>

                I got it working wihout any problems. How did you install the software ? My installation is done using oracle:dba. After the leopard installation I just had to add the 'dba' group with the same groupid as it had in tiger. Assigned the group to my dba account. after that I was able to start oracle 10.1.0.5 on Leopard.

                regards,
                Ronald
                http://ronr.nl/unix-dba
                • 5. Re: Oracle 10.1 + Leopard
                  150819
                  I am having the same issues

                  After the upgrade I tried to start oracle and it crashed Leopard. I did a re install of oracle following the same instructions I used for Tiger.

                  Firstly XCode no longer installs gcc 3.3 as standard so I did that. Then gcc_select has gone in Leopard (thanks). I then tried to do switch gcc by changing the symbolic link from 4 to 3.3 in usr/bin. This is not really my area of knowledge so i am not sure if I have to do something else.

                  I then tried to do a re-install and it failed during the link.

                  I will post the logs up when I get home.
                  • 6. Re: Oracle 10.1 + Leopard
                    Ronald Rood
                    Do you run on leopard server of on the client ? If on the server, do you use ASM ? I run an my client and have no difficulties at all. Maybe I have to do some more testing to get the crash but once the environment was ok (PATH, ORACLE_HOME, uid's, gid's) all was running without a problem. No need to re-install oracle at all.

                    regards,
                    Ronald
                    http://ronr.blogspot.com
                    • 7. Re: Oracle 10.1 + Leopard
                      150819
                      This is what I get during install

                      "Errors in invoking target 'install' of makefile "........./db_1/sqlplus/lib/ins_sqlplus.ml"

                      ld: file not found: /Users/oracle/service/u01/app/oracle/product/10.1.0/db_1/lib/libclntsh.dylib.10.1
                      make: *** [sqlplus] Error 1

                      End output from spawned process.
                      ----------------------------------
                      Exception thrown from action: make
                      Exception Name: MakefileException
                      Exception String: Error in invoking target 'install' of makefile '/Users/oracle/service/u01/app/oracle/product/10.1.0/db_1/sqlplus/lib/ins_sqlplus.mk'. See '/Users/oracle/service/u01/app/oracle/oraInventory/logs/installActions2007-10-30_12-42-09AM.log' for details.
                      Exception Severity: 1
                      • 8. Re: Oracle 10.1 + Leopard
                        606209
                        I have the exact same problem.

                        Tried updating Tiger to Leopard and during start get "kernel panic"

                        Tried "archive & install", installing Xtools & gcc 3.3 and start and get "kernel panic"

                        Tried relinking all on Leopard using gcc 3.3 and start get "kernel panic"

                        Tried going back to Tiger, getting fresh copy of 10.1.0.3 and 10.1.0.5 update. Reinstalled 10.1.0.3 and updated to "10.1.0.5", relink all (moving libnnz10.dynlib per previous instructions), and using dbca to create brand new 10.1.0.5 database. Tested that Oracle would start ok in Tiger. Copied this Oracle install to Leopard disk, checked that u+s permissions were set correctly in binaries, made sure I had the "dba" with same gid setup. Tried starting and got "kernel panic".

                        Checked kernel parameters and the shared memory and semaphore parameters look the same using sysctl -a. I'm at a complete loss as to what to try next. Ronald is very fortunate :-). There must be something different but I've not been able to figure it out so far.

                        Rand
                        • 9. Re: Oracle 10.1 + Leopard
                          Ronald Rood
                          Rand,

                          there are some differences. You copied your ORACLE_HOME to the leopard disk. I did not, I just left it were it was and made sure that I created all users and groups I had in tiger. Use oraenv to set your environment. Make a symbolic link from the old /etc/oratab to /etc (or copy it). I used the symlink so I can easily switch back to tiger and have the samen administration there. Make sure that the path to your ORACLE_HOME as mentioned in /etc/oratab is valid. To do this I used the full path /Volumes/disk1/Users/oracle/.. and not /Users/oracle ...

                          I hope this helps,
                          Ronald
                          http://ronr.blogspot.com
                          • 10. Re: Oracle 10.1 + Leopard
                            606209
                            Thanks Ronald. I'll try what you suggest and see what happens.

                            Rand
                            • 11. Re: Oracle 10.1 + Leopard
                              68535
                              What about the Oracle Instant Client 10gR1 running as a PowerPC application on Leopard:
                              Does that work at least or are we back to stone age on the Mac platform?
                              • 12. Re: Oracle 10.1 + Leopard
                                386814
                                I have been running the 10gR1 Instant client on Leopard on an Intel Mac. I used sqlplus at the unix command line in terminal and it worked fine, Shows up as PowerPC application in the Activity Monitor.

                                I also tried JDeveloper and SQLDeveloper - all work fine.

                                Paul
                                • 13. Re: Oracle 10.1 + Leopard
                                  606209
                                  I tried Ronald's excellent suggestions but without success, however, I finally found a solution that works for me.

                                  The problem appears to be with the "processes" parameter in the initialization file. Mine was set to 400. I eventually stopped getting the "kernel panic" by setting "processes" to 50. Somewhere between there and 75 it started getting the "kernel panic" again.

                                  This may not be a solution for everyone since one may need more than 50 processes, but it's a start. There may also be some other kernel parameter that needs to be adjusted so that Oracle's parameter can be increased, but it doesn't appear to be related to kern.maxproc or kern.maxprocperuid as I have those set to 2068 and my ulimit is set to 2048.

                                  So if you can get processes lowered to around 50, you may be able to start Oracle on 10.5.

                                  Rand
                                  • 14. Re: Oracle 10.1 + Leopard
                                    491831
                                    Huge thanks to both Ronald (for proving it could be done) and Rand (for actually pointing out how) - I've now got Oracle running again under Leopard, all be it with processes set at 50.

                                    If anyone knows why this now seems to be an upper limit for Oracle, or what kernel params need to be changed to increase it, that'd be great.
                                    1 2 3 Previous Next