4 Replies Latest reply on Oct 19, 2006 10:17 AM by mlipman

    No results displayed !!!


      I use Ultrasearch on windows XP.
      I configured the tool and indexed some html documents. You can see below on document that I have indexed.
      I received no errors, but when I tried to use
      and I search a word that is existing in the document, I have no results displayed.

      I checked the tables and the only tables that contain some datas are:

      What can I check to be able to have a result displayed ?
      Does anybody have an idea ?

      Thank you in advance for your answers.

      Oracle Ultra Search, Crawler: Release Production
      Copyright B) 2001, 2002, Oracle Corporation. All rights reserved.

      ================== Crawling settings ==================
      Reading configuration file from C:\oracle\ora92/ultrasearch/data/config/crawler.dat
      Agent = Oracle Ultra Search
      User = ULTRASEARCH
      Database connect string = jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=ltfra)(PORT=1521)))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ora92)))
      Data source type is FILE
      Data source is "test1"
      Number of crawling threads = 20
      Queue table = I1S43
      URL table = WK$URL
      Maximum documents to crawl = no limit
      Maximum depth to crawl = no limit
      Locale of the crawler message is "en_US"
      Document read timeout threshold = 30 second(s)
      Crawler default character set is "8859_1"
      Crawler default language is "en"
      Auto language detection is on
      Verbose mode is on
      Caching on: directory = c:\tmp\ultrasearch\I1S43, max size = 5, action = begin ctx_ddl.sync_index('wk$doc_path_idx'); end;
      Filtering on: filter path = C:\oracle\ora92\bin\ctxhx.exe, number of filters = 1
      MIME inclusions = text/html text/plain application/vnd.ms-excel application/x-msexcel
      URL table attributes = url, depth, signature, last_modified, status, url_id, access_url, enqueue_status, TITLE, DESCRIPTION, AUTHOR, CRAWLED_DATE, CONTENT_LENGTH, CONTENT_TYPE, LANG, CACHE_FILE_PATH, DS_ID
      SQL callback statement is "begin wk_crw.crawler_callback(?,?,?,?); exception when wk_def.isearch_error then wk_err.raise; when others then wk_err.raise; end;"
      SQL hook ID is "44"
      SQL command hook statement is "begin ? := wk_crw.crawler_get_command(?,?,?,?); end;"
      SQL response hook statement is "begin ? := wk_crw.crawler_send_response (?,?,?,?,?,?,?,?,?,?,?,?); end;"
      Crawler launched by schedule "schedule1"

      =================== Crawling status ===================
      Crawling started at 03.12.02 10:50
      URL manager connecting to Oracle... connected
      Time of last crawl is 2002-12-03
      Queue manager connecting to Oracle... connected
      Indexing log file is "ultrasearch_log" under oracle_home/ctx/log/
      Cleaning up cache directory... Done
      Cache queue is empty (1 times)
      Current waiting caching thread is cache_0
      Current waiting caching thread is cache_1
      Initializing language detection module...
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\danish.dat for language da
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\dutch.dat for language nl
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\english.dat for language en
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\french.dat for language fr
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\german.dat for language de
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\italian.dat for language it
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\portugue.dat for language pt
      Loading training data C:\oracle\ora92/ultrasearch/data/training/\spanish.dat for language es
      Processing file://localhost/C:/Projet/Orange/corporate/data/awards.html
      Total documents successfully processed = 1
      Documents to process = 0
      Shutting down all crawling threads...
      Caching thread cache_1 returns without getting a file
      Caching thread cache_0 returns without getting a file
      Shutting down all caching threads...
      Total number of documents cached = 1
      Total data collected = 19'647 bytes
      Indexing started at 03.12.02 10:50
      Indexing completed at 03.12.02 10:50
      Shutting down crawler...

      =================== Crawling results ===================
      Crawling started at 03.12.02 10:50
      Crawling stopped at 03.12.02 10:50
      Total crawling time = 0:0:22

      Total number of documents fetched = 1
      Document fetch failures = 0
      Document conversion failures = 0
      Total number of unique documents indexed = 1
      Total data collected = 19'647 bytes
      Total number of non-indexable documents = 0
      Average size of fetched document = 19'647 bytes

      Total indexing time = 0:0:0 for 19'647 bytes of data
      Number of documents collected/indexed per hour = 163

      Number of times disk cache is full = 0

        • 1. Re: No results displayed !!!
          Chris Antognini

          The indexed documents are listed in WK$DOC. If some documents are only listed in WK$URL there was a problem (e.g. timeout, the document was a directory, ...).

          To find out what is the problem you can check the status with the following query:

          select status, count(*) from wk$url group by status;

          If status = 200 is ok. If not, via the admin GUI (Crawler Statistics) you can see a summary with a "description" of the problem (number of documents for each status).

          • 2. Re: No results displayed !!!
            Yeah, but what should I do if all documents have status=200 but still the results does not display all documents containing the string I searched? this is happening to me, and I really don't know US does not display all documents, just a part of them.
            • 3. Re: No results displayed !!!
              Hi guys,

              I'm just wondering if you got a solution for this? I have the same problem.
              I've installed UltraSearch and am using the API to perform searches..
              No results are coming out.

              there are lots of documents in the wk$url table where status = '200'

              But what ever text I search for, I get nothing...
              Please help.

              Thanks heaps,

              My java class that talks to the UltraSearch API is:

              import java.sql.*;
              import oracle.ultrasearch.*;
              import oracle.ultrasearch.query.*;
              import oracle.ultrasearch.query.QueryInstance;
              import oracle.ultrasearch.query.InstanceMetaData;
              import oracle.ultrasearch.query.Query;
              import oracle.ultrasearch.query.Contains;
              import oracle.ultrasearch.query.Result;
              import java.util.Locale;
              import java.sql.Connection;

              class OracleUltraSearchProvider {

              public static void main(String args[])
              throws java.sql.SQLException,
              ClassNotFoundException {

              String resultsXml = PerformSearch (


              public static String PerformSearch (
              String usDbRepositoryConnectionString,
              String usDbRepositoryUserName,
              String usDbRepositoryPassword,
              String usRepositoryInstanceName,
              String searchPhrase
              ) throws java.sql.SQLException,
              ClassNotFoundException {
              boolean outputDebug = false;

              if (outputDebug) System.out.print("Getting Connection Settings\n");
              Class.forName ("oracle.jdbc.driver.OracleDriver").newInstance();
              if (outputDebug) System.out.print("Connecting\n");

              Connection conn = DriverManager.getConnection(usDbRepositoryConnectionString
              , usDbRepositoryUserName
              , usDbRepositoryPassword);
              if (outputDebug) System.out.print("Connected\n");

              Instance i = new Instance();
              if (outputDebug) System.out.print("Instance Created\n");

              if (outputDebug) System.out.print("Specify Query\n");
              InstanceMetaData imd = i.getMetaData();
              String textQuery = searchPhrase;
              Query q = new CtxContains(textQuery);
              // Query q = new Contains(textQuery, imd);

              if (outputDebug) System.out.print("Run Query\n");

              Request request = new Request();
              request.setQueryLanguage(new Locale("EN", ""));
              // request.setExcerptLength(200);
              // request.setStartTag ("");
              // request.setEndTag ("");
              // request.setEllipsisMark (" ... ");

              Result r = i.getResult(request);

              if (outputDebug) System.out.print("Results:\n");
              String str = String.valueOf(r.size());

              return str;
              • 4. Re: No results displayed !!!

                I made one small change to your code in order to make it work for me:
                I removed the setDocLanguage() call, as it tries to filter the results by document language.
                Now it works fine.

                Best regards,