10 Replies Latest reply: Mar 21, 2010 11:17 PM by Hussein Sawwan-Oracle RSS

    FRM-92050 Failed to connect to the server

    609456
      Hi Fadi , hsawwan, all,

      i successfully implemented SSL on HTTP of 11.5.10.2 on RHEL4
      but when i try to access any of the forms i get the following error

      FRM-92050: Failed to connect to the server
      java.io.IOException: javax.net.ssl.SSLException: SSL handshake failed: SSLConnectionClosedGraceful

           at oracle.security.ssl.OracleSSLSocketImpl.startHandshake(Unknown Source)
      at oracle.forms.net.HTTPSStream.connect(Unknown Source)
      at oracle.forms.net.HTTPConnection.connect(Unknown Source)

      error_log details:
      [Fri Jan 18 17:45:25 2008] [error] [client 192.168.10.65] client denied by server configuration: /u02/oracle/prodcomn/java/java
      [Fri Jan 18 17:45:27 2008] [error] [client 192.168.10.65] File does not exist: /u02/oracle/prodcomn/java/oracle/forms/icons/oracle_logo_light.gif
      [Fri Jan 18 17:45:27 2008] [error] [client 192.168.10.65] File does not exist: /u02/oracle/prodcomn/java/oracle/forms/icons/oracle_logo_light.gif
      [Fri Jan 18 17:45:28 2008] [error] [client 192.168.10.65] client denied by server configuration: /u02/oracle/prodcomn/java/oracle/ewt
      [Fri Jan 18 17:45:28 2008] [error] [client 192.168.10.65] File does not exist: /u02/oracle/prodcomn/java/oracle/ewt/alert/resource/AlertBundle_en_US.properties


      i tried the fix's in following Metalink notes:
      FRM-92050 SSLException SSLConnectionClosedGraceful On SSL Implementation
           Doc ID: Note:393128.1
      Unable To Login To Core Apps With HTTPS mode. javax.net.ssl.SSLException: SSL handshake failed: SSLConnectionClosedGraceful
           Doc ID:      Note:257418.1

      but still getting the same error message.

      I'm using a 14-day trail SSL certificate from verisign.
      Please suggest.

      Thanks,
      Krishnaraj
        • 1. Re: FRM-92050 Failed to connect to the server
          user473916
          Look at the xml context file at the SSL section. Insure your certs are all in the proper locations. This was problem I encountered mostly. Note also, I encountered bug where autoconfig did not update httpd.conf with context file value and retained default.

          I found the SSL implementation note confusing so I made the following notes/summary, hope it helps.


               ************************
               SSL Files & Descriptions
               ************************

               ~/.rnd               generated by MD5 cryptographic hash function with a 128 bit output, created on local server from 8.0.6 $ORACLE_HOME.
                              Referenced in RANDFILE entry in $IAS_ORACLE_HOME/Apache/open_ssl/bin/openssl.cnf

               apache_1024.key.bak     1024 bit RSA key, PEM encrypted, generated from RANDFILE entry in $IAS_ORACLE_HOME/Apache/open_ssl/bin/openssl.cnf (~/.rnd)

               apache_1024.key          1024 bit RSA key, PEM unencrypted, generated from apache_1024.key.bak

               apache_1024.csr          Certificate Signing Request generated from apache_1024.key, sent to NITC/Verisign

               cert.cer          Certificate received from NITC, generated by Verisign from apache_1024.csr

               intermediate.crt     Certificate retrieved from Verisign e-mail containing cert.cer. E-mail contains URL. Data is copied and
                              pasted from Verisign website into intermediate.crt, per Oracle documentation and standards.

               apache_1024.crt          Copy of cert.cer, per Oracle documentation and standards

          ***     server.crt          Copy of apache_1024.crt, per Oracle documentation and standards

          ***     server.key          Copy of apache_1024.key, per Oracle documentation and standards

          ***     ca.crt               Copy of intermediate.crt, per Oracle documentation and standards


          Note: '***' = Files referenced and required for final SSL configuration


          ***************************
          SSL Configuration Mapping
          ***************************


               *****************************                         *************************     **************************************
               Required SSL files & Location                         $APPL_TOP/admin/*.xml Tag     $IAS_ORACLE_HOME/A*/A*/conf/httpd.conf
               *****************************                         *************************     **************************************

               $IAS_ORACLE_HOME/Apache/Apache/conf/ssl.crt/server.crt          s_web_ssl_certfile          SSLCertificateFile
               $IAS_ORACLE_HOME/Apache/Apache/conf/ssl.key/ca.crt          s_web_ssl_certchainfile          SSLCertificateChainFile
               $IAS_ORACLE_HOME/Apache/Apache/conf/ssl.key/server.key          s_web_ssl_keyfile          SSLCertificateKeyFile

               These must all match. If they do not map, update the XML file and run autoconfig. Verify httpd.conf was updated by autoconfig.

               - This should be executed as the applmgr user on the application server
          • 2. Re: FRM-92050 Failed to connect to the server
            609456
            hi user473916,

            i have verified what you mentioned, the required file and their location.

            can you please let me know what are the changes made to httpd.conf file after running autoconfig......?

            rgds,
            Krishnaraj
            • 3. Re: FRM-92050 Failed to connect to the server
              Hussein Sawwan-Oracle
              Krishnaraj,

              Do you get any error when starting adfrmctl.sh? Does the f60svrm.txt log file contain any errors?
              • 4. Re: FRM-92050 Failed to connect to the server
                609456
                hi hsawwan,

                starting adfrmctl.sh did not give any error.
                and f60svrm.txt log file entry is as follows:
                port=9000
                Choosing default pool 1 for this process...
                1
                Choosing socket protocol for this process...
                socket
                Forms listener stopped on port 9000.
                port=9000
                Choosing default pool 1 for this process...
                1
                Choosing socket protocol for this process...
                socket
                Forms listener stopped on port 9000.
                ~

                The last time around when i was stuck at the same point, according to metalink doc ID :393128.1
                tha cause: Forms Listener Servlet implementation has not yet been performed.
                i followed appendix C of Note 123718.1
                After doing so i got      FRM-92050: Failed to connect to Server: /forms/lservlet:-1(Negative Content-length) error.

                my task is to implement SSL on WEb server only.

                Please suggest.
                rgds,
                Krishnaraj
                • 5. Re: FRM-92050 Failed to connect to the server
                  609456
                  Hi All,

                  i succeeded in solving the problem by running the script
                  txkrun.pl -script=SetAdvCfg -appsuser=apps - appspass=apps -enable=FormsLsrnServlet

                  and boucing Apache & adfrmclt.sh manually owned by the user based on the port used for SSL.

                  Thanks hsawwan, Fadi n others
                  rgds,
                  Krishnaraj
                  • 6. Re: FRM-92050 Failed to connect to the server
                    Hussein Sawwan-Oracle
                    Krishnaraj,

                    Thanks for sharing the solution.
                    • 7. Re: FRM-92050 Failed to connect to the server
                      206229
                      I got below error while executing /home/oracle/PROD/apps/apps_st/appl/fnd/12.0.0/bin/txkrun.pl -script=SetAdvCfg -appsuser=apps -appspass=apps -enable=FormsLsrnServlet

                      Errors encountered running /home/oracle/PROD/apps/apps_st/appl/fnd/12.0.0/patch/115/bin/txkSetAdvCfg.pl

                      /home/oracle/PROD/apps/apps_st/appl/fnd/12.0.0/patch/115/bin/txkSetAdvCfg.pl did not return a true value at /home/oracle/PROD/apps/apps_st/appl/au/12.0.0/perl/TXK/RunScript.pm line 105.

                      please advice.
                      • 8. Re: FRM-92050 Failed to connect to the server
                        Hussein Sawwan-Oracle
                        Hi,

                        What is the complete error message you get?
                        /home/oracle/PROD/apps/apps_st/appl/au/12.0.0/perl/TXK/RunScript.pm line 105.
                        Could you please post this line from the file here.

                        Regards,
                        Hussein
                        • 9. Re: FRM-92050 Failed to connect to the server
                          ahgarcera
                          FRM-92050: Failed to Connect to the Server: /forms/lservelet:-1

                          The Error just suddenly appear. I had been already using the Forms for more than a week using my IElxplorer 8, but suddenly it had started receiving the error. My other officemat got the same error also. What could be the cost and how to fix it.

                          I had already diables XSS Filter on Security Tab.. Under the Internet and Local Internet,

                          On the advanced tab, I had set to disable the enable third-party browser extensions*

                          Anyonce can help.


                          Thanks in Advance

                          Edited by: user8871651 on Mar 30, 2010 6:08 PM
                          • 10. Re: FRM-92050 Failed to connect to the server
                            Hussein Sawwan-Oracle
                            Hi,

                            What is the OS?
                            The Error just suddenly appear. I had been already using the Forms for more than a week using my IElxplorer 8, but suddenly it had started receiving the error. My other officemat got the same error also. What could be the cost and how to fix it.
                            Any changes have been done at the server side? Can you reproduce the issue with a different browser or different IE version?

                            If none of the clients can connect, you may need to run AutoConfig at the application side and see if it runs successfully.
                            Anyonce can help.
                            Search MOS for "FRM-92050 11i" and go through the documents.

                            Regards,
                            Hussein