6 Replies Latest reply: Mar 26, 2008 4:03 PM by Jaffy RSS

    Problem login to EM

    396523
      Hi,
      I setup a domain and installed Oracle 10g Enterprise Edition on the domain controller. I have 2 issues.

      1. We cannot access SQLPlus from the client machines. iSQLPlus and EM work fine. What are we doing wrong?

      2. After starting EM, and we want to perform tasks like Local Naming, another login sceen shows up and when we enter sys/password, we get an error message: wrong password. What do we have to do to rectify this?
      Thanks in advance.

      Chi...
        • 1. Re: Problem login to EM
          damorgan
          1. Not reading the docs? What operating system? What does 10g mean? 10.1.0.3 or 10.2.0.2 or some other actual version?

          "It isn't working" is roughly equivalent to "my car won't start tell me why." Consider providing an explanation of what it is you are actually doing in a manner sufficiently clear for someone to tell what it is you are doing incorrectly.

          2. Use the correct password.

          Again a total lack of clarity. What user name did you enter? What password?
          • 2. Re: Problem login to EM
            Madrid
            1. We cannot access SQLPlus from the client machines.
            iSQLPlus and EM work fine. What are we doing wrong?
            You will be able to access isqlplus and Enterprise manager from anywhere in your network where there are no firewall restrictions and where the hostname and address are visible. If you want to access from sqlplus, I assume you have installed the oracle client on each end user machine and you can access the hostname by means of the tns protocol. It is advisable for you to properly specify what exactly you have done at the client machine and how do you arrive to the conclusion that this client is unable to access your database from the client.

            2. After starting EM, and we want to perform tasks
            like Local Naming, another login sceen shows up and
            when we enter sys/password, we get an error message:
            wrong password. What do we have to do to rectify
            this?
            Sys' password is the one defined at install time, if it is reporting a wrong password error this error is straightforward, your password is wrong, if it happened that you have forgotten sys' password you can reset it by means of the ALTER USER sys IDENTIFIED BY yourNewPassword; command issued from a sqlplus session with dba privileges.


            ~ Madrid
            • 3. Re: Problem login to EM
              396523
              Sorry guys for my not being clear. Here we go.

              When I try to start up my database from the Enterprise Manager I get a page with:
              “Startup/Shutdown: Specify Host and Target Database Credentials”

              I enter the UN: Administrator and my windows PW (this is the log into the domain) in the first two fields and UN: SYSMAN and my DB PW (which I created at install) in the last two fields, I choose SYSDBA but I then get:

              Error Message: RemoteOperationException: ERROR: Wrong password for user

              logging in as SYS in both SQL*PLUS and Enterprise Manager works fine.
              I am running a Windows Server 2003 Server domain with the client systems running Win XP Pro.
              The Oracle version is 10gR2 Server on the server and 10gR2 client on the client machines.

              I’ve added all users to the ora-dba group. I even assigned the “Log on as a batch job” privilege to the “Administrator” user (for the domain). In spite of all the above effort, I still get the same error.

              Secondly, I configured the listener on the client machines using Net Manager. The clients connect to the server alright but when I try to connect sqlplus, I get a TNS:Listener Protocol adapter error.

              I have checked different Oracle forums and noticed that many people are experiencing the same problems. Nobody seems to have the right answer so far.

              Please, suggest the steps to correct these problems or point me to the proper documentations to help take care of the frustration.

              Thanks in advance for your help.

              Chi…
              • 4. Re: Problem login to EM
                396523
                Sorry guys for my not being clear. Here we go.

                When I try to start up my database from the Enterprise Manager I get a page with:
                “Startup/Shutdown: Specify Host and Target Database Credentials”

                I enter the UN: Administrator and my windows PW (this is the log into the domain) in the first two fields and UN: SYSMAN and my DB PW (which I created at install) in the last two fields, I choose SYSDBA but I then get:

                Error Message: RemoteOperationException: ERROR: Wrong password for user

                logging in as SYS in both SQL*PLUS and Enterprise Manager works fine.
                I am running a Windows Server 2003 Server domain with the client systems running Win XP Pro.
                The Oracle version is 10gR2 Server on the server and 10gR2 client on the client machines.

                I’ve added all users to the ora-dba group. I even assigned the “Log on as a batch job” privilege to the “Administrator” user (for the domain). In spite of all the above effort, I still get the same error.

                Secondly, I configured the listener on the client machines using Net Manager. The clients connect to the server alright but when I try to connect sqlplus, I get a TNS:Listener Protocol adapter error.

                I have checked different Oracle forums and noticed that many people are experiencing the same problems. Nobody seems to have the right answer so far.

                Please, suggest the steps to correct these problems or point me to the proper documentations to help take care of the frustration.

                Thanks in advance for your help.

                Chi…
                • 5. Re: Problem login to EM
                  630576
                  I am having the same problem.Could login as sys but couldnt access administration privileges.SyStem user doesnt work at all.either couldnt login into sqlplus.
                  • 6. Re: Problem login to EM
                    Jaffy
                    Hi,

                    Error shows wrong password for SYS user. Try to change sys password as mentioned by madrid above.
                    Secondly, I configured the listener on the client machines using Net Manager. The clients connect to the server alright but when I try to connect sqlplus, I get a TNS:Listener Protocol adapter error.
                    You said you can connect to server from client but when you connect through sqlplus you get an error. Earlier how you get connected to server from client.

                    Confusing... can you elaborate what you did?

                    Regards

                    Jafar