4 Replies Latest reply: Jun 21, 2011 9:17 AM by 796289 RSS

    Enterprise manager configuration failed due to the following error

    623211
      SEVERE: Failed to allocate port(s) in the specified range(s) for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM Agent [3938] | [1830-1849]
      Refer to the log file

      Oracle 10g R2 + AIX5.3 all patches are ok!

      emConfig.log

      Jan 30, 2008 4:31:54 PM oracle.sysman.emcp.util.OUIInventoryUtil setOUILoc
      CONFIG: Setting oracle.installer.oui_loc to /plm/oracle/oracle10g/oui
      Jan 30, 2008 4:31:54 PM oracle.sysman.emcp.util.OUIInventoryUtil setOUILoc
      CONFIG: Setting oracle.installer.oui_loc to /plm/oracle/oracle10g/oui
      Jan 30, 2008 4:31:55 PM oracle.sysman.emcp.util.CentralAgentUtil getCentralAgentHomeAndURL
      CONFIG: Central Agent home and URL: {}
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: LOG_FILE value: /plm/oracle/oracle10g/cfgtoollogs/dbca/tcdata/emConfig.log
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: HOST value: pdmserver
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: PORT value: 1521
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: SID value: tcdata
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: LISTENER value: LISTENER
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: LISTENER_OH value: /plm/oracle/oracle10g
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag '-config' set to true
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'db' set to true
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: EM_HOME value: /plm/oracle/oracle10g
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: DB_UNIQUE_NAME value: tcdata
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: SERVICE_NAME value: tcdata
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: ORACLE_HOME value: /plm/oracle/oracle10g
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'dbcontrol' set to true
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'UPDATE_EMAIL' set to false
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag '-backup' set to false
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'create' set to false
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.util.FileUtil _copyFile
      CONFIG: Copying file /plm/oracle/oracle10g/cfgtoollogs/emca/emca_2008-01-30_04-31-54-PM.log to /plm/oracle/oracle10g/cfgtoollogs/emca/tcdata/emca_2008-01-30_04-31-54-PM.log
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.EMConfig perform
      INFO: This operation is being logged at /plm/oracle/oracle10g/cfgtoollogs/dbca/tcdata/emConfig.log.
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'CHECK_CONFIG' set to true
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: SYS
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:41 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: DBSNMP
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter MODIFY_SID.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: SYS
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'asm_db' set to false
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter MODIFY_SID.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.DatabaseChecks getDbServiceName
      CONFIG: No service name available. Will try to set db_unique_name.db_domain
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: SYS
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: DB_UNIQUE_NAME value:
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter DB_UNIQUE_NAME.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.DatabaseChecks getDbUniqueName
      CONFIG: No Database unique name available. Will try to retrieve it from DB itself
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: DB_UNIQUE_NAME value: tcdata
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter DB_DOMAIN.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.DatabaseChecks getDbDomain
      CONFIG: No db domain available. Will query db for db_domain parameter
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: DB_UNIQUE_NAME value: tcdata
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: SERVICE_NAME value: tcdata
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter MODIFY_SID.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter DBID.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.DatabaseChecks getDbid
      CONFIG: No dbid available. Will query db to extract it.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: SYS
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: DBID value: 4096508527
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: SYSMAN
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: SYS
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.EMDBPreConfig invoke
      CONFIG: Passed repository configuration check
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter MODIFY_SID.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter MODIFY_SID.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter GLOBAL_DB_UNIQUE_NAME.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.DatabaseChecks getGlobalDbUniqueName
      CONFIG: No Global database unique name available. Will try to retrieve it from DB itself
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine connecting with SID: tcdata, oracleHome: /plm/oracle/oracle10g, and user: SYS
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
      CONFIG: SQLEngine created successfully and connected
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter DB_DOMAIN.
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.DatabaseChecks getDbDomain
      CONFIG: No db domain available. Will query db for db_domain parameter
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager setParam
      CONFIG: Setting param: GLOBAL_DB_UNIQUE_NAME value: tcdata
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.FileUtil _copyFile
      CONFIG: Copying file /plm/oracle/oracle10g/sysman/config/emd.properties to /plm/oracle/oracle10g/sysman/config/emd.properties.emca.tmp
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.FileUtil backupFile
      CONFIG: The original file /plm/oracle/oracle10g/sysman/config/emd.properties has been copied to /plm/oracle/oracle10g/sysman/config/emd.properties.emca.tmp
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.FileUtil _copyFile
      CONFIG: Copying file /plm/oracle/oracle10g/sysman/config/emoms.properties.emca to /plm/oracle/oracle10g/sysman/config/emoms.properties
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.FileUtil backupFile
      CONFIG: The original file /plm/oracle/oracle10g/sysman/config/emoms.properties.emca has been copied to /plm/oracle/oracle10g/sysman/config/emoms.properties
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.FileUtil _copyFile
      CONFIG: Copying file /plm/oracle/oracle10g/sysman/emd/targets.xml to /plm/oracle/oracle10g/sysman/emd/targets.xml.emca.tmp
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.util.FileUtil backupFile
      CONFIG: The original file /plm/oracle/oracle10g/sysman/emd/targets.xml has been copied to /plm/oracle/oracle10g/sysman/emd/targets.xml.emca.tmp
      Jan 30, 2008 4:50:42 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
      CONFIG: This is expected, as we might be calling it from a non-rac home
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
      CONFIG: Error retrieving the local node for the cluster
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
      CONFIG: PRKH-1010 : Unable to communicate with CRS services.
      [OCR Error(Native: prsr_initCLSS:[21])]
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
      CONFIG: Cluster Error Message: PRKH-1010 : Unable to communicate with CRS services.
      [OCR Error(Native: prsr_initCLSS:[21])]
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'IS_CENTRAL_AGENT_RECONFIG' set to false
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.CentralAgentUtil isCentralAgentConfigured
      CONFIG: Sid: tcdata Host: pdmserver Node: null OH: /plm/oracle/oracle10g agentHome: null isCentral: false
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.DBControlUtil isDBConsoleConfigured
      CONFIG: Sid: tcdata Host: pdmserver Node: null OH: /plm/oracle/oracle10g isDBC: false
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'IS_CENTRAL_AGENT_CONFIGURED' set to false
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager setFlag
      CONFIG: Flag 'IS_DBCONTROL_CONFIGURED' set to false
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter DBCONTROL_HTTP_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter AGENT_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter RMI_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter JMS_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.DBControlUtil isDBConsoleConfigured
      CONFIG: Sid: tcdata Host: pdmserver Node: null OH: /plm/oracle/oracle10g isDBC: false
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter PORTS_FILE.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter JMS_PORT_tcdata.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter JMS_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter RMI_PORT_tcdata.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter RMI_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter DBCONTROL_HTTP_PORT_tcdata.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter DBCONTROL_HTTP_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter AGENT_PORT_tcdata.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.ParamsManager getParam
      CONFIG: No value was set for the parameter AGENT_PORT.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.OUIInventoryUtil setOUILoc
      CONFIG: Setting oracle.installer.oui_loc to /plm/oracle/oracle10g/oui
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
      CONFIG: Homes to scan for used ports: [plm/oracle/oracle10g]
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
      CONFIG: Searching all DBConsole instances for used ports under ORACLE_HOME /plm/oracle/oracle10g
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
      CONFIG: Marking JMS port: null from /plm/oracle/oracle10g/oc4j/j2ee/OC4J_DBConsole
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
      CONFIG: Marking RMI port: null from /plm/oracle/oracle10g/oc4j/j2ee/OC4J_DBConsole
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
      CONFIG: Marking HTTP port: null from /plm/oracle/oracle10g/oc4j/j2ee/OC4J_DBConsole
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager getAgentPort
      CONFIG: Cannot parse EMD_URL correctly. No port identified
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
      CONFIG: Marking Agent port: null from /plm/oracle/oracle10g/sysman/config/emd.properties
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
      CONFIG: Cannnot parse EMD_URL correctly. No port identified
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.util.FileUtil getProperties
      CONFIG: Error reading file /plm/oracle/oracle10g/install/staticports.ini
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.EMConfig perform
      SEVERE: Failed to allocate port(s) in the specified range(s) for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM Agent [3938] | [1830-1849]
      Refer to the log file at /plm/oracle/oracle10g/cfgtoollogs/dbca/tcdata/emConfig.log for more details.
      Jan 30, 2008 4:50:44 PM oracle.sysman.emcp.EMConfig perform
      CONFIG: Stack Trace:
      oracle.sysman.emcp.exception.EMConfigException: Failed to allocate port(s) in the specified range(s) for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM Agent [3938] | [1830-1849]
           at oracle.sysman.emcp.EMDBPreConfig.checkPorts(EMDBPreConfig.java:2266)
           at oracle.sysman.emcp.EMDBPreConfig.performConfiguration(EMDBPreConfig.java:670)
           at oracle.sysman.emcp.EMDBPreConfig.invoke(EMDBPreConfig.java:233)
           at oracle.sysman.emcp.EMDBPreConfig.invoke(EMDBPreConfig.java:160)
           at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:141)
           at oracle.sysman.assistants.util.em.EMConfiguration.run(EMConfiguration.java:426)
           at java.lang.Thread.run(Thread.java:568)

      Message was edited by:
      user620208
        • 1. Re: Enterprise manager configuration failed due to the following error
          623211
          I have checked almost possible ideas, but no one can work correctly.

          Such as:

          ports check

          emca -config dbcontrol db -DBCONTROL_HTTP_PORT 5508 -AGENT_PORT 3940 -RMI_PORT 5524 -JMS_PORT 5545

          emctl stop dbconsole

          emctl start dbconsole
          ----------------------------------------

          I think the reason is the hosts maybe!
          Because I have installed another two ethernet cards and given them one static IP.
          But I added the ip into the hosts, it didn't work also.

          Anyone give me a help?

          Message was edited by:
          user620208
          • 2. Re: Enterprise manager configuration failed due to the following error
            635639
            Hi. I have the same problem. Did you find out what was wrong?
            • 3. Re: Enterprise manager configuration failed due to the following error
              277993
              Possible causes

              1. You already have those port ranges in use
              2. Those ports are not open (closed by firewall or Anti-virus etc)
              3. If you have two network cards, the installer cannot identify which of the cards (hosts) you are using hence it cannot allocate the posts to the appropriate host. In this case use the appropriate Hostname parameter before installation.
              • 4. Re: Enterprise manager configuration failed due to the following error
                796289
                after a new installation of Suse SLES 11Sp1 and Oracle 11.1.0.6 I also got that

                Enterprise manager configuration failed due to the following error:
                Failed to allocate port(s) in the specified range(s) for the following process(es): JMS [5540-5559],RMI [5520-5539],Database Control [5500-5519],EM Agent [3938] | [1830-1849]

                The DB was created and running, but the Enterprise manager (OEM) could not be configured - even not reconfigured or something.

                After some time I checked the network settings and found, that was using DHCP.

                After assigning a static IP / subnet (and recreating with dbca) even OEM worked.

                As this took me some time, I thought maybe some else might have the same problem :-)

                Edited by: 793286 on 21.06.2011 15:17