1 2 3 4 Previous Next 50 Replies Latest reply on Mar 7, 2008 7:42 PM by Madrid

    emctl dbconsole not starting

    620899
      Hi,
      I am using Oracle 10.1.0.2.0 on Win XPP, when I am trying t start EM Dbcontrol from Dos prompt, I am getting the following error, Can anybody please advise where is the prblem.

      C:\>set ORACLE_SID=ORCL

      C:\>emctl start dbconsole
      Oracle Enterprise Manager 10g Database Control Release 10.1.0.2.0
      Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
      http://suman:5500/em/console/aboutApplication
      Starting Oracle Enterprise Manager 10g Database Control ...The system cannot fin
      d the path specified.

      C:\>

      Please tell me how to specify the path for DBconsole.

      Thanks
      SKR
        • 1. Re: emctl dbconsole not starting
          247514
          You must have truncate the error message, the message should include the path that it can't find.

          In any event, it looks like you didn't configure your dbconsole properly before.
          Since you are on 10gR1 try to follow this article.

          http://www.akadia.com/services/ora_dbconsole.html
          • 2. Re: emctl dbconsole not starting
            569251
            Hi,
            Can you please show me the message you got on command line when you
            do the command
            EMCTL START DBCONSOLE
            Regards ,
            Ahmed
            • 3. Re: emctl dbconsole not starting
              Aman....
              Issue emctl status dbconsole and than emctl start dbconsole and print the entire message that will come up.
              Aman....
              • 4. Re: emctl dbconsole not starting
                620899
                Hi the Error message is as follows...

                C:\>emctl status dbconsole
                Oracle Enterprise Manager 10g Database Control Release 10.1.0.2.0
                Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
                http://suman:5500/em/console/aboutApplication
                Oracle Enterprise Manager 10g is not running.

                C:\>emctl start dbconsole
                Oracle Enterprise Manager 10g Database Control Release 10.1.0.2.0
                Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
                http://suman:5500/em/console/aboutApplication
                Starting Oracle Enterprise Manager 10g Database Control ...The system cannot find the path specified.

                C:\>

                Regards
                • 5. Re: emctl dbconsole not starting
                  277993
                  Have you ever used the dbconsole? Was the repository created when you installed the database? If not, then you need to create it. If yes, then set the ORACLE_HOME and ORACLE_SID before you issue the command
                  • 6. Re: emctl dbconsole not starting
                    620899
                    Hi
                    Thanks for your response,
                    Yes I used to use DB console before, Even I set the SID as

                    C:\>set oracle_sid=orcl

                    C:\>emctl start dbconsole
                    Oracle Enterprise Manager 10g Database Control Release 10.1.0.2.0
                    Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
                    http://suman:5500/em/console/aboutApplication
                    Starting Oracle Enterprise Manager 10g Database Control ...The system cannot find the path specified.

                    Still the same error.

                    Regards
                    • 7. Re: emctl dbconsole not starting
                      Jaffy
                      Hi,

                      Try this

                      Drop And recreate dbconsole with specific credentials.

                      www.akadia.com/services/ora_dbconsole.html

                      Jafar
                      • 8. Re: emctl dbconsole not starting
                        620899
                        Hi,
                        I have re-created the dbconsole providing all the credentials, but still it is not starting.

                        Thanks
                        • 9. Re: emctl dbconsole not starting
                          Aman....
                          Did you do any sort of change in your system's host configurations like connecting to dhcp or changing some ip address or machine name , anything like that? Though you have recreated the repository so it should work now but still its important for us to know. And what's the error that you are getting now?
                          Aman....
                          • 10. Re: emctl dbconsole not starting
                            523455
                            Please paste of result of the following file

                            $ORACLE_HOME\host_SID\sysman\config\emd.properties
                            • 11. Re: emctl dbconsole not starting
                              620899
                              Thanks to all of you, Sorry I got offline.

                              Yes Aman I changed my Host to DHCP ip. But it is from begining and I used to use EMCTL DBCONSOLE before also.

                              One thing I have noticed is, the config file should be in "$ORACLE_HOME\host_SID\sysman\config\emd.properties"

                              My host name is 'suman' but my config file is under
                              '$ORACLE_HOME\localhost_SID\sysman\config\emd.properties'
                              not
                              '$ORACLE_HOME\suman_SID\sysman\config\emd.properties'

                              I do not know why.

                              the 'emd.properties' contains
                              ------------------
                              #Fri Aug 17 09:53:55 GMT+03:00 2007
                              oracle.sysman.emSDK.svlt.ConsoleServerName=localhost_Management_Service
                              oracle.sysman.eml.mntr.emdRepPwd=01169917e1bb79da
                              emdrep.ping.pingCommand=/usr/sbin/ping <hostname>
                              oracle.sysman.eml.mntr.emdRepPort=1521
                              oracle.sysman.eml.mntr.emdRepDBName=ocp10g
                              oracle.sysman.emSDK.svlt.ConsoleMode=standalone
                              oracle.sysman.emRep.dbConn.statementCacheSize=30
                              oracle.sysman.db.isqlplusUrl=http\://suman\:5560/isqlplus/dynamic
                              oracle.sysman.emSDK.svlt.ConsoleServerPort=5501
                              oracle.sysman.eml.mntr.emdRepRAC=FALSE
                              oracle.sysman.emSDK.emd.rt.useMonitoringCred=true
                              oracle.sysman.eml.mntr.emdRepPwdEncrypted=TRUE
                              oracle.sysman.db.isqlplusWebDBAUrl=http\://suman\:5560/isqlplus/dba/dynamic
                              oracle.sysman.emSDK.svlt.ConsoleServerHost=localhost
                              oracle.sysman.emSDK.svlt.ConsoleServerHTTPSPort=5501
                              oracle.sysman.eml.mntr.emdRepServer=localhost
                              oracle.sysman.eml.mntr.emdRepSID=ocp10g
                              oracle.sysman.emSDK.sec.ReuseLogonPassword=true
                              oracle.sysman.eml.mntr.emdRepConnectDescriptor=(DESCRIPTION\=(ADDRESS_LIST\=(ADDRESS\=(PROTOCOL\=TCP)(HOST\=suman)(PORT\=1521)))(CONNECT_DATA\=(SERVICE_NAME\=ocp10g)))
                              oracle.sysman.eml.mntr.emdRepUser=SYSMAN
                              oracle.sysman.db.adm.conn.statementCacheSize=2
                              oracle.sysman.db.perf.conn.statementCacheSize=30
                              ------------------
                              when I ran emca this file was updated also.

                              Regards

                              SKR
                              • 12. Re: emctl dbconsole not starting
                                Aman....
                                SKR,
                                I am not sure that how it was working in the past.What I can say this that it could be working till the time you were using that particular IP which was given to you by DHCP once it is changed than it is not working. But as you have recreated the repository,it should work.Post the files , emoms.properties and target.xml also.The host name in this file emd.properties is Suman only.Post the results of those two files too.
                                Also when you give emctl status dbconsole what comes up?
                                Aman....
                                • 13. Re: emctl dbconsole not starting
                                  620899
                                  Hi Aman

                                  here is the output for targets.xml

                                  ------------
                                  - <Targets AGENT_SEED="-1266652552">
                                  <Target TYPE="oracle_emd" NAME="localhost:1830" />
                                  <Target TYPE="host" NAME="localhost" DISPLAY_NAME="localhost" VERSION="1.0" />
                                  - <Target TYPE="oracle_database" NAME="ocp10g" VERSION="1.0">
                                  <Property NAME="MachineName" VALUE="suman" />
                                  <Property NAME="Port" VALUE="1521" />
                                  <Property NAME="SID" VALUE="ocp10g" />
                                  <Property NAME="OracleHome" VALUE="C:\oracle\product\10.1.0\Db_1" />
                                  <Property NAME="UserName" VALUE="b23af5a7180e63ee" ENCRYPTED="TRUE" />
                                  <Property NAME="password" VALUE="8e4cb18c439020e9" ENCRYPTED="TRUE" />
                                  </Target>
                                  - <Target TYPE="oracle_listener" NAME="LISTENER_suman" VERSION="1.0">
                                  <Property NAME="Machine" VALUE="suman" />
                                  <Property NAME="LsnrName" VALUE="LISTENER" />
                                  <Property NAME="Port" VALUE="1521" />
                                  <Property NAME="OracleHome" VALUE="C:\oracle\product\10.1.0\Db_1" />
                                  <Property NAME="ListenerOraDir" VALUE="C:\oracle\product\10.1.0\Db_1\network\admin" />
                                  </Target>
                                  </Targets>
                                  ---------------

                                  Regarding config file, I have confusion as I can see 2 config files
                                  one is under <<oracle_home/localhost_orcl\sysman\config

                                  another is <<oracle_home/suman_orcl\sysman\config

                                  ------------emctl

                                  C:\>emctl start dbconsole
                                  OC4J Configuration issue. C:\oracle\product\10.1.0\Db_1/oc4j/j2ee/OC4J_DBConsole_localhost_orcl not found.

                                  C:\>emctl start dbconsole
                                  Oracle Enterprise Manager 10g Database Control Release 10.1.0.2.0
                                  Copyright (c) 1996, 2004 Oracle Corporation. All rights reserved.
                                  http://localhost:5500/em/console/aboutApplication
                                  Starting Oracle Enterprise Manager 10g Database Control ...The system cannot find the path specified.

                                  C:\>emctl status dbconsole
                                  OC4J Configuration issue. C:\oracle\product\10.1.0\Db_1/oc4j/j2ee/OC4J_DBConsole_suman_orcl not found.

                                  -------------

                                  Regards

                                  Suman
                                  • 14. Re: emctl dbconsole not starting
                                    Aman....
                                    Hi Suman,
                                    Well surely there is a confliction as the hostname that is being picked up by Oracle is Suman but its not using the suman_ folder that is created for your em console. That's why you are getting the message path not found.
                                    Ok what we will do is , we will recreate the repository and see what comes up.Remove your system from the DHCP first , make it stand alone and then do it.
                                    run this on command prompt
                                    emca -deconfig dbcontrol db -repos drop
                                    then
                                    emca -config dbcontrol db -repos create
                                    Post the results what comes up from these commands.
                                    Aman....
                                    1 2 3 4 Previous Next