6 Replies Latest reply on Mar 3, 2008 11:55 PM by 612183

    HAL error 1033 when connecting to essbase/ Analytics

    Detlev
      when I try to conect with HAL (Vignette Business Integration Studio Version 7.3) to a essbase (7.1) server I get the error: EssbaseAdapterDesign Building Block
      --------------------------- Exception # 1 Error Code = 1033 Error Msg = Operating system exception thrown

      when I try to conect with HAL (Vignette Business Integration Studio Version 7.3) to a essbase (9.3.1) server I get the error: EssbaseAdapterDesign Building Block
      ---------------------------Exception #1: error code - 1006: Error: Destroy session failed: native code -
      I see posintgs about 1033 but no resolutions yet. Anyone an idea?
        • 1. Re: HAL error 1033 when connecting to essbase/ Analytics
          612183
          Im getting the same error using HAL Essbase Adapter 9.2.0, VBIS 7.3 and Essbase 9.3.1.

          Any solutions would be greatly appreciated!
          • 2. Re: HAL error 1033 when connecting to essbase/ Analytics
            user622597
            We had received the same 1033 error when connecting using the Essbase adapter. Below is information that we found that resolved our problem:


            Executing larger queries/updates on Windows XP or 2003 systems can produce the following error message: ”com.hyperion.essbaseadapter.application.ap.APException: Exception #1: error code - 1033: [Tue Jan 18 13:43:39 2005]Error(1042006) Network Error [10048]: Unable To Connect To [server name]. The client timed out waiting to connect to the Essbase Agent using TCP/IP. Check your network connections.”
            This error is the result of a large number of queries to the Essbase server where the available connection resources are insufficient to handle the amount of queries. The registry modifications in the remainder of this document make connection resources available to satisfy larger Essbase Adapter dimension queries.
            The Fix:
            The MaxUserPort registry key specifies the highest port number that TCP can assign when an application requests an available user port from the system. For more information on the MaxUserPort registry value, go to this address on the Web: http://www.microsoft.com/resources/documentation/WindowsServ/2003/all/deployguide/en-us/58791.aspThe TCPTimedWaitDelay registry key specifies the time that must elapse before TCP can release a closed connection and reuse its resources. For more information on the TcpTimedWaitDelay registry value go to this address on the Web: http://www.microsoft.com/resources/documentation/WindowsServ/2003/all/deployguide/en-us/58811.asp

            Note: The registry modifications in the following procedure are made to the computer where the Essbase Adapter integration is being executed.
            Open up regedit
            In the left frame of the Registry Editor window, select the following directory: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
            The right frame lists the current values for the Parameters key.
            To update the MaxUserPort Value data:
            a. If the MaxUserPort value name is not listed in the right frame, create this value:
            i. In the right frame, right-click and select New>DWORD Value.
            ii. Type MaxUserPort for the value name and press Enter.
            b. Double-click MaxUserPort.
            In the Edit DWORD Value dialog box, select the Decimal option in the Base box, type 65534 in the Value data edit box, and then click OK.

            To update the TCPTimedWaitDelay Value data: a. If the TCPTimedWaitDelay value name is not listed in the right frame, create this value: i. In the right frame, right-click and select New>DWORD Value. ii. Type TCPTimedWaitDelay for the value name and press Enter. b. Double-click TCPTimedWaitDelay. c. In the Edit DWORD Value dialog box, select the Decimal option in the Base box, type 120 in the Value data edit box, and then click OK.
            • 3. Re: HAL error 1033 when connecting to essbase/ Analytics
              Detlev
              thanks for your response. I doubt we talk about the same error. Although the error number is the same, mine is about a OS exception. Never the less I allready tried your solution. It did not work.
              It is also not a matter of huge queries, since I only try to make a new connection to an essbase demo database. Very very few times (ones in 20 to 40 times trying) I succeed to make a connection but before saving it it gives the same errors en can't save.
              • 4. Re: HAL error 1033 when connecting to essbase/ Analytics
                612183
                Ive got a solution which Ive tested and works! You need the 9.2.0 runtime in order for the VBIS Essbase 9.2.0 Adapter to work. This comes from installing the 9.2.0 Essbase Client

                This is what I did I on my client machine:
                1. Uninstall EAS 9.3.1 Console (Not the server), Essbase Client 9.3.1, VBIS
                2. Reinstall in this sequence:
                2.1 Essbase Client 9.2.0, including runtime, and spreadsheet add-in
                2.2 VBIS 7.3
                2.3 HAL Essbase Adapter 9.2.0
                2.4 EAS 9.3.1 Console

                Also ensure these Window Environment Variables are set(This is based on my computer settings so could differ from yours) Right mouse click My Computer > Properties > Advanced Tab > Environment Variables:

                /*USER VARIABLES*/

                /*CLASS PATH*/
                C:\Program Files\Vignette\V7\vbis\Hyperion\EssbaseAdapter

                /*PATH*/
                C:\Program Files\Vignette\V7\vbis\Hyperion\EssbaseAdapter\adm

                /*ENVIRONMENT VARIABLES*/

                /*CLASS PATH*/
                C:\Program Files\Vignette\V7\vbis\Hyperion\EssbaseAdapter\adm

                /*PATH*/
                C:\Program Files\Vignette\V7\vbis\Hyperion\EssbaseAdapter\adm;C:\Program Files\Java\jre1.5.0_07\bin\client\

                You might have extra variable paths defined under the PATH variables.

                Ive managed to add the adapter in a VBIS project without any errors, it connects to Essbase though yet to test if it will perform a send properly. The spreadsheet addin works with 9.2.0 and the EAS Console works with 9.3.1 connecting to the Essbase Server 9.3.1.

                Hope this helps!

                Message was edited by:
                user609180
                • 5. Re: HAL error 1033 when connecting to essbase/ Analytics
                  Detlev
                  Hi User609180, that info solved it for me. Thanks! I discovered that the latest version of HAl is not working fine with the 9.3.1 client bins. It works fine with 9.2.0.
                  • 6. Re: HAL error 1033 when connecting to essbase/ Analytics
                    612183
                    No problem Detlev, great to hear that it worked for you too