9 Replies Latest reply on Oct 3, 2008 7:31 AM by 663218

    problem with JDev and CVS

    504967
      I created a web project in JDev 11 with ADF Fusion. I defined a connection to oracle db and everything works fine. Then, I imported the project into CVS. When I check out the project from an other client (JDev) and try to run the project i receive this error:

      (oracle.jbo.ConfigException) JBO-33003: Connection name Connection1 not defined

      I try to redefined the connection again, but i get alaways the same problem....

      PLEASE HELP!!!
        • 1. Re: problem with JDev and CVS
          152512
          Hi,

          It's possible that your application's connections.xml file is not being checked in to CVS. This file is in your application folder, under .adf\META-INF.

          Blaise
          • 2. Re: problem with JDev and CVS
            504967
            the file connections.xml is correctly under CVS...Is this a Jdev 11 bug?
            • 3. Re: problem with JDev and CVS
              504967
              Can someone help me to sove the problem? I still can't develop an application based on Oracle Fusion with CVS!!!!!!
              • 4. Re: problem with JDev and CVS
                Timo Hahn
                try updating the connection of the embedded OC4J container

                Timo
                • 5. Re: problem with JDev and CVS
                  504967
                  I alaways get the same error. I changed the connection name (FISICA-XE) into the project and now, when i try to start it, i get this exception:

                  oracle.jbo.jbotester.ErrorHandler$ExceptionWrapper: Could not retrieve connection details for database FISICA-XE. The error encountered was: oracle.adf.share.security.ADFSecurityRuntimeException: Unable to initialize the credential store.

                       at oracle.jbo.jbotester.ErrorHandler.displayError(ErrorHandler.java:90)
                       at oracle.jbo.jbotester.ErrorHandler.displayError(ErrorHandler.java:83)
                       at oracle.jbo.jbotester.dialog.ConnectionDialogBase.<init>(ConnectionDialogBase.java:297)
                       at oracle.jbo.jbotester.jdevx.ConnectionDialog.<init>(ConnectionDialog.java:47)
                       at oracle.jbo.dt.jdevx.jbotester.JdxTester.getConfiguration(JdxTester.java:911)
                       at oracle.jbo.dt.jdevx.jbotester.JdxTester.<init>(JdxTester.java:208)
                       at oracle.jbo.dt.jdevx.jbotester.TesterStarter.start(TesterStarter.java:106)
                       at oracle.ide.runner.RunProcess.startTarget(RunProcess.java:891)
                       at oracle.jdeveloper.runner.JRunProcess.startTarget(JRunProcess.java:550)
                       at oracle.jdeveloper.runner.RunningProcess.startTarget(RunningProcess.java:83)
                       at oracle.ide.runner.RunProcess.start(RunProcess.java:839)
                       at oracle.jdeveloper.runner.JRunProcess.super_start(JRunProcess.java:403)
                       at oracle.jdeveloper.runner.JRunProcess.mav$super_start(JRunProcess.java:57)
                       at oracle.jdeveloper.runner.JRunProcess$1$1.run(JRunProcess.java:428)
                       at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
                       at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
                       at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
                       at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
                       at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
                       at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
                       at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
                  • 6. Re: problem with JDev and CVS
                    152512
                    Hi,

                    It does sound as though the connection isn't where it should be after you check out your application. So, when you check out your application and open it up in the JDev navigator, please try the following:
                    1. Expand the Application Resources accordion, then the Connections folder and the Database node.
                    2. Does the Database node contain a node for your connection?
                    3. Right-click the node for your connection and select Properties in the context menu.
                    4. In the Edit Database Connection dialog, click Test Connection. Is the test successful?
                    5. In the navigator, double-click your business components project to edit it.
                    6. In the Project Properties dialog, go to the Business Components page.
                    7. Is there a connection selected, and is it the same connection that you tested in step 4?
                    8. Click the pencil icon to edit the connection, and click the Test Connection button. Is the test successful?

                    Thanks
                    Blaise
                    • 7. Re: problem with JDev and CVS
                      504967
                      Hi, thanks for replay....I have done every and the test is successful, but when i run the application (run the model) I ALAWAYS GET THE SAME PROBLEM
                      • 8. Re: problem with JDev and CVS
                        504967
                        can someone tell what does it mean when jdev tells

                        oracle.adf.share.security.ADFSecurityRuntimeException: Unable to initialize the credential store.

                        ? This error comes up every time i try to start the application mobule into a CVS project.

                        Thanks...
                        • 9. Re: problem with JDev and CVS
                          663218
                          I also faced the same problem. As part the exception I got FileNotFound for jps-config.xml. When I deleted the database connections and re-created it is working now. Can you please check the complete exception stack trace?
                          i) Remove .adf directory and its contents where connections.xml resides
                          ii) Recreate the Database connections.

                          Automatically the files should created properly.

                          Hope this helps,
                          Arasan