1 2 Previous Next 22 Replies Latest reply: May 28, 2013 10:23 AM by 1004396 Go to original post RSS
      • 15. Re: Always asking password for XDB user
        A J
        I tried unlocking the account of XDB user

        by
        alter user xdb accoun unlock;

        Then I restarted the listener using

        $ lsnrctl stop

        and then
        $lsnrctl start

        Wait for 5 minutes

        and then try to access the apex website at
        http://localhost:8080/apex/apex_admin
        The XDB popup goes away.

        Now I dont know the password to this website.
        • 16. Re: Always asking password for XDB user
          Tyler-Oracle
          The Embedded PL/SQL Gateway (EPG) is NOT supported on Oracle 10g. It is only supported on Express Edition (XE) or 11g. So, even if you do get this to work, you're going forward on an unsupported configuration. Even though the EPG is a bit more convenient, it also has a lot of limitations such as no GZip support and no "Expires Headers" (both of which make it substantially slower), no Apache module support, such as mod_rewrite, SSL is a pain to configure, port 80 on Unix / Linux is a pain to configure...

          Go with a supported platform. If you need 10g, install the HTTP Server from the companion CD, or better yet the HTTP Server that ships with 11g based on Apache 2.0.

          Tyler
          • 17. Re: Always asking password for XDB user
            394851
            With apex 3.2 and 11.1.0.6 and having gone through this frustrating problem in three previous apex releases, this is what I have figured out for my current installation:

            In OEM, I changed the images resource administered by the /sys/acls/ro_anonymous_acl.xml ACL file to grant 'dav:read' to ANONYMOUS rather than the default of 'read-contents'.

            This is the sql OEM used:
            UPDATE resource_view r
            SET r.res=UPDATEXML(res, '/a:Resource/a:Contents/b:acl','
            <acl
            xmlns="http://xmlns.oracle.com/xdb/acl.xsd"
            xmlns:dav="DAV:"
            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlns.oracle.com/xdb/acl.xsd http://xmlns.oracle.com/xdb/acl.xsd">
            <ace>
            <grant>true</grant>
            <principal>ANONYMOUS</principal>
            <privilege>
            <dav:read/>
            </privilege>
            </ace>
            </acl>',
            'xmlns:a="http://xmlns.oracle.com/xdb/XDBResource.xsd" xmlns:b="http://xmlns.oracle.com/xdb/acl.xsd"') WHERE r.any_path = '/sys/acls/ro_anonymous_acl.xml';

            Cheers,
            Bill

            Edited by: Bill on Apr 9, 2009 10:18 AM
            • 18. Re: Always asking password for XDB user
              438121
              The script from Pravednik worked for me. I am running Oracle 11gR1 and APEX 3.1.2.00.02
              • 19. Re: Always asking password for XDB user
                TimLei
                I find the privilege changed to 'resolve'

                Then I granted 'dav:read' to ANONYMOUS

                this is works.

                Thanks all of above.

                Edited by: PPMonkey on Aug 13, 2009 7:13 PM
                • 20. Re: Always asking password for XDB user
                  884413
                  After a ton of troubleshooting - this is the ONLY setting that worked for me for the plsql gateway:

                  Modify the ACL to add 'dav:read' to ANONYMOUS !!!
                  • 21. Re: Always asking password for XDB user
                    TexasApexDeveloper
                    2 THINGS:

                    1) DO NOT POST NEW MESSAGES TO A THREAD THAT IS THIS OLD!!

                    2) Change your forum handle to something more friendly.. We are a sociable group here and like to know who we are talking to..

                    Thank you,

                    Tony Miller
                    Webster, TX

                    Time flies like the wind, but fruit flies like bananas.

                    If this question is answered, please mark the thread as closed and assign points where earned..
                    • 22. Re: Always asking password for XDB user
                      1004396
                      Hi,

                      I've tried some of the above, never forget to clean the browser history before any next try (I use Chrome). It works for me in Oracle XE 11g on Fedora.

                      Regards,

                      Eric Jansen.
                      1 2 Previous Next