1 2 Previous Next 23 Replies Latest reply: Feb 12, 2009 1:16 AM by 681850 RSS

    autoconfig is not running on appstier

    504825
      After doing cloning from multinode to single node
      getting error below


      [PROFILE PHASE]
      AutoConfig could not successfully execute the following scripts:
      Directory: /data3/applmgr/clonecomn/admin/install/CLONE_pramod
      afcmprf.sh INSTE8_PRF 1
      ahladmprf.sh INSTE8_PRF 1
      aradmprf.sh INSTE8_PRF 1
      bisadmprf.sh INSTE8_PRF 1
      AutoConfig is exiting with status 24

      For more information in Autoconfig log file

      ERROR:
      ORA-12154: TNS:could not resolve service name


      ERRORCODE = 1 ERRORCODE_END
      .end std out.
        • 1. Re: autoconfig is not running on appstier
          Hussein Sawwan-Oracle
          afcmprf.sh INSTE8_PRF 1
          ahladmprf.sh INSTE8_PRF 1
          aradmprf.sh INSTE8_PRF 1
          bisadmprf.sh INSTE8_PRF 1
          Looks like you have more than one issue here. So, please check AutoConfig log file for more details about each error.
          • 2. Re: autoconfig is not running on appstier
            504825
            in autoconfig log file the errors show below. the erros coming because of ORA-12154: TNS:could not resolve service name


            afcmprf.sh started at Mon Apr 14 18:16:46 IST 2008


            The environment settings are as follows ...

            ORACLE_HOME : /data3/applmgr/cloneora/8.0.6
            ORACLE_SID :
            TWO_TASK : CLONE
            PATH : /data3/applmgr/cloneora/iAS/Apache/perl/bin:/data3/applmgr/cloneora/8.0.6/bin:/data3/applmgr/cloneappl/fnd/11.5.0/bin:/data3/applmgr/cloneappl/ad/11.5.0/bin:/data3/applmgr/clonecomn/util/java/1.4/j2sdk1.4.2_04/bin:/data3/applmgr/clonecomn/util/unzip/unzip/unzip-5.50::/data3/applmgr/cloneora/8.0.6/bin:/usr/bin:/usr/ccs/bin:/usr/sbin:/data3/applmgr/cloneora/iAS/Apache/perl/bin:/data3/applmgr/cloneora/iAS/Apache/perl/bin:/data3/applmgr/cloneora/8.0.6/bin:/data3/applmgr/clonecomn/util/java/1.4/j2sdk1.4.2_04/bin:/data3/applmgr/clonecomn/util/unzip/unzip/unzip-5.50:/data3/applmgr/cloneora/8.0.6/bin:/usr/bin:/usr/ccs/bin:/usr/sbin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/data3/applmgr/bin
            LD_LIBRARY_PATH : /data3/applmgr/cloneora/8.0.6/network/jre11/lib/i686/native_threads:/data3/applmgr/cloneora/8.0.6/network/jre11/lib/linux/native_threads:/data3/applmgr/cloneappl/cz/11.5.0/bin:/data3/applmgr/cloneora/8.0.6/lib:/usr/X11R6/lib:/usr/openwin/lib

            Executable : /data3/applmgr/cloneora/8.0.6/bin/sqlplus


            SQL*Plus: Release 8.0.6.0.0 - Production on Mon Apr 14 18:16:46 2008

            (c) Copyright 1999 Oracle Corporation. All rights reserved.

            ERROR:
            ORA-12154: TNS:could not resolve service name


            ERRORCODE = 1 ERRORCODE_END
            .end std out.


            /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisadmprf.sh

            script returned:
            ****************************************************

            bisadmprf.sh started at Mon Apr 14 18:17:05 IST 2008

            Enter value for 3: ERROR:
            ORA-12154: TNS:could not resolve service name


            ERRORCODE = 1 ERRORCODE_END
            .end std out.
            • 3. Re: autoconfig is not running on appstier
              625827
              Your apps tier is not able to connect to db tier listener. Make sure database listener is up and running and you can do tnsping from apps tier to that listener. If that works autoconfig with work..

              Thanks
              Sundeep
              http://troubleshootingappsdba.blogspot.com
              • 4. Re: autoconfig is not running on appstier
                504825
                listener and db are running.. we are able to connect to the db directly.
                When autoconfig is run, initially itz able to connect to the db,but later itz throwing an error. Plz see the log file below for the error :


                Processing DriverFile = /data3/applmgr/cloneappl/ecx/11.5.0/admin/driver/ecxtmpl.drv
                AutoConfig Profile Phase
                Running Instantiation Drivers for ECX_TOP
                instantiate file:
                source : /data3/applmgr/cloneappl/ecx/11.5.0/admin/template/ecxadmprf.sql
                dest : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/ecxadmprf.sql
                backup : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/ecxadmprf.sql to /data3/applmgr/cloneappl/admin/CLONE_pramod/out/04141814/ecxadmprf.sql
                setting permissions: 600
                setting ownership: applmgr:dba
                instantiate file:
                source : /data3/applmgr/cloneappl/ecx/11.5.0/admin/template/ecxadmprf.sh
                dest : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/ecxadmprf.sh
                backup : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/ecxadmprf.sh to /data3/applmgr/cloneappl/admin/CLONE_pramod/out/04141814/ecxadmprf.sh
                setting permissions: 700
                setting ownership: applmgr:dba
                AutoConfig Profile Phase
                Running Profile Process 1 of 1 for ECX_TOP
                Executing script in InstantiateFile:
                /data3/applmgr/clonecomn/admin/install/CLONE_pramod/ecxadmprf.sh

                script returned:
                ****************************************************

                ecxadmprf.sh started at Mon Apr 14 18:17:03 IST 2008


                The environment settings are as follows ...

                ORACLE_HOME : /data3/applmgr/cloneora/8.0.6
                ORACLE_SID :
                TWO_TASK : CLONE
                PATH : /data3/applmgr/cloneora/iAS/Apache/perl/bin:/data3/applmgr/cloneora/8.0.6/bin:/data3/applmgr/cloneappl/fnd/11.5.0/bin:/data3/applmgr/cloneappl/ad/11.5.0/bin:/data3/applmgr/clonecomn/util/java/1.4/j2sdk1.4.2_04/bin:/data3/applmgr/clonecomn/util/unzip/unzip/unzip-5.50::/data3/applmgr/cloneora/8.0.6/bin:/usr/bin:/usr/ccs/bin:/usr/sbin:/data3/applmgr/cloneora/iAS/Apache/perl/bin:/data3/applmgr/cloneora/iAS/Apache/perl/bin:/data3/applmgr/cloneora/8.0.6/bin:/data3/applmgr/clonecomn/util/java/1.4/j2sdk1.4.2_04/bin:/data3/applmgr/clonecomn/util/unzip/unzip/unzip-5.50:/data3/applmgr/cloneora/8.0.6/bin:/usr/bin:/usr/ccs/bin:/usr/sbin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/data3/applmgr/bin
                LD_LIBRARY_PATH : /data3/applmgr/cloneora/8.0.6/network/jre11/lib/i686/native_threads:/data3/applmgr/cloneora/8.0.6/network/jre11/lib/linux/native_threads:/data3/applmgr/cloneappl/cz/11.5.0/bin:/data3/applmgr/cloneora/8.0.6/lib:/usr/X11R6/lib:/usr/openwin/lib

                Executable : /data3/applmgr/cloneora/8.0.6/bin/sqlplus


                SQL*Plus: Release 8.0.6.0.0 - Production on Mon Apr 14 18:17:03 2008

                (c) Copyright 1999 Oracle Corporation. All rights reserved.

                ecxadmprf.sh exiting with status 0
                ERRORCODE = 0 ERRORCODE_END
                .end std out.

                .end err out.
                ****************************************************


                Processing DriverFile = /data3/applmgr/cloneappl/bis/11.5.0/admin/driver/bistmpl.drv
                AutoConfig Profile Phase
                Running Instantiation Drivers for BIS_TOP

                instantiate file:
                source : /data3/applmgr/cloneappl/bis/11.5.0/admin/template/bisdblrp.sql
                dest : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisdblrp.sql
                backup : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisdblrp.sql to /data3/applmgr/cloneappl/admin/CLONE_pramod/out/04141814/bisdblrp.sql
                setting permissions: 600
                setting ownership: applmgr:dba
                instantiate file:
                source : /data3/applmgr/cloneappl/bis/11.5.0/admin/template/bisadmprf.sql
                dest : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisadmprf.sql
                backup : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisadmprf.sql to /data3/applmgr/cloneappl/admin/CLONE_pramod/out/04141814/bisadmprf.sql
                setting permissions: 600
                setting ownership: applmgr:dba
                instantiate file:
                source : /data3/applmgr/cloneappl/bis/11.5.0/admin/template/bisdblrp.sh
                dest : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisdblrp.sh
                backup : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisdblrp.sh to /data3/applmgr/cloneappl/admin/CLONE_pramod/out/04141814/bisdblrp.sh
                setting permissions: 700
                setting ownership: applmgr:dba
                instantiate file:
                source : /data3/applmgr/cloneappl/bis/11.5.0/admin/template/bisadmprf.sh
                dest : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisadmprf.sh
                backup : /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisadmprf.sh to /data3/applmgr/cloneappl/admin/CLONE_pramod/out/04141814/bisadmprf.sh
                setting permissions: 700
                setting ownership: applmgr:dba
                AutoConfig Profile Phase
                Running Profile Process 1 of 2 for BIS_TOP
                Executing script in InstantiateFile:
                /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisdblrp.sh

                script returned:
                ****************************************************
                bisdblrp.sh started at Mon Apr 14 18:17:04 IST 2008

                Enter value for 3: ERROR:
                ORA-12154: TNS:could not resolve service name


                Error returned while creating EDW database linksERRORCODE = 1 ERRORCODE_END
                .end std out.

                .end err out.
                ****************************************************


                AutoConfig Profile Phase
                Running Profile Process 2 of 2 for BIS_TOP
                Executing script in InstantiateFile:
                /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisadmprf.sh

                script returned:
                ****************************************************

                bisadmprf.sh started at Mon Apr 14 18:17:05 IST 2008

                Enter value for 3: ERROR:
                ORA-12154: TNS:could not resolve service name


                ERRORCODE = 1 ERRORCODE_END
                .end std out.

                .end err out.
                • 5. Re: autoconfig is not running on appstier
                  Fadi Hasweh
                  hi
                  plz run env file and issue sqlplus apps/apps@SID.

                  is it connecting
                  fadi
                  • 6. Re: autoconfig is not running on appstier
                    dba-india
                    Also check tns entries in tnsnames.ora file.
                    • 7. Re: autoconfig is not running on appstier
                      634039
                      i am continuing the thread instead of Hariprasad.

                      yes, i am able to connect apps/apps@sid...
                      tns entries are also correct.
                      • 8. Re: autoconfig is not running on appstier
                        Hussein Sawwan-Oracle
                        /data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisdblrp.sh
                        Could you please check if the "env_file" is set in this script?
                        • 9. Re: autoconfig is not running on appstier
                          634039
                          the env_file is set in data3/applmgr/clonecomn/admin/install/CLONE_pramod/bisdblrp.sh
                          • 10. Re: autoconfig is not running on appstier
                            Hussein Sawwan-Oracle
                            Uncomment the following, and run AutoConfig again. Please post the log file then:
                            ### printf "\nThe environment settings are as follows ...\n\n"
                            ### printf "       ORACLE_HOME : $ORACLE_HOME\n"
                            ### printf "        ORACLE_SID : $ORACLE_SID\n"
                            ### printf "          TWO_TASK : $TWO_TASK\n"
                            ### printf "              PATH : $PATH\n"
                            ### printf "   LD_LIBRARY_PATH : $LD_LIBRARY_PATH\n\n"
                            ### printf "Executable : `which sqlplus`\n\n"
                            • 11. Re: autoconfig is not running on appstier
                              634039
                              all those are uncommented....
                              • 12. Re: autoconfig is not running on appstier
                                Hussein Sawwan-Oracle
                                all those are uncommented....
                                Weird, since the above is not reported in the log file.

                                As applmgr user, source the env file and run the file manually, what does it return?
                                • 13. Re: autoconfig is not running on appstier
                                  634039
                                  hi,
                                  thanx..
                                  nw autoconfig is running successfully.
                                  bt ICM is not active.
                                  itz showing as below.

                                  [applmgr@pramod CLONE_pramod]$ ./adcmctl.sh status apps/apps

                                  You are running adcmctl.sh version 115.28

                                  Internal Concurrent Manager is Not Active at this time.

                                  adcmctl.sh: exiting with status 0

                                  How to make it active??
                                  • 14. Re: autoconfig is not running on appstier
                                    Hussein Sawwan-Oracle
                                    Check the CM log file for more details about the error.
                                    1 2 Previous Next