This discussion is archived
5 Replies Latest reply: Oct 8, 2013 11:49 PM by BhaviSavla RSS

Oracle Multimedia INVALID but no invalid objects...

441858 Newbie
Currently Being Moderated
Oracle 11g RHEL 4AS

Hi Guys,

I have been struggling with a problem. When I check the status of Multimedia I see it as invalid, but there are no invalid objects in the ORDSYS schema. Don't know what it could be.

SQL> select version, status from dba_registry where comp_id='ORDIM';

VERSION STATUS
------------------------------ -----------
11.1.0.6.0 INVALID



I have also tried the following:

SQL> call ordsys.validate_ordim();
call ordsys.validate_ordim()
*
ERROR at line 1:
ORA-06576: not a valid function or procedure name


So I checked:

SQL> select owner, object_name
from dba_objects
where object_name like 'VALIDATE%';


OWNER OBJECT_NAME
------------------------------ ----------------------------------------
SYS VALIDATE_APEX
SYS VALIDATE_WK
SYS VALIDATE_SDO
SYS VALIDATE_ORDIM
SYS VALIDATE_CONTEXT
SYS VALIDATE_ODM
SYS VALIDATE_RUL
SYS VALIDATE_EXF
SYS VALIDATE_OWM
WMSYS VALIDATE_OWM
ORDSYS VALIDATE_ORDIM_WITH_DETAILS

So I tried:

SQL> call sys.validate_ordim();

Call Completed.

SQL> select dbms_registry.status('ORDIM') from dual;

DBMS_REGISTRY.STATUS('ORDIM')
---------------------------------------------------------------
INVALID



Then I also tried the following per Metalink Note: 458228.1:

SQL> execute validate_ordim;

PL/SQL procedure successfully completed.

SQL> select version, status from dba_registry where comp_id='ORDIM';

VERSION STATUS
------------------------------ -----------
11.1.0.6.0 INVALID


I am running out of ideas. Anyone have a clue?

Thanks.