2 Replies Latest reply on Jul 5, 2008 1:24 PM by Sabdar Syed

    ALTER SESSION NS_LANG

    602082
      i need to set the NS_LANG parameter as AMERICAN_AMERICA.WE8MSWIN1252

      i tried using the command
      ALTER SESSION set NLS_LANG=AMERICAN_AMERICA.WE8MSWIN1252
      ALTER SESSION set NLS_LANG=AMERICAN_AMERICA_.WE8MSWIN1252

      But it didn't work out..can anyone help me please
        • 1. Re: ALTER SESSION NS_LANG
          Aman....
          Isn't it that NLS_LANG is an Environment variable and for the session its NLS_LANGUAGE?
          Also read this Faq about the same,
          http://www.oracle.com/technology/tech/globalization/htdocs/nls_lang%20faq.htm#_Toc110410550
          And this page about Alter session and NLS settings,
          http://download.oracle.com/docs/cd/B19306_01/server.102/b14200/statements_2012.htm#i2277774

          Aman....
          • 2. Re: ALTER SESSION NS_LANG
            Sabdar Syed
            NLS_LANG is an environment variable, i.e. which can't be at session level using ALTER SESSION.

            If you are on Windows, try as follows.

            C:\> set NLS_LANG=AMERICAN_AMERICA.WE8MSWIN1252

            On Unix/Linux:

            $ export NLS_LANG=AMERICAN_AMERICA.WE8MSWIN1252

            Other NLS Parameters can be set in the initialization parameter, As environment variables , and With the ALTER SESSION statement.

            Hope this helps.

            Regards,
            Sabdar Syed.