0 Replies Latest reply: Jul 23, 2008 11:26 AM by 508055 RSS

    Force OAS to use the correct version of JSP library - how?

    508055
      When trying to compile the first JSP, we get the following error on the OAS console:

      2008-07-23 11:48:56.417 NOTIFICATION J2EE JSP-0008 Unable to dispatch JSP Page
      : Exception:oracle.jsp.provider.JspCompileException:
      Errors compiling:D:\ora
      cle\product\oc4j_101310\j2ee\home\application-deployments\myapp\pers
      istence\_pages\_schema\_core\_views\_login.java
      cannot find symbol
      symbol : class VariableResolver

      Server Info: Oracle Containers for J2EE 10g (10.1.3.1.0)
      Java version: 1.5.0_15 Vendor: Sun Microsystems Inc
      OS: Windows 2003 Version: 5.2

      The class VariableResolver is in jsp-api.jar. I guess OAS is using different version of this JAR.
      How can I force OAS to use our version of this library?
      If I try to copy jsp-api.jar to jre\endorsed folder, OAS does not start.
      If I try to copy jsp-api.jar to WEB-INF\lib folder, it has no effect.