9 Replies Latest reply: Feb 16, 2009 3:03 AM by 680952 RSS

    ILM Assistant is not running

    652426
      Installed Oracle 10g and Oracle Application Express 3.1. Installed ILM Assistant files as per the installation guide. When tried to run ILMA as follows,
      'http://fiscbanda707450.fmr.com:7777/pls/apex/f?p=4550:1:93550923130323', with

      workspace->ilm_toolkit
      username->admin
      password->password

      not getting any details of ILMA. My http server is stopped and restarted, doesnt help.

      Kindly suggest.
      Regards,
      Uday
        • 1. Re: ILM Assistant is not running
          543302
          Hi Uday,

          The ILM Assistant cannot be run directly from the APEX development screens. To invoke ILMA, change your application id number in the URL:

          http://fiscbanda707450.fmr.com:7777/pls/apex/f?p=737677

          Thanks,

          Greg
          • 2. Re: ILM Assistant is not running
            652426
            Hello Greg,

            I am now hitting the following error,

            Expecting p_company or wwv_flow_company cookie to contain security group id of application owner.
            Error ERR-7620 Could not determine workspace for application (737677).
            OK

            I read about this error.

            My question is do we need to uninstall ilma and then

            sqlplus "sys/my_password@ORCLDB as sysdba"
            @ilma_install my_password ILM_ASSISTANT ORCLDB

            as suggested by you earlier in other thread?

            Regards,
            Uday
            • 3. Re: ILM Assistant is not running
              543302
              Hmmm ...

              I think re-installing ILMA would be a good next step. It only takes a few minutes to do.

              Let me know if this fixes the problem.

              Thanks,

              Greg
              • 4. Re: ILM Assistant is not running
                652426
                Hi Greg,
                I reinstalled ilma. The spool log says the installation is successful.

                @c:\ilm\ilma_install flows_030100 ilm-toolkit orcl
                @c:\ilm\ilma_post_install

                when I start ilma, I am getting 'database account' and 'password', I created a user oracomp with the appropriate privileges, but in vain. There is no login happening.
                Displays 'Error on page' with no detail.

                Kindly suggest.
                • 5. Re: ILM Assistant is not running
                  652426
                  Also when I ran post installation script, the message says, it could take several hours, but the procedure completed quite fast. Also, I restarted the http server after the completion.

                  Thanks,
                  Uday
                  • 6. Re: ILM Assistant is not running
                    543302
                    The post-installation script execution time depends on the number of metadata objects in your database. If you don't have 1000s of tables, then it will finish quickly.

                    Now, regarding the failure to run, I will have to do a little investigation. I will post another reply when I have something to report.

                    Thanks,

                    Greg
                    • 7. Re: ILM Assistant is not running
                      KLaker
                      Uday,

                      Can you see the ILM Workspace listed as an existing workspace via the APEX administration page? On my 10g environment I used the ADMIN account and APEX system installation password to access my APEX admin page, which for my instance called BEANS was like this:

                      http://klaker-uk.uk.oracle.com:7777/pls/beansapex/apex_admin

                      Then you can use the manage workspace option to check the details of the ILM application. This will allow you to see if the username you are entering for the main page is listed as being assigned to the ILM application. If your user is not listed as either a developer or user it is possible to use the admin tools to assign your user to the application. But if you need to add your user I would have expected an error message when you tried to login.


                      Make sure you are not blocking cookies via your browser as this will stop the ILM application from loading.

                      The other option is this might be related to bug 4244021, which you can view via Metalink. The bug relates to an incorrect configuration parameter with the HTTP server. In the files dads.conf, marvel.conf, wdbsvr.app there is a reference to a line which states:

                      PlsqlDocumentProcedure wwv_flow_file_mgr.process_download

                      this should read, according to the bug as follows:

                      PlsqlDocumentProcedure wwv_flow_file_manager.process_download


                      As usual when modifying configuration files, I would stop the HTTP Server, first then make backup copies of the files before changing them and restarting the HTTP Server

                      Hope this helps

                      Keith
                      • 8. Re: ILM Assistant is not running
                        652426
                        I modified the dasd.conf and everything started fine.

                        Q1. ILM Assistant is not supported via Oracle Support?
                        Q2. ILMA help is advising/alerting on the events, does it actually make it compress or partition at the database level?
                        • 9. Re: ILM Assistant is not running
                          680952
                          Information Lifecycle Management (ILM) is a set of policies and techniques for managing data during its lifetime. The ILM Assistant provides the information you need to manage your data from its initial creation through to deletion or lifetime retention. In this initial release the ILM Assistant generates scripts to perform tasks such as moving data onto a different storage tier. Fluke

                          Edited by: user10829913 on Feb 16, 2009 1:02 AM