This discussion is archived
4 Replies Latest reply: Aug 5, 2008 8:36 AM by KLaker RSS

ILM assistant XDB username and password not working

653584 Newbie
Currently Being Moderated
Hi All,

Hi I'm using ILM 1.3 with Oracle 11g on HP.

I am able to log-in to apex server but not ILM assistant.

http://dblxamd02.vxindia.veritas.com:8080/apex/apex_admin it works with admin/oracle.

But im not able to login to http://dblxamd02.vxindia.veritas.com:8080 when it asks for XDB username and password.

I tried to reset the password using apxxepwd.sql but not luck.

Did anybody observer this issue ? if so can somebody please reply me ASAP ?

Thanks in advance.
  • 1. Re: ILM assistant XDB username and password not working
    653584 Newbie
    Currently Being Moderated
    Ok I think the problem is with the installation itself.I havent checked the spool file of ilma_install.

    I found following errors in spool file
    .
    .

    User altered.

    ERROR:
    ORA-01017: invalid username/password; logon denied

    Does anybody tried to execute this script on 11g ?

    Thanks/-
    Manohar
  • 2. Re: ILM assistant XDB username and password not working
    KLaker Newbie
    Currently Being Moderated
    I have installed this correctly on my 11g Linux instance and it all works correctly.

    To access the ILM Assistant I use this URL:

    http://192.168.222.128:8080/apex/f?p=737677

    and login with either the user ILM or ILM_DEMO. The ILM_DEMO was created during the installation process and I manually added ILM afterwards following the steps in the documentation. One thing you need to watch out for is the passwords in 11g are now case sensitive and the error message you will get is:ORA-01741: illegal zero-length identifier

    Hope this helps

    Keith
  • 3. Re: ILM assistant XDB username and password not working
    653584 Newbie
    Currently Being Moderated
    Hi Keith,

    Thanks for you immediate response.Well in my case the following script does not execute successfully.

    Here is the output of @ilma_install.sql pune@11 users none.
    .
    .
    .
    User altered.

    ERROR:
    ORA-12154: TNS:could not resolve the connect identifier specified
  • 4. Re: ILM assistant XDB username and password not working
    KLaker Newbie
    Currently Being Moderated
    There are two wats to install the ILM toolkit:

    1) Directly on the server where your instance is located. In this case you do not need to provide a TNS connection name. Therefore, you would execute the script as follows:

    @ilma_install.sql pune

    2) Remotely from a client. In this case you do need to provide a connection string to your remote database instance. Therefore, you would execute the script as follows:

    @ilma_install.sql pune@11

    in this scenario the connection details are derived from your TNSNAMES.ORA file. If you have multiple Oracle products installed you have multiple copies of this file and it can be difficult to track down which file is being used. To point to a specific TNSNAMES.ORA I normally set three parameters:

    ORACLE_HOME - points to your 11g Client installation directory
    PATH - point this to the Oracle home containing SQLPlus, usually this is ORACLE_HOME/bin
    TNS_ADMIN = ORACLE_HOME/network/admin

    then make sure the TNSNAMES.ORA contains a reference to your identifier "11". You can test the connection by using the TNSPING utility that is part of the 11g client installation. The format for your instance would be:

    TNSPING 11

    this will tell you if you can connect to your instance. If there are any issues check the connection via the Net Configuration Assistant, or you can edit the TNSNAMES.ORA file directly via Notepad.

    Hope this helps

    Keith