1 2 3 4 Previous Next 45 Replies Latest reply: Apr 6, 2011 4:19 AM by 826457 RSS

    One way to fix the "Unable to load DLL (OraOps.dll)" error

    3004
      If run into the error "Unable to load DLL (OraOps.dll)", here is one of the common scenarios in which you would run into this problem and how you would solve it.


      Problem Description:

      Operating System: Windows 2000 or Windows XP
      Database: Oracle9i Release 2 Database or Client

      Windows OS authenticated users cannot read, write, nor execute programs in the ORACLE_HOME directory (e.g. d:\oracle\ora92\). This prevents authenticated users and applications from accessing the Oracle database or software.


      Solution Description:
      Follow these steps to restore default access to Read and Execute access for Windows authenticated users:

      1. Log on to Windows with administrator privileges.
      2. Launch Windows Explorer from the Start Menu.
      3. Navigate to the ORACLE_HOME directory and right click on the ORACLE_HOME folder icon.
      4. Select the "Properties" option from the drop down list. A "Properties" window should appear.
      5. Click on the "Security" tab on the "Properties" window.
      6. Click on Autheticated Users in the "Name" list.
      7. Uncheck the "Read and Execute" box in the "Permissions" list. This box will be under the "Allow" column.
      8. Check the "Read and Execute" box. This is the box you just unchecked.
      9. Click the "Apply" button.
      10. Click the "OK" button.
        • 1. re:One way to fix the
          305606
          No help for me :-( I even format HDD and install everything new, no result, still the same error. This error appear only in ASP.NET application, when I use ODP in console app, everything is OK. What can I do?

          HlR
          • 2. re:One way to fix the
            319945
            Thanks, this worked for me. I had to uncheck the Read and Execute then apply and wait for a few minutes before I rechecked the box and hit apply again for it to work.
            • 3. re:One way to fix the
              170794

              Quote :
              "Click on the "Security" tab on the "Properties" window. "



              There is no Security tab in Window XP !!!!!!!


              how to do that ?
              • 4. re:One way to fix the
                10275
                First, your hard drive must be formatted NTFS for this tab to show up.

                Second, if you're running XP Pro, you must open Windows Explorer, go to Tools, Folder Options, View and uncheck Use Simple File Sharing.

                Third, if you're running XP Home, Simple File Sharing is enforced by default and cannot be disabled. You must boot the computer into Safe Mode and log in with the Administrator account, in order to see the Security tab.
                • 5. re:One way to fix the
                  7101
                  This fix does not seem to correct the problem for WebApplications.

                  I have a Windows-app and a Web-app with the same code, the windows-app connects to Oracle without any problems. But when trying to Oracle with the web-app I get one of the two errors:

                  1)
                  An unhandled exception of type 'System.NullReferenceException' occurred in oracle.dataaccess.dll
                  Additional information: Object reference not set to an instance of an object.

                  2)
                  {"Unable to load DLL (OraOps.dll)." }     System.Exception
                  • 6. re:One way to fix the
                    170397
                    It doesn't work for me either - we still have to have the aspnet_wp to run as SYSTEM, which is not acceptable in production for us.

                    Bob
                    • 7. Re: One way to fix the "Unable to load DLL (OraOps.dll)" error
                      390491
                      I have just fixed this problem on my Windows XP machine.

                      At first I applied the new permissions to the ora92 directory, this did not work because it was in a directory that the authenticated user had no access to.

                      I updated this directory with the above permissions.

                      Also when you update your permissions you should ensure that the "replace permission entries on all child objects with entries shown here that apply to child objects" check box is ticked.

                      • 8. Re: One way to fix the "Unable to load DLL (OraOps.dll)" error
                        385610
                        Why don't you try to give necessary rights specifically to ASPNET account.

                        I guess this will solve the problem.
                        • 9. Re: One way to fix the "Unable to load DLL (OraOps.dll)" error
                          430109
                          This works. BUT I needed to do a reboot after all the security changes as described above. In fact I just added ASP.NET with read & exceute permission on c:\oracle\ora92 directory which is my ORACLE_HOME. But after that unchekcing and checking of that read&exceute permission it did not work for me until I rebooted as one forum suggested. Hope this will help others. Now it works for me.
                          • 10. Re: One way to fix the "Unable to load DLL (OraOps.dll)" error
                            446688
                            I'm running Oracle 10g client with Visual Studio .NET and I have IIS running on my machine. I'm trying to compile a web project that used 9i ODP.NET in the past and worked fine. Now I have 10g ODP.NET and I get the following error:

                            Unable to load DLL (OraOps10.dll).
                            Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

                            Exception Details: System.DllNotFoundException: Unable to load DLL (OraOps10.dll).


                            Now I've been through everything I can possibly think of. my 10g [OracleHome]/bin directory is located in the Path. And I have taken READ&EXECUTE permissions from that oracle home 10g directory for authenticated users and then put the rights back. Then i rebooted and still got the error. I even went so far as to put 'everyone' on the directory and give them read and execute permissions and I still get the error. I'm running Windows 2000. If anyone has any idea as to what i could be doing wrong, I would appreciate it.
                            • 12. Re: One way to fix the "Unable to load DLL (OraOps.dll)" error
                              Alex.Keh .Product.Manager-Oracle
                              You probably need to set the Policy.9.2.Oracle.DataAccess.dll to redirect your 9.2 ODP.NET application to use 10g.
                              • 13. Re: One way to fix the "Unable to load DLL (OraOps.dll)" error
                                439143
                                Hi Alex. How are you doing? :-) I have a quick question. Is there a way to get the policy file into place after installing the client? Here is what I did:

                                1) Installed Oracle Developer Tools for VS.NET 10.1.0.4. This includes ODP.NET 10.1.0.4. There was no policy file installed into the GAC, since I didn't have an older version of Oracle on the machine (or maybe because it's only included in the ODAC install).

                                2) Installed the Oracle 10g database. This added ODP.NET 10.1.0.2 to the GAC.

                                3) Now my apps want to use the older one instead of the newer one.

                                I think my options are to re-install everything in a different order, or to write my own policy file from scratch, but is there any way to get it from somewhere?

                                -- Matt
                                • 14. Re: One way to fix the "Unable to load DLL (OraOps.dll)" error
                                  449521
                                  Just like the other posts mentioned - Simply changing permissions didnt do it. I had to restart my box for this problem to go away.
                                  1 2 3 4 Previous Next