2 Replies Latest reply: Aug 27, 2008 3:21 PM by Madrid RSS

    ORA-15000: command disallowed by current instance type

    656553
      Connect to the ASM instance on the standby host, and create a directory within the DATA disk group that has the same name as the DB_UNIQUE_NAME of the physical standby database.


      [oracle@standby ~]$ ORACLE_SID=ASM
      [oracle@standby ~]$ sqlplus /nolog

      SQL*Plus: Release 10.2.0.1.0 - Production on 星期六 8月 16 20:52:35 2008

      Copyright (c) 1982, 2005, Oracle. All rights reserved.

      SQL> conn /as sysdba
      Connected to an idle instance.
      SQL> conn sys/sys@standby as sysdba
      Connected.
      SQL> ALTER DISKGROUP dg add directory '+dg1/pgy';
      ALTER DISKGROUP dg add directory '+dg1/pgy'
      *
      ERROR at line 1:
      ORA-15000: command disallowed by current instance type
        • 1. Re: ORA-15000: command disallowed by current instance type
          Paul M.
          $ oerr ora 15000
          15000, 00000, "command disallowed by current instance type"
          // *Cause:  The user has issued a command to a conventional RDBMS instance
          //          that is only appropriate for an ASM instance. Alternatively, the
          //          user has issued a command to an ASM instance that is only
          //          appropriate for an RDBMS instance.
          // *Action: Connect to the correct instance type and re-issue the command.
          //
          $ 
          SQL> conn sys/sys@standby as sysdba
          Most probably standby connection string connects you to standby database, not to ASM instance.

          ORACLE_SID=ASM
          shouldn't it be ORACLE_SID=+ASM ?

          SQL> ALTER DISKGROUP dg add directory *'+dg1/pgy'*;
          is this correct ?
          • 2. Re: ORA-15000: command disallowed by current instance type
            Madrid
            This error code is shown when you try to issue a command against the wrong instance type. For instance, if you try to open an ASM instance, or if you try to issue an ASM command against a non started ASM instance, which it looks to be the case.

            Try to start the ASM instance first, you will be required to manually mount the disk groups only if the disk group parameter doesn't declare which DG will be automatically started.


            ~ Madrid
            http://hrivera99.blogspot.com