1 Reply Latest reply: Aug 28, 2008 4:58 PM by charliemays RSS

    Problems advertising SALT services

    charliemays
      Hello my friends,
      After I do all steps for importing a wsdl service and boot the GWWS server my service is not advertised

      From Tuxedo log I get the following extract:
      LIBTUX_CAT:262: INFO: Standard main starting
      INFO: BEA SALT, Version 2.0, 32-bit, Patch Level (none)
      |- Loading Service Pattern "aVeryLongNameForATuxedoService"
      |  |- WARN:WSCFG_CAT:139: Pattern "aVeryLongNameForATuxedoService" does not exist in Metadata Repository
      WSCFG_CAT:33: INFO: Get configuration for GWWS <GWWS_INST1> successful.
      GWWS_CAT:19: INFO: GWWS started.
      ...{code}
      I call tmunloadrepos on my metadata repository and I get the following extract:
      {code:java}service=aVeryLongNameForATuxedoService
      servicetype=service
      export=Y
      inbuf=FML32
      outbuf=FML32
      tuxservice=aVeryLongNameFo
      errbuf=FML32
      servicemode=webservice
      ...{code}
      So the service it does exists in metadata repository... 
      
      I already verify my field tables looking for params with the same name but I don't find any.
      I don't think it has to do with a 15+ chars service name, because I have another GWWS instance with another metadata repository, which has a service with less than 15 chars and presents the same problem.
      
      I don't get it.... I'm missing something here??
      Any help will be appreciated